diff --git a/.accel-config.checksum b/.accel-config.checksum
index 15ac99d239ccde583699a8da43b6290a0d37171d..cf594da5adbb3a549cdfd17218e31bbd21ee443e 100644
--- a/.accel-config.checksum
+++ b/.accel-config.checksum
@@ -1 +1 @@
-4b3939555ec0da9be1a77a89aef294d379ddba221338d94a5c9eabb30586cc13
+ba48e50fd7c92b4e12f037c1814ff48657e8231ee495c22d7c5277fad721176e
diff --git a/.accel-config.metadata b/.accel-config.metadata
index 72ad88e2fdcac8aeb79d1518de352e35038ca65d..f4e59275455b7abdd43655ba636debf85a1ad5ef 100644
--- a/.accel-config.metadata
+++ b/.accel-config.metadata
@@ -1 +1 @@
-1202a495cbb630264cabcb6e35801c4070f1f5b5c8cc1e3a16976a35c5950980 SOURCES/accel-config-v3.5.3.tar.gz
+ec40c19349b104154000d8aa65c7993392cec4932e5b9040ce82fc4e9f9cb4a5 SOURCES/accel-config-v4.1.3.tar.gz
diff --git a/SOURCES/0001-accel-config-test-only-configure-ats_disable-if-supp.patch b/SOURCES/0001-accel-config-test-only-configure-ats_disable-if-supp.patch
new file mode 100644
index 0000000000000000000000000000000000000000..fca77b2e339a696cd0d2f8ba16ab92c84924c99b
--- /dev/null
+++ b/SOURCES/0001-accel-config-test-only-configure-ats_disable-if-supp.patch
@@ -0,0 +1,54 @@
+From bcc6e90baa61434568e8225a7fcdc070610dae46 Mon Sep 17 00:00:00 2001
+From: Jerry Snitselaar <jsnitsel@redhat.com>
+Date: Thu, 30 Nov 2023 14:58:06 -0700
+Subject: [PATCH] accel-config/test: only configure ats_disable if supported
+'Content-type: text/plain'
+
+Upstream Status: RHEL-only
+
+Don't try to configure ats_disable if it isn't supported.
+Temporary work around until there is a complete upstream
+solution, and we don't ship the testing bits just use
+them for test.
+
+Signed-off-by: Jerry Snitselaar <jsnitsel@redhat.com>
+---
+ test/libaccfg.c | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/test/libaccfg.c b/test/libaccfg.c
+index bfe277b996cf..4a580b2bb02e 100644
+--- a/test/libaccfg.c
++++ b/test/libaccfg.c
+@@ -240,7 +240,9 @@ static int config_wq(struct accfg_ctx *ctx, struct accfg_device *device,
+ 	if (wq_param->threshold)
+ 		SET_ERR(rc, accfg_wq_set_threshold(wq, wq_param->threshold));
+ 
+-	SET_ERR(rc, accfg_wq_set_ats_disable(wq, wq_param->ats_disable));
++	if (accfg_wq_get_ats_disable(wq) >= 0) {
++		SET_ERR(rc, accfg_wq_set_ats_disable(wq, wq_param->ats_disable));
++	}
+ 	/* Don't fail test if per wq ats disable is not supported */
+ 	if (rc == -EOPNOTSUPP)
+ 		rc = 0;
+@@ -251,6 +253,7 @@ static int config_wq(struct accfg_ctx *ctx, struct accfg_device *device,
+ static int check_wq(struct accfg_ctx *ctx, struct accfg_device *device,
+ 		struct accfg_wq *wq, struct wq_parameters *wq_param)
+ {
++	int ats_disable = 0;
+ 
+ 	if (wq_param->wq_size != accfg_wq_get_size(wq)) {
+ 		fprintf(stderr, "%s failed on wq_size\n", __func__);
+@@ -290,7 +293,8 @@ static int check_wq(struct accfg_ctx *ctx, struct accfg_device *device,
+ 		fprintf(stderr, "%s failed on wq name\n", __func__);
+ 		return -EINVAL;
+ 	}
+-	if (wq_param->ats_disable != accfg_wq_get_ats_disable(wq)) {
++	ats_disable = accfg_wq_get_ats_disable(wq);
++	if (ats_disable >= 0 && (wq_param->ats_disable != ats_disable)) {
+ 		fprintf(stderr, "%s failed on ats_disable\n", __func__);
+ 		return -EINVAL;
+ 	}
+-- 
+2.41.0
+
diff --git a/SPECS/accel-config.spec b/SPECS/accel-config.spec
index 270945f466e3e6ac87d3463ec4e35962950d7c70..867cad967afb3a70559d7ca0bd3f04994dc8067c 100644
--- a/SPECS/accel-config.spec
+++ b/SPECS/accel-config.spec
@@ -1,15 +1,13 @@
 %global	project_name	idxd-config
 
 Name:		accel-config
-Version:	3.5.3
+Version:	4.1.3
 Release:	2%{?dist}
 Summary:	Configure accelerator subsystem devices
-# The entire source code is under GPLv2 except for accel-config
-# library which is mostly LGPLv2.1, ccan/list which is BSD-MIT and
-# the rest of ccan which is CC0.
-License:	GPLv2 and LGPLv2+ and MIT and CC0
+License:	GPL-2.0-only
 URL:		https://github.com/intel/%{project_name}
 Source0:	%{URL}/archive/%{name}-v%{version}.tar.gz
+Patch0:		0001-accel-config-test-only-configure-ats_disable-if-supp.patch
 
 Requires:	%{name}-libs%{?_isa} = %{version}-%{release}
 BuildRequires:	gcc
@@ -18,6 +16,7 @@ BuildRequires:	asciidoc
 BuildRequires:	xmlto
 BuildRequires:	automake
 BuildRequires:	libtool
+BuildRequires:  openssl-devel
 BuildRequires:	pkgconfig
 BuildRequires:	pkgconfig(libkmod)
 BuildRequires:	pkgconfig(uuid)
@@ -36,7 +35,7 @@ Utility library for configuring the accelerator subsystem.
 
 %package devel
 Summary:	Development files for libaccfg
-License:	LGPLv2+
+License:	LGPL-2.1-only
 Requires:	%{name}-libs%{?_isa} = %{version}-%{release}
 
 %description devel
@@ -46,9 +45,7 @@ developing applications that use %{name}.
 
 %package libs
 Summary:	Configuration library for accelerator subsystem devices
-# All source code of configuration library is LGPLv2.1, except
-# ccan/list which is BSD-MIT and the rest of ccan/ which is CC0.
-License:	LGPLv2+ and MIT and CC0
+License:	LGPL-2.1-only
 Requires:	%{name}%{?_isa} = %{version}-%{release}
 
 %description libs
@@ -56,7 +53,7 @@ Libraries for %{name}.
 
 %package test
 Summary:        Tests for accel-config
-License:        GPLv2
+License:        GPL-2.0-only
 Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
 
 %description test
@@ -103,6 +100,15 @@ make check
 %{_libexecdir}/accel-config/test/*
 
 %changelog
+* Wed Jan 17 2024 Jerry Snitselaar <jsnitsel@redhat.com> - 4.1.3-2
+- Fix SPDX tags
+Resolves: RHEL-15610
+
+* Fri Dec 01 2023 Jerry Snitselaar <jsnitsel@redhat.com> - 4.1.3-1
+- Rebase to 4.1.3 release
+- Update License tags to SPDX identifiers
+Resolves: RHEL-15610
+
 * Tue Apr 18 2023 Jerry Snitselaar <jsnitsel@redhat.com> - 3.5.3-2
 - Remove spec file variable that blocked debuginfo build
 Resolves: rhz#2153899