diff --git a/SOURCES/0001-data-don-t-send-change-updates-for-login-history.patch b/SOURCES/0001-data-don-t-send-change-updates-for-login-history.patch
new file mode 100644
index 0000000000000000000000000000000000000000..56489a9c0ce893b28a1a87b2818425276607b256
--- /dev/null
+++ b/SOURCES/0001-data-don-t-send-change-updates-for-login-history.patch
@@ -0,0 +1,88 @@
+From b4f85d66280affcb52e998661f782c2ab4f806a7 Mon Sep 17 00:00:00 2001
+From: Ray Strode <rstrode@redhat.com>
+Date: Thu, 9 May 2019 14:58:34 -0400
+Subject: [PATCH] data: don't send change updates for login-history
+
+The login-history property of user objects can be quite large.
+If wtmp is changed frequently, that can lead to memory fragmentation
+in clients.
+
+Furthermore, most clients never check login-history, so it's
+wasted memory and wasted cpu.
+
+This commit disables change notification for that property.  If
+a client really needs to get updates, they can manually refresh
+their cache when appropriate.
+---
+ data/org.freedesktop.Accounts.User.xml | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/data/org.freedesktop.Accounts.User.xml b/data/org.freedesktop.Accounts.User.xml
+index 8d3fe1c..3b839a3 100644
+--- a/data/org.freedesktop.Accounts.User.xml
++++ b/data/org.freedesktop.Accounts.User.xml
+@@ -785,60 +785,61 @@
+     <doc:doc>
+       <doc:description>
+         <doc:para>
+           The users location.
+         </doc:para>
+       </doc:description>
+     </doc:doc>
+   </property>
+ 
+   <property name="LoginFrequency" type="t" access="read">
+     <doc:doc>
+       <doc:description>
+         <doc:para>
+           How often the user has logged in.
+         </doc:para>
+       </doc:description>
+     </doc:doc>
+   </property>
+ 
+   <property name="LoginTime" type="x" access="read">
+     <doc:doc>
+       <doc:description>
+         <doc:para>
+           The last login time.
+         </doc:para>
+       </doc:description>
+     </doc:doc>
+   </property>
+ 
+   <property name="LoginHistory" type="a(xxa{sv})" access="read">
++    <annotation name="org.freedesktop.DBus.Property.EmitsChangedSignal" value="false"/>
+     <doc:doc>
+       <doc:description>
+         <doc:para>
+           The login history for this user.
+           Each entry in the array represents a login session. The first two
+           members are the login time and logout time, as timestamps (seconds since the epoch). If the session is still running, the logout time
+           is 0.
+         </doc:para>
+         <doc:para>
+           The a{sv} member is a dictionary containing additional information
+           about the session. Possible members include 'type' (with values like ':0', 'tty0', 'pts/0' etc).
+         </doc:para>
+       </doc:description>
+     </doc:doc>
+   </property>
+ 
+   <property name="IconFile" type="s" access="read">
+     <doc:doc>
+       <doc:description>
+         <doc:para>
+            The filename of a png file containing the users icon.
+         </doc:para>
+       </doc:description>
+     </doc:doc>
+   </property>
+ 
+   <property name="Saved" type="b" access="read">
+     <doc:doc>
+       <doc:description>
+         <doc:para>
+-- 
+2.21.0
+
diff --git a/SPECS/accountsservice.spec b/SPECS/accountsservice.spec
index e15866d3866a831e275f6f929b734b245e13f38d..fcbb382fa77b9f22686b0e7630a71a2cc347fd52 100644
--- a/SPECS/accountsservice.spec
+++ b/SPECS/accountsservice.spec
@@ -2,7 +2,7 @@
 
 Name:           accountsservice
 Version:        0.6.50
-Release:        6%{?dist}
+Release:        7%{?dist}
 Summary:        D-Bus interfaces for querying and manipulating user account information
 License:        GPLv3+
 URL:            https://www.freedesktop.org/wiki/Software/AccountsService/
@@ -26,6 +26,8 @@ Patch10:        0001-daemon-Fix-warnings-about-type-punning.patch
 
 Patch20:        0001-lib-don-t-set-loaded-state-until-seat-is-fetched.patch
 
+Patch30:        0001-data-don-t-send-change-updates-for-login-history.patch
+
 Patch90:        0001-lib-save-os-when-creating-user.patch
 
 Requires:       polkit
@@ -111,6 +113,10 @@ rm $RPM_BUILD_ROOT%{_libdir}/*.a
 %{_datadir}/gtk-doc/html/libaccountsservice/*
 
 %changelog
+* Mon Jun 17 2019 Ray Strode <rstrode@redhat.com> - 0.6.50-7
+- Don't send change updates for login history changes
+  Resolves: #1713080
+
 * Mon Nov 26 2018 Ray Strode <rstrode@redhat.com> - 0.6.50-6
 - Fix user switching before screen lock
   Resolves: #1653263