diff --git a/SPECS/boost.spec b/SPECS/boost.spec
index 1c1baf49ac656a7d18c22d27a2bec383e8bfebc8..cce55db32c9dd1afeda90388ab0e277b2c71e518 100644
--- a/SPECS/boost.spec
+++ b/SPECS/boost.spec
@@ -42,7 +42,7 @@ Name: boost
 %global real_name boost
 Summary: The free peer-reviewed portable C++ source libraries
 Version: 1.75.0
-Release: 6%{?dist}
+Release: 8%{?dist}
 License: Boost and MIT and Python
 
 # Replace each . with _ in %%{version}
@@ -54,7 +54,7 @@ License: Boost and MIT and Python
 %global toplev_dirname %{real_name}_%{version_enc}
 URL: http://www.boost.org
 
-Source0: https://dl.bintray.com/boostorg/release/%{version}/source/%{name}_%%{version_enc}.tar.bz2
+Source0: https://dl.bintray.com/boostorg/release/%{version}/source/%{name}_%{version_enc}.tar.bz2
 Source1: libboost_thread.so
 # Add a manual page for b2, based on the online documentation:
 # http://www.boost.org/boost-build2/doc/html/bbv2/overview.html
@@ -114,6 +114,7 @@ BuildRequires: libstdc++-devel
 BuildRequires: bzip2-devel
 BuildRequires: zlib-devel
 BuildRequires: xz-devel
+BuildRequires: libzstd-devel
 %if %{with python3}
 BuildRequires: python3-devel
 BuildRequires: python3-numpy
@@ -220,6 +221,9 @@ provides a sort of cooperative multitasking on a single thread.
 
 %package coroutine
 Summary: Run-time component of boost coroutine library
+Requires: %{name}-chrono%{?_isa} = %{version}-%{release}
+Requires: %{name}-context%{?_isa} = %{version}-%{release}
+Requires: %{name}-thread%{?_isa} = %{version}-%{release}
 
 %description coroutine
 Run-time support for Boost.Coroutine, a library that provides
@@ -239,6 +243,8 @@ on generic programming concepts.
 %if %{with context}
 %package fiber
 Summary: Run-time component of boost fiber library
+Requires: %{name}-context%{?_isa} = %{version}-%{release}
+Requires: %{name}-filesystem%{?_isa} = %{version}-%{release}
 
 %description fiber
 
@@ -276,6 +282,7 @@ stream buffers and i/o filters.
 
 %package json
 Summary: Run-time component of boost json library
+Requires: %{name}-container%{?_isa} = %{version}-%{release}
 
 %description json
 
@@ -296,6 +303,11 @@ handling tools.
 
 %package log
 Summary: Run-time component of boost logging library
+Requires: %{name}-atomic%{?_isa} = %{version}-%{release}
+Requires: %{name}-chrono%{?_isa} = %{version}-%{release}
+Requires: %{name}-filesystem%{?_isa} = %{version}-%{release}
+Requires: %{name}-regex%{?_isa} = %{version}-%{release}
+Requires: %{name}-thread%{?_isa} = %{version}-%{release}
 
 %description log
 
@@ -429,6 +441,7 @@ with as little as one #include and one additional line of code.
 Summary: Run-time component of boost type erasure library
 Requires: %{name}-chrono%{?_isa} = %{version}-%{release}
 Requires: %{name}-system%{?_isa} = %{version}-%{release}
+Requires: %{name}-thread%{?_isa} = %{version}-%{release}
 
 %description type_erasure
 
@@ -459,15 +472,10 @@ Requires: libquadmath-devel%{?_isa}
 %if %{with python3}
 # Require boost-numpy3 here, because main boost metapackage only Recommends: it
 Requires: %{name}-numpy3%{?_isa} = %{version}-%{release}
-# Added for F33, remove for F35:
-Obsoletes: %{name}-python3-devel < 1.69.0-20
+# Old Provides: for compatibility with RHEL <= 8 and packages that require it.
 Provides: %{name}-python3-devel = %{version}-%{release}
 Provides: %{name}-python3-devel%{?_isa} = %{version}-%{release}
 %endif
-# Added for F33, remove for F35:
-Obsoletes: boost-nowide-devel <= 0.20190814
-Provides: boost-nowide-devel = %{version}
-Provides: boost-nowide-devel%{?_isa} = %{version}
 
 %description devel
 Headers and shared object symbolic links for the Boost C++ libraries.
@@ -654,10 +662,6 @@ Tools for working with Boost documentation in BoostBook or QuickBook format.
 
 %package b2
 Summary: A low-level build tool
-# Added for F33, remove for F35:
-Obsoletes: boost-jam < 1.73.0
-Provides: boost-jam = %{version}
-Provides: boost-jam%{?_isa} = %{version}
 
 %description b2
 B2 (formerly Boost.Jam) is the low-level build engine tool for Boost.Build.
@@ -1278,6 +1282,13 @@ fi
 %{_mandir}/man1/b2.1*
 
 %changelog
+* Fri Jun 24 2022 Jonathan Wakely <jwakely@redhat.com> - 1.75.0-8
+- Restore Provides for boost-python3-devel
+
+* Tue Jun 21 2022 Jonathan Wakely <jwakely@redhat.com> - 1.75.0-7
+- Build with zstd support (#2091041)
+- Fix rpminspect CI warnings about missing versioned dependencies
+
 * Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.75.0-6
 - Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
   Related: rhbz#1991688