diff --git a/SOURCES/grubby-bls b/SOURCES/grubby-bls
index 01167077b24850428da19ac5800b1d6766301ac0..1e8901ce67ce89a733caf3680692f251436a5620 100755
--- a/SOURCES/grubby-bls
+++ b/SOURCES/grubby-bls
@@ -595,17 +595,19 @@ remove_var_prefix() {
 
 update_grubcfg()
 {
-    # Older ppc64le OPAL firmware don't have BLS support so grub2-mkconfig has to be run
-    # to generate a config with menuentry commands.
-    if [ "${arch}" = "ppc64le" ] && [ -d /sys/firmware/opal ]; then
+    # Turn on RUN_MKCONFIG on different archs/scenarios
+    if [[ "${arch}" = 's390' ]] || [[ "${arch}" = 's390x' ]]; then
+        # On s390/s390x systems, run mkconfig/zipl
         RUN_MKCONFIG="true"
-    fi
-
-    # PV and PVH Xen DomU guests boot with pygrub that doesn't have BLS support,
-    # also Xen Dom0 use the menuentries from 20_linux_xen and not the ones from
-    # 10_linux. So grub2-mkconfig has to run for both Xen Dom0 and DomU.
-    if [[ -e /sys/hypervisor/type ]] && grep -q "^xen$" /sys/hypervisor/type; then
+    elif [[ "${arch}" = "ppc64le" ]] && [[ -d /sys/firmware/opal ]]; then
+        # Older ppc64le OPAL firmware don't have BLS support so grub2-mkconfig has to be run
+        # to generate a config with menuentry commands.
+        RUN_MKCONFIG="true"
+    elif [[ -e /sys/hypervisor/type ]] && grep -q "^xen$" /sys/hypervisor/type; then
         if [ ! -e /sys/hypervisor/guest_type ] || ! grep -q "^HVM$" /sys/hypervisor/guest_type; then
+            # PV and PVH Xen DomU guests boot with pygrub that doesn't have BLS support,
+            # also Xen Dom0 use the menuentries from 20_linux_xen and not the ones from
+            # 10_linux. So grub2-mkconfig has to run for both Xen Dom0 and DomU.
             RUN_MKCONFIG=true
         fi
     fi
diff --git a/SPECS/grubby.spec b/SPECS/grubby.spec
index 4c92a5aeb9c1d86f1ea3ffd0114e43d43de3da49..684bd8f58f4353b57993645e72862f471be02498 100644
--- a/SPECS/grubby.spec
+++ b/SPECS/grubby.spec
@@ -3,7 +3,7 @@
 
 Name:                 grubby
 Version:              8.40
-Release:              80%{?dist}
+Release:              81%{?dist}
 Summary:              Command line tool for updating bootloader configs
 License:              GPL-2.0-or-later
 Source1:              grubby-bls
@@ -75,9 +75,14 @@ fi
 %{_mandir}/man8/grubby.8*
 
 %changelog
-* Fri Jan 10 2025 Release Engineering <releng@rockylinux.org> - 8.40-80
+* Thu Mar 20 2025 Release Engineering <releng@rockylinux.org> - 8.40-81
 - Add riscv64 device tree support
 
+* Thu Mar 20 2025 Leo Sandoval <lsandova@redhat.com> - 8.40-81
+- grubby-bls: in s390* systems, run zipl on grub cfg update event
+  Fixes previous commit and formats better the conditions that trigger grub cfg updates
+  Resolves: #RHEL-36092
+
 * Fri Dec 06 2024 Leo Sandoval <lsandova@redhat.com> - 8.40-80
 - grubby-bls: on PPC systems, remove petiboot's version checks
   Resolves: #RHEL-70194