From 2bafc66f1ac448afae69a282446173f9fc00f0af Mon Sep 17 00:00:00 2001
From: Peridot Bot <rockyautomation@rockylinux.org>
Date: Thu, 20 Mar 2025 18:42:09 +0000
Subject: [PATCH] import grubby-8.40-81.el10

---
 SOURCES/grubby-bls | 20 +++++++++++---------
 SPECS/grubby.spec  |  9 +++++++--
 2 files changed, 18 insertions(+), 11 deletions(-)

diff --git a/SOURCES/grubby-bls b/SOURCES/grubby-bls
index 0116707..1e8901c 100755
--- a/SOURCES/grubby-bls
+++ b/SOURCES/grubby-bls
@@ -595,17 +595,19 @@ remove_var_prefix() {
 
 update_grubcfg()
 {
-    # Older ppc64le OPAL firmware don't have BLS support so grub2-mkconfig has to be run
-    # to generate a config with menuentry commands.
-    if [ "${arch}" = "ppc64le" ] && [ -d /sys/firmware/opal ]; then
+    # Turn on RUN_MKCONFIG on different archs/scenarios
+    if [[ "${arch}" = 's390' ]] || [[ "${arch}" = 's390x' ]]; then
+        # On s390/s390x systems, run mkconfig/zipl
         RUN_MKCONFIG="true"
-    fi
-
-    # PV and PVH Xen DomU guests boot with pygrub that doesn't have BLS support,
-    # also Xen Dom0 use the menuentries from 20_linux_xen and not the ones from
-    # 10_linux. So grub2-mkconfig has to run for both Xen Dom0 and DomU.
-    if [[ -e /sys/hypervisor/type ]] && grep -q "^xen$" /sys/hypervisor/type; then
+    elif [[ "${arch}" = "ppc64le" ]] && [[ -d /sys/firmware/opal ]]; then
+        # Older ppc64le OPAL firmware don't have BLS support so grub2-mkconfig has to be run
+        # to generate a config with menuentry commands.
+        RUN_MKCONFIG="true"
+    elif [[ -e /sys/hypervisor/type ]] && grep -q "^xen$" /sys/hypervisor/type; then
         if [ ! -e /sys/hypervisor/guest_type ] || ! grep -q "^HVM$" /sys/hypervisor/guest_type; then
+            # PV and PVH Xen DomU guests boot with pygrub that doesn't have BLS support,
+            # also Xen Dom0 use the menuentries from 20_linux_xen and not the ones from
+            # 10_linux. So grub2-mkconfig has to run for both Xen Dom0 and DomU.
             RUN_MKCONFIG=true
         fi
     fi
diff --git a/SPECS/grubby.spec b/SPECS/grubby.spec
index 4c92a5a..684bd8f 100644
--- a/SPECS/grubby.spec
+++ b/SPECS/grubby.spec
@@ -3,7 +3,7 @@
 
 Name:                 grubby
 Version:              8.40
-Release:              80%{?dist}
+Release:              81%{?dist}
 Summary:              Command line tool for updating bootloader configs
 License:              GPL-2.0-or-later
 Source1:              grubby-bls
@@ -75,9 +75,14 @@ fi
 %{_mandir}/man8/grubby.8*
 
 %changelog
-* Fri Jan 10 2025 Release Engineering <releng@rockylinux.org> - 8.40-80
+* Thu Mar 20 2025 Release Engineering <releng@rockylinux.org> - 8.40-81
 - Add riscv64 device tree support
 
+* Thu Mar 20 2025 Leo Sandoval <lsandova@redhat.com> - 8.40-81
+- grubby-bls: in s390* systems, run zipl on grub cfg update event
+  Fixes previous commit and formats better the conditions that trigger grub cfg updates
+  Resolves: #RHEL-36092
+
 * Fri Dec 06 2024 Leo Sandoval <lsandova@redhat.com> - 8.40-80
 - grubby-bls: on PPC systems, remove petiboot's version checks
   Resolves: #RHEL-70194
-- 
GitLab