diff --git a/.grubby.checksum b/.grubby.checksum
new file mode 100644
index 0000000000000000000000000000000000000000..aaa54cdce7a3a4914ef25fab1b95057e5d560c96
--- /dev/null
+++ b/.grubby.checksum
@@ -0,0 +1 @@
+cf243444b0a597051b63da2c3fc86a89d6e187549f0765edd2129ba8ab48f48c
diff --git a/.grubby.metadata b/.grubby.metadata
index 6085fc6e49c2fa76ad7d602c12f84fdc84d87e7a..e6061b76470cac822d3b26bb594591e589fe2d75 100644
--- a/.grubby.metadata
+++ b/.grubby.metadata
@@ -1 +1 @@
-97ae8d113b74538c05f05083dcff4f44012fd0cd SOURCES/8.40-1.tar.gz
+85f1c678484f74c8978e8643451594967defce463a86c35cb1ee56d12767a9df SOURCES/8.40-1.tar.gz
diff --git a/SOURCES/grubby-bls b/SOURCES/grubby-bls
index 360c6e81067599db8340609460eb9224810b4f3d..07df5c87627c2da885793c7856487007f7ceb9fa 100755
--- a/SOURCES/grubby-bls
+++ b/SOURCES/grubby-bls
@@ -500,7 +500,7 @@ update_bls_fragment() {
             if [[ -n $old_args ]]; then
                 opts="$(update_args "${old_args}" "${remove_args}" "${add_args}")"
                 opts="$(echo "$opts" | sed -e 's/\//\\\//g')"
-                sed -i -e "s/^GRUB_CMDLINE_LINUX.*/GRUB_CMDLINE_LINUX=\\\"${opts}\\\"/" "${grub_etc_default}"
+                sed -i -e "s/^GRUB_CMDLINE_LINUX=.*/GRUB_CMDLINE_LINUX=\\\"${opts}\\\"/" "${grub_etc_default}"
             fi
         fi
 
@@ -812,7 +812,9 @@ if [[ -n $kernel ]]; then
 	    opts="${opts} ${args}"
 	fi
     else
-	opts="${args}"
+	opts="${opts} ${args}"
+	remove_args="$kernelopts"
+	update_args "${opts}" "${remove_args}" ""
     fi
 
     add_bls_fragment "${kernel}" "${title}" "${opts}" "${initrd}" \
diff --git a/SPECS/grubby.spec b/SPECS/grubby.spec
index e8aef0ede292f9934fdf7295fef2d0a0ea6e72af..878b99dd6e7ee583157072444007997b94feed52 100644
--- a/SPECS/grubby.spec
+++ b/SPECS/grubby.spec
@@ -1,6 +1,6 @@
 Name: grubby
 Version: 8.40
-Release: 47%{?dist}
+Release: 49%{?dist}
 Summary: Command line tool for updating BootLoaderSpec files
 License: GPLv2+
 URL: https://github.com/rhinstaller/grubby
@@ -169,6 +169,14 @@ current boot environment.
 %{_mandir}/man8/*.8*
 
 %changelog
+* Wed Jan 10 2024 Marta Lewandowska <mlewando@redhat.com> - 8.40-49
+- Do not overwrite all vars that start with GRUB_CMDLINE_LINUX
+- Resolves: #RHEL-12853
+
+* Tue Feb 21 2023 Marta Lewandowska <mlewando@redhat.com> - 8.40-48
+- Apply Marta's default args fix
+- Resolves: #1900829
+
 * Mon Oct 10 2022 Robbie Harwood <rharwood@redhat.com> - 8.40-47
 - Backport fedora/rhel9 initial cmdline population
 - Resolves: #2129740