diff --git a/SOURCES/grubby-bls b/SOURCES/grubby-bls
index 5b428a0b0be93531638be514e6e7de8f6d6df8e5..1a89d80a5c233afa2af0d51d43d8e5c2938a0550 100755
--- a/SOURCES/grubby-bls
+++ b/SOURCES/grubby-bls
@@ -235,7 +235,7 @@ get_bls_args() {
     local opts=(${args})
 
     for opt in ${opts[*]}; do
-        if [[ $opt =~ ^\$ ]]; then
+        if [[ $opt = "\$kernelopts" ]]; then
             value="$(expand_var $opt)"
             args="$(echo ${args} | sed -e "s/${opt}/${value}/")"
         fi
diff --git a/SPECS/grubby.spec b/SPECS/grubby.spec
index e26c6b1b56515283289b1f4c2e8f59134b62fbd5..aeeeb6f6ca9e8cc377c56e1479d18c44fd1b3e1b 100644
--- a/SPECS/grubby.spec
+++ b/SPECS/grubby.spec
@@ -1,6 +1,6 @@
 Name: grubby
 Version: 8.40
-Release: 41%{?dist}
+Release: 42%{?dist}
 Summary: Command line tool for updating BootLoaderSpec files
 License: GPLv2+
 URL: https://github.com/rhinstaller/grubby
@@ -169,6 +169,10 @@ current boot environment.
 %{_mandir}/man8/*.8*
 
 %changelog
+* Wed Jun 09 2021 Javier Martinez Canillas <javierm@redhat.com> - 8.40-42
+- grubby-bls: expand only the kernelopts variable
+  Resolves: rhbz#1819666
+
 * Thu May 07 2020 Javier Martinez Canillas <javierm@redhat.com> - 8.40-41
 - grubby-bls: only attempt to update the cmdline if was already set
   Related: rhbz#1152027