diff --git a/.python3.11.metadata b/.python3.11.metadata
index 019ffb6091d8b6c7d7d621fea02453d9ea61bbea..6856768d3f3fd6cadf40c9088e1ba18106dad437 100644
--- a/.python3.11.metadata
+++ b/.python3.11.metadata
@@ -1,2 +1,2 @@
-18e1aa7e66ff3a58423d59ed22815a6954e53342122c45df20c96877c062b9b7 SOURCES/Python-3.11.7.tar.xz
+9b1e896523fc510691126c864406d9360a3d1e986acbda59cda57b5abda45b87 SOURCES/Python-3.11.9.tar.xz
 fb28243ffeb9725b14b60586a9a123682a89604c025b7a9d4bcdeb67078203c6 SOURCES/pgp_keys.asc
diff --git a/SOURCES/00329-fips.patch b/SOURCES/00329-fips.patch
index 256d214e657edec760b93d9db87a23b61e69c172..e2935117bbcabd6a642b1cccc2bc3249e6e2ca43 100644
--- a/SOURCES/00329-fips.patch
+++ b/SOURCES/00329-fips.patch
@@ -1,4 +1,4 @@
-From ecc5137120f471c22ff6dcb1bd128561c31e023c Mon Sep 17 00:00:00 2001
+From 929f90dc647114675317ed1ab65511003d9daebc Mon Sep 17 00:00:00 2001
 From: Charalampos Stratakis <cstratak@redhat.com>
 Date: Thu, 12 Dec 2019 16:58:31 +0100
 Subject: [PATCH 1/7] Expose blake2b and blake2s hashes from OpenSSL
@@ -205,10 +205,10 @@ index 5d84f4a..011026a 100644
 -/*[clinic end generated code: output=69f2374071bff707 input=a9049054013a1b77]*/
 +/*[clinic end generated code: output=c6a9af5563972eda input=a9049054013a1b77]*/
 -- 
-2.43.0
+2.44.0
 
 
-From 0198d467525e79cb4be4418708719af3eaee7a40 Mon Sep 17 00:00:00 2001
+From a0a19a8057c0b674000e921766e39684f92f4cd8 Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <pviktori@redhat.com>
 Date: Thu, 1 Aug 2019 17:57:05 +0200
 Subject: [PATCH 2/7] Use a stronger hash in multiprocessing handshake
@@ -220,7 +220,7 @@ https://bugs.python.org/issue17258
  1 file changed, 6 insertions(+), 2 deletions(-)
 
 diff --git a/Lib/multiprocessing/connection.py b/Lib/multiprocessing/connection.py
-index 8b81f99..69c0b7e 100644
+index 59c61d2..7fc594e 100644
 --- a/Lib/multiprocessing/connection.py
 +++ b/Lib/multiprocessing/connection.py
 @@ -43,6 +43,10 @@ BUFSIZE = 8192
@@ -234,7 +234,7 @@ index 8b81f99..69c0b7e 100644
  _mmap_counter = itertools.count()
  
  default_family = 'AF_INET'
-@@ -752,7 +756,7 @@ def deliver_challenge(connection, authkey):
+@@ -753,7 +757,7 @@ def deliver_challenge(connection, authkey):
              "Authkey must be bytes, not {0!s}".format(type(authkey)))
      message = os.urandom(MESSAGE_LENGTH)
      connection.send_bytes(CHALLENGE + message)
@@ -243,7 +243,7 @@ index 8b81f99..69c0b7e 100644
      response = connection.recv_bytes(256)        # reject large message
      if response == digest:
          connection.send_bytes(WELCOME)
-@@ -768,7 +772,7 @@ def answer_challenge(connection, authkey):
+@@ -769,7 +773,7 @@ def answer_challenge(connection, authkey):
      message = connection.recv_bytes(256)         # reject large message
      assert message[:len(CHALLENGE)] == CHALLENGE, 'message = %r' % message
      message = message[len(CHALLENGE):]
@@ -253,10 +253,10 @@ index 8b81f99..69c0b7e 100644
      response = connection.recv_bytes(256)        # reject large message
      if response != WELCOME:
 -- 
-2.43.0
+2.44.0
 
 
-From a7822e2e1f21529e9730885bd8c9c6ab7c704d5b Mon Sep 17 00:00:00 2001
+From a6ec352e5f2c38ccbd4ca3beffbd39e8a350319e Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <pviktori@redhat.com>
 Date: Thu, 25 Jul 2019 17:19:06 +0200
 Subject: [PATCH 3/7] Disable Python's hash implementations in FIPS mode,
@@ -446,10 +446,10 @@ index 56ae7a5..45fb403 100644
 +    if (_Py_hashlib_fips_error(exc, name)) return NULL; \
 +} while (0)
 diff --git a/configure.ac b/configure.ac
-index 52d5c1f..56aff78 100644
+index 7b4000f..8e2f0ad 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -7069,7 +7069,8 @@ PY_STDLIB_MOD([_sha512], [test "$with_builtin_sha512" = yes])
+@@ -7070,7 +7070,8 @@ PY_STDLIB_MOD([_sha512], [test "$with_builtin_sha512" = yes])
  PY_STDLIB_MOD([_sha3], [test "$with_builtin_sha3" = yes])
  PY_STDLIB_MOD([_blake2],
    [test "$with_builtin_blake2" = yes], [],
@@ -460,10 +460,10 @@ index 52d5c1f..56aff78 100644
  PY_STDLIB_MOD([_crypt],
    [], [test "$ac_cv_crypt_crypt" = yes],
 -- 
-2.43.0
+2.44.0
 
 
-From e9ce6d33544559172dbebbe0c0dfba2757c62331 Mon Sep 17 00:00:00 2001
+From 3a52b3f1ee7735913584ced6440b4241c9d8104d Mon Sep 17 00:00:00 2001
 From: Charalampos Stratakis <cstratak@redhat.com>
 Date: Fri, 29 Jan 2021 14:16:21 +0100
 Subject: [PATCH 4/7] Use python's fall back crypto implementations only if we
@@ -623,10 +623,10 @@ index 01d12f5..a7cdb07 100644
      def test_pbkdf2_hmac_py(self):
          with warnings_helper.check_warnings():
 -- 
-2.43.0
+2.44.0
 
 
-From 641c617775b6973ed84711a2602ba190fe064474 Mon Sep 17 00:00:00 2001
+From f64047f079725f4a4985edc5532a8a24035040ad Mon Sep 17 00:00:00 2001
 From: Charalampos Stratakis <cstratak@redhat.com>
 Date: Wed, 31 Jul 2019 15:43:43 +0200
 Subject: [PATCH 5/7] Test equivalence of hashes for the various digests with
@@ -783,21 +783,21 @@ index a7cdb07..c071f28 100644
  class KDFTests(unittest.TestCase):
  
 -- 
-2.43.0
+2.44.0
 
 
-From a706c8342f0f9307d44c43c203702e1476fe73b4 Mon Sep 17 00:00:00 2001
+From d769d1de3fc7fdb9e5f8164108f130301639889a Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <pviktori@redhat.com>
 Date: Mon, 26 Aug 2019 19:39:48 +0200
 Subject: [PATCH 6/7] Guard against Python HMAC in FIPS mode
 
 ---
- Lib/hmac.py           | 13 +++++++++----
+ Lib/hmac.py           | 12 +++++++++---
  Lib/test/test_hmac.py | 10 ++++++++++
- 2 files changed, 19 insertions(+), 4 deletions(-)
+ 2 files changed, 19 insertions(+), 3 deletions(-)
 
 diff --git a/Lib/hmac.py b/Lib/hmac.py
-index 8b4f920..20ef96c 100644
+index 8b4eb2f..8930bda 100644
 --- a/Lib/hmac.py
 +++ b/Lib/hmac.py
 @@ -16,8 +16,9 @@ else:
@@ -812,16 +812,9 @@ index 8b4f920..20ef96c 100644
  
  # The size of the digests returned by HMAC depends on the underlying
  # hashing module used.  Use digest_size from the instance of HMAC instead.
-@@ -48,17 +49,18 @@ class HMAC:
-                    msg argument.  Passing it as a keyword argument is
-                    recommended, though not required for legacy API reasons.
-         """
--
-         if not isinstance(key, (bytes, bytearray)):
-             raise TypeError("key: expected bytes or bytearray, but got %r" % type(key).__name__)
- 
+@@ -55,10 +56,12 @@ class HMAC:
          if not digestmod:
-             raise TypeError("Missing required parameter 'digestmod'.")
+             raise TypeError("Missing required argument 'digestmod'.")
  
 -        if _hashopenssl and isinstance(digestmod, (str, _functype)):
 +        if _hashopenssl.get_fips_mode() or (_hashopenssl and isinstance(digestmod, (str, _functype))):
@@ -833,7 +826,7 @@ index 8b4f920..20ef96c 100644
                  self._init_old(key, msg, digestmod)
          else:
              self._init_old(key, msg, digestmod)
-@@ -69,6 +71,9 @@ class HMAC:
+@@ -69,6 +72,9 @@ class HMAC:
          self.block_size = self._hmac.block_size
  
      def _init_old(self, key, msg, digestmod):
@@ -844,7 +837,7 @@ index 8b4f920..20ef96c 100644
              digest_cons = digestmod
          elif isinstance(digestmod, str):
 diff --git a/Lib/test/test_hmac.py b/Lib/test/test_hmac.py
-index a39a2c4..0742a1c 100644
+index 1502fba..e40ca4b 100644
 --- a/Lib/test/test_hmac.py
 +++ b/Lib/test/test_hmac.py
 @@ -5,6 +5,7 @@ import hashlib
@@ -883,7 +876,7 @@ index a39a2c4..0742a1c 100644
      @unittest.skipUnless(sha256_module is not None, 'need _sha256')
      def test_with_sha256_module(self):
          h = hmac.HMAC(b"key", b"hash this!", digestmod=sha256_module.sha256)
-@@ -481,6 +489,7 @@ class SanityTestCase(unittest.TestCase):
+@@ -489,6 +497,7 @@ class UpdateTestCase(unittest.TestCase):
  
  class CopyTestCase(unittest.TestCase):
  
@@ -891,7 +884,7 @@ index a39a2c4..0742a1c 100644
      @hashlib_helper.requires_hashdigest('sha256')
      def test_attributes_old(self):
          # Testing if attributes are of same type.
-@@ -492,6 +501,7 @@ class CopyTestCase(unittest.TestCase):
+@@ -500,6 +509,7 @@ class CopyTestCase(unittest.TestCase):
          self.assertEqual(type(h1._outer), type(h2._outer),
              "Types of outer don't match.")
  
@@ -900,10 +893,10 @@ index a39a2c4..0742a1c 100644
      def test_realcopy_old(self):
          # Testing if the copy method created a real copy.
 -- 
-2.43.0
+2.44.0
 
 
-From 03f1dedfe5d29af20fb3686d76b045384d41d8dd Mon Sep 17 00:00:00 2001
+From 142e0b03f8cbfbfbeb58c54e45fc51f1ff4a903e Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <encukou@gmail.com>
 Date: Wed, 25 Aug 2021 16:44:43 +0200
 Subject: [PATCH 7/7] Disable hash-based PYCs in FIPS mode
@@ -946,10 +939,10 @@ index db52725..5fca65e 100644
          return PycInvalidationMode.CHECKED_HASH
      else:
 diff --git a/Lib/test/support/__init__.py b/Lib/test/support/__init__.py
-index dc7a6e6..646b328 100644
+index 059542c..152bb91 100644
 --- a/Lib/test/support/__init__.py
 +++ b/Lib/test/support/__init__.py
-@@ -2203,6 +2203,20 @@ def sleeping_retry(timeout, err_msg=None, /,
+@@ -2204,6 +2204,20 @@ def sleeping_retry(timeout, err_msg=None, /,
          delay = min(delay * 2, max_delay)
  
  
@@ -1020,10 +1013,10 @@ index 9cd92ad..4ec29a1 100644
          with open(pyc, 'rb') as fp:
              data = fp.read()
 diff --git a/Lib/test/test_imp.py b/Lib/test/test_imp.py
-index 4062afd..6bc276d 100644
+index aa67cc3..594a1b5 100644
 --- a/Lib/test/test_imp.py
 +++ b/Lib/test/test_imp.py
-@@ -352,6 +352,7 @@ class ImportTests(unittest.TestCase):
+@@ -355,6 +355,7 @@ class ImportTests(unittest.TestCase):
          import _frozen_importlib
          self.assertEqual(_frozen_importlib.__spec__.origin, "frozen")
  
@@ -1031,7 +1024,7 @@ index 4062afd..6bc276d 100644
      def test_source_hash(self):
          self.assertEqual(_imp.source_hash(42, b'hi'), b'\xfb\xd9G\x05\xaf$\x9b~')
          self.assertEqual(_imp.source_hash(43, b'hi'), b'\xd0/\x87C\xccC\xff\xe2')
-@@ -371,6 +372,7 @@ class ImportTests(unittest.TestCase):
+@@ -374,6 +375,7 @@ class ImportTests(unittest.TestCase):
              res = script_helper.assert_python_ok(*args)
              self.assertEqual(res.out.strip().decode('utf-8'), expected)
  
@@ -1092,7 +1085,7 @@ index 378dcbe..7b223a1 100644
          with util.create_modules('_temp') as mapping:
              bc_path = self.manipulate_bytecode(
 diff --git a/Lib/test/test_py_compile.py b/Lib/test/test_py_compile.py
-index 9b420d2..dd6460a 100644
+index 7f24abe..229ffb9 100644
 --- a/Lib/test/test_py_compile.py
 +++ b/Lib/test/test_py_compile.py
 @@ -143,13 +143,16 @@ class PyCompileTestsBase:
@@ -1154,7 +1147,7 @@ index 59a5200..81fadb3 100644
      def test_checked_hash_based_change_pyc(self):
          source = b"state = 'old'"
 diff --git a/Python/import.c b/Python/import.c
-index 39144d3..b439059 100644
+index c4e2145..e19e42e 100644
 --- a/Python/import.c
 +++ b/Python/import.c
 @@ -2449,6 +2449,26 @@ static PyObject *
@@ -1185,5 +1178,5 @@ index 39144d3..b439059 100644
          uint64_t x;
          char data[sizeof(uint64_t)];
 -- 
-2.43.0
+2.44.0
 
diff --git a/SOURCES/00397-tarfile-filter.patch b/SOURCES/00397-tarfile-filter.patch
index 3c4ebf41bf15466a659253b4caf20b0a4f509aee..bae08fa5990aecbc6966a43c03401bffbab08562 100644
--- a/SOURCES/00397-tarfile-filter.patch
+++ b/SOURCES/00397-tarfile-filter.patch
@@ -1,4 +1,4 @@
-From 8b70605b594b3831331a9340ba764ff751871612 Mon Sep 17 00:00:00 2001
+From 0181d677dd7fd11bc19a211b3eb735ac3ad3d7fb Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <encukou@gmail.com>
 Date: Mon, 6 Mar 2023 17:24:24 +0100
 Subject: [PATCH] CVE-2007-4559, PEP-706: Add filters for tarfile extraction
@@ -9,11 +9,11 @@ variable and config file.
 ---
  Lib/tarfile.py           |  42 +++++++++++++
  Lib/test/test_shutil.py  |   3 +-
- Lib/test/test_tarfile.py | 128 ++++++++++++++++++++++++++++++++++++++-
- 3 files changed, 169 insertions(+), 4 deletions(-)
+ Lib/test/test_tarfile.py | 127 ++++++++++++++++++++++++++++++++++++++-
+ 3 files changed, 168 insertions(+), 4 deletions(-)
 
 diff --git a/Lib/tarfile.py b/Lib/tarfile.py
-index 130b5e0..3b7d8d5 100755
+index 612217b..dc59fc6 100755
 --- a/Lib/tarfile.py
 +++ b/Lib/tarfile.py
 @@ -72,6 +72,13 @@ __all__ = ["TarFile", "TarInfo", "is_tarfile", "TarError", "ReadError",
@@ -30,7 +30,7 @@ index 130b5e0..3b7d8d5 100755
  
  #---------------------------------------------------------
  # tar constants
-@@ -2211,6 +2218,41 @@ class TarFile(object):
+@@ -2219,6 +2226,41 @@ class TarFile(object):
          if filter is None:
              filter = self.extraction_filter
              if filter is None:
@@ -73,10 +73,10 @@ index 130b5e0..3b7d8d5 100755
              if isinstance(filter, str):
                  raise TypeError(
 diff --git a/Lib/test/test_shutil.py b/Lib/test/test_shutil.py
-index 9bf4145..f247b82 100644
+index 6728d30..2338b63 100644
 --- a/Lib/test/test_shutil.py
 +++ b/Lib/test/test_shutil.py
-@@ -1665,7 +1665,8 @@ class TestArchives(BaseTest, unittest.TestCase):
+@@ -1774,7 +1774,8 @@ class TestArchives(BaseTest, unittest.TestCase):
      def check_unpack_tarball(self, format):
          self.check_unpack_archive(format, filter='fully_trusted')
          self.check_unpack_archive(format, filter='data')
@@ -87,10 +87,10 @@ index 9bf4145..f247b82 100644
  
      def test_unpack_archive_tar(self):
 diff --git a/Lib/test/test_tarfile.py b/Lib/test/test_tarfile.py
-index cdea033..4724285 100644
+index 389da7b..5a43f9d 100644
 --- a/Lib/test/test_tarfile.py
 +++ b/Lib/test/test_tarfile.py
-@@ -2,7 +2,7 @@ import sys
+@@ -3,7 +3,7 @@ import sys
  import os
  import io
  from hashlib import sha256
@@ -99,7 +99,7 @@ index cdea033..4724285 100644
  from random import Random
  import pathlib
  import shutil
-@@ -2999,7 +2999,11 @@ class NoneInfoExtractTests(ReadTest):
+@@ -3049,7 +3049,11 @@ class NoneInfoExtractTests(ReadTest):
          tar = tarfile.open(tarname, mode='r', encoding="iso8859-1")
          cls.control_dir = pathlib.Path(TEMPDIR) / "extractall_ctrl"
          tar.errorlevel = 0
@@ -112,7 +112,7 @@ index cdea033..4724285 100644
          tar.close()
          cls.control_paths = set(
              p.relative_to(cls.control_dir)
-@@ -3674,7 +3678,8 @@ class TestExtractionFilters(unittest.TestCase):
+@@ -3868,7 +3872,8 @@ class TestExtractionFilters(unittest.TestCase):
          """Ensure the default filter does not warn (like in 3.12)"""
          with ArchiveMaker() as arc:
              arc.add('foo')
@@ -122,10 +122,10 @@ index cdea033..4724285 100644
              with self.check_context(arc.open(), None):
                  self.expect_file('foo')
  
-@@ -3844,6 +3849,123 @@ class TestExtractionFilters(unittest.TestCase):
+@@ -4037,6 +4042,122 @@ class TestExtractionFilters(unittest.TestCase):
+         with self.check_context(arc.open(errorlevel='boo!'), filtererror_filter):
              self.expect_exception(TypeError)  # errorlevel is not int
  
- 
 +    @contextmanager
 +    def rh_config_context(self, config_lines=None):
 +        """Set up for testing various ways of overriding the default filter
@@ -242,10 +242,9 @@ index cdea033..4724285 100644
 +            ):
 +                self.check_trusted_default(tar, tempdir)
 +
-+
- def setUpModule():
-     os_helper.unlink(TEMPDIR)
-     os.makedirs(TEMPDIR)
+ 
+ class OverwriteTests(archiver_tests.OverwriteTests, unittest.TestCase):
+     testdir = os.path.join(TEMPDIR, "testoverwrite")
 -- 
-2.41.0
+2.44.0
 
diff --git a/SOURCES/00415-cve-2023-27043-gh-102988-reject-malformed-addresses-in-email-parseaddr-111116.patch b/SOURCES/00415-cve-2023-27043-gh-102988-reject-malformed-addresses-in-email-parseaddr-111116.patch
index 73bf9b76d06f56fe1ddcc46a5240e819c18553c1..b29388f16f4ce83e35433cec885ccef6bd13a73b 100644
--- a/SOURCES/00415-cve-2023-27043-gh-102988-reject-malformed-addresses-in-email-parseaddr-111116.patch
+++ b/SOURCES/00415-cve-2023-27043-gh-102988-reject-malformed-addresses-in-email-parseaddr-111116.patch
@@ -1,4 +1,4 @@
-From d8b0fafb202bf884135a3f7f0ce0b086217a2da2 Mon Sep 17 00:00:00 2001
+From 642f28679e04c7b4ec7731f0c8872103f21a76f8 Mon Sep 17 00:00:00 2001
 From: Victor Stinner <vstinner@python.org>
 Date: Fri, 15 Dec 2023 16:10:40 +0100
 Subject: [PATCH 1/2] 00415: [CVE-2023-27043] gh-102988: Reject malformed
@@ -12,10 +12,10 @@ Thomas Dwyer.
 Co-Authored-By: Thomas Dwyer <github@tomd.tel>
 ---
  Doc/library/email.utils.rst                   |  19 +-
- Lib/email/utils.py                            | 151 ++++++++++++-
+ Lib/email/utils.py                            | 150 ++++++++++++-
  Lib/test/test_email/test_email.py             | 204 +++++++++++++++++-
  ...-10-20-15-28-08.gh-issue-102988.dStNO7.rst |   8 +
- 4 files changed, 361 insertions(+), 21 deletions(-)
+ 4 files changed, 360 insertions(+), 21 deletions(-)
  create mode 100644 Misc/NEWS.d/next/Library/2023-10-20-15-28-08.gh-issue-102988.dStNO7.rst
 
 diff --git a/Doc/library/email.utils.rst b/Doc/library/email.utils.rst
@@ -72,18 +72,10 @@ index 0e266b6..6723dc4 100644
  .. function:: parsedate(date)
  
 diff --git a/Lib/email/utils.py b/Lib/email/utils.py
-index cfdfeb3..9522341 100644
+index 8993858..41bb3c9 100644
 --- a/Lib/email/utils.py
 +++ b/Lib/email/utils.py
-@@ -48,6 +48,7 @@ TICK = "'"
- specialsre = re.compile(r'[][\\()<>@,:;".]')
- escapesre = re.compile(r'[\\"]')
- 
-+
- def _has_surrogates(s):
-     """Return True if s contains surrogate-escaped binary data."""
-     # This check is based on the fact that unless there are surrogates, utf8
-@@ -106,12 +107,127 @@ def formataddr(pair, charset='utf-8'):
+@@ -106,12 +106,127 @@ def formataddr(pair, charset='utf-8'):
      return address
  
  
@@ -125,12 +117,7 @@ index cfdfeb3..9522341 100644
 +        result.append(addr[start:])
 +
 +    return ''.join(result)
- 
--def getaddresses(fieldvalues):
--    """Return a list of (REALNAME, EMAIL) for each fieldvalue."""
--    all = COMMASPACE.join(str(v) for v in fieldvalues)
--    a = _AddressList(all)
--    return a.addresslist
++
 +
 +supports_strict_parsing = True
 +
@@ -139,7 +126,12 @@ index cfdfeb3..9522341 100644
 +
 +    When parsing fails for a fieldvalue, a 2-tuple of ('', '') is returned in
 +    its place.
-+
+ 
+-def getaddresses(fieldvalues):
+-    """Return a list of (REALNAME, EMAIL) for each fieldvalue."""
+-    all = COMMASPACE.join(str(v) for v in fieldvalues)
+-    a = _AddressList(all)
+-    return a.addresslist
 +    If strict is true, use a strict parser which rejects malformed inputs.
 +    """
 +
@@ -216,7 +208,7 @@ index cfdfeb3..9522341 100644
  
  
  def _format_timetuple_and_zone(timetuple, zone):
-@@ -205,16 +321,33 @@ def parsedate_to_datetime(data):
+@@ -205,16 +320,33 @@ def parsedate_to_datetime(data):
              tzinfo=datetime.timezone(datetime.timedelta(seconds=tz)))
  
  
@@ -255,7 +247,7 @@ index cfdfeb3..9522341 100644
  
  
 diff --git a/Lib/test/test_email/test_email.py b/Lib/test/test_email/test_email.py
-index 677f209..20b6779 100644
+index 785696e..ad60ed3 100644
 --- a/Lib/test/test_email/test_email.py
 +++ b/Lib/test/test_email/test_email.py
 @@ -17,6 +17,7 @@ from unittest.mock import patch
@@ -266,7 +258,7 @@ index 677f209..20b6779 100644
  
  from email.charset import Charset
  from email.generator import Generator, DecodedGenerator, BytesGenerator
-@@ -3321,15 +3322,154 @@ Foo
+@@ -3336,15 +3337,154 @@ Foo
             [('Al Person', 'aperson@dom.ain'),
              ('Bud Person', 'bperson@dom.ain')])
  
@@ -429,7 +421,7 @@ index 677f209..20b6779 100644
  
      def test_getaddresses_embedded_comment(self):
          """Test proper handling of a nested comment"""
-@@ -3520,6 +3660,54 @@ multipart/report
+@@ -3535,6 +3675,54 @@ multipart/report
                  m = cls(*constructor, policy=email.policy.default)
                  self.assertIs(m.policy, email.policy.default)
  
@@ -499,10 +491,10 @@ index 0000000..3d0e9e4
 +if the *strict* paramater is available. Patch by Thomas Dwyer and Victor
 +Stinner to improve the CVE-2023-27043 fix.
 -- 
-2.43.0
+2.44.0
 
 
-From 6c34f5b95da90bd494e29776c0e807af44689fae Mon Sep 17 00:00:00 2001
+From d371679e7c485551c10380ac11e5039a9fb4515b Mon Sep 17 00:00:00 2001
 From: Lumir Balhar <lbalhar@redhat.com>
 Date: Wed, 10 Jan 2024 08:53:53 +0100
 Subject: [PATCH 2/2] Make it possible to disable strict parsing in email
@@ -510,9 +502,9 @@ Subject: [PATCH 2/2] Make it possible to disable strict parsing in email
 
 ---
  Doc/library/email.utils.rst       | 26 +++++++++++
- Lib/email/utils.py                | 54 +++++++++++++++++++++-
+ Lib/email/utils.py                | 55 ++++++++++++++++++++++-
  Lib/test/test_email/test_email.py | 74 ++++++++++++++++++++++++++++++-
- 3 files changed, 150 insertions(+), 4 deletions(-)
+ 3 files changed, 151 insertions(+), 4 deletions(-)
 
 diff --git a/Doc/library/email.utils.rst b/Doc/library/email.utils.rst
 index 6723dc4..c89602d 100644
@@ -559,10 +551,10 @@ index 6723dc4..c89602d 100644
  
        from email.utils import getaddresses
 diff --git a/Lib/email/utils.py b/Lib/email/utils.py
-index 9522341..2e30e09 100644
+index 41bb3c9..09a414c 100644
 --- a/Lib/email/utils.py
 +++ b/Lib/email/utils.py
-@@ -48,6 +48,46 @@ TICK = "'"
+@@ -48,6 +48,47 @@ TICK = "'"
  specialsre = re.compile(r'[][\\()<>@,:;".]')
  escapesre = re.compile(r'[\\"]')
  
@@ -606,10 +598,11 @@ index 9522341..2e30e09 100644
 +
 +    return True
 +
- 
++
  def _has_surrogates(s):
-     """Return True if s contains surrogate-escaped binary data."""
-@@ -149,7 +189,7 @@ def _strip_quoted_realnames(addr):
+     """Return True if s may contain surrogate-escaped binary data."""
+     # This check is based on the fact that unless there are surrogates, utf8
+@@ -148,7 +189,7 @@ def _strip_quoted_realnames(addr):
  
  supports_strict_parsing = True
  
@@ -618,7 +611,7 @@ index 9522341..2e30e09 100644
      """Return a list of (REALNAME, EMAIL) or ('','') for each fieldvalue.
  
      When parsing fails for a fieldvalue, a 2-tuple of ('', '') is returned in
-@@ -158,6 +198,11 @@ def getaddresses(fieldvalues, *, strict=True):
+@@ -157,6 +198,11 @@ def getaddresses(fieldvalues, *, strict=True):
      If strict is true, use a strict parser which rejects malformed inputs.
      """
  
@@ -630,7 +623,7 @@ index 9522341..2e30e09 100644
      # If strict is true, if the resulting list of parsed addresses is greater
      # than the number of fieldvalues in the input list, a parsing error has
      # occurred and consequently a list containing a single empty 2-tuple [('',
-@@ -321,7 +366,7 @@ def parsedate_to_datetime(data):
+@@ -320,7 +366,7 @@ def parsedate_to_datetime(data):
              tzinfo=datetime.timezone(datetime.timedelta(seconds=tz)))
  
  
@@ -639,7 +632,7 @@ index 9522341..2e30e09 100644
      """
      Parse addr into its constituent realname and email address parts.
  
-@@ -330,6 +375,11 @@ def parseaddr(addr, *, strict=True):
+@@ -329,6 +375,11 @@ def parseaddr(addr, *, strict=True):
  
      If strict is True, use a strict parser which rejects malformed inputs.
      """
@@ -652,7 +645,7 @@ index 9522341..2e30e09 100644
          addrs = _AddressList(addr).addresslist
          if not addrs:
 diff --git a/Lib/test/test_email/test_email.py b/Lib/test/test_email/test_email.py
-index 20b6779..d7d99f0 100644
+index ad60ed3..f85da56 100644
 --- a/Lib/test/test_email/test_email.py
 +++ b/Lib/test/test_email/test_email.py
 @@ -8,6 +8,9 @@ import base64
@@ -676,7 +669,7 @@ index 20b6779..d7d99f0 100644
  from test.test_email import openfile, TestEmailBase
  
  # These imports are documented to work, but we are testing them using a
-@@ -3427,6 +3430,73 @@ Foo
+@@ -3442,6 +3445,73 @@ Foo
          # Test email.utils.supports_strict_parsing attribute
          self.assertEqual(email.utils.supports_strict_parsing, True)
  
@@ -751,5 +744,5 @@ index 20b6779..d7d99f0 100644
          for addresses, expected in (
              (['"Sürname, Firstname" <to@example.com>'],
 -- 
-2.43.0
+2.44.0
 
diff --git a/SOURCES/00422-fix-expat-tests.patch b/SOURCES/00422-fix-expat-tests.patch
new file mode 100644
index 0000000000000000000000000000000000000000..64c84496436b822dfb6c0478ce84349cea6579be
--- /dev/null
+++ b/SOURCES/00422-fix-expat-tests.patch
@@ -0,0 +1,75 @@
+From 670984c96eea60488c5355b4cf535c1ee3cf081a Mon Sep 17 00:00:00 2001
+From: rpm-build <rpm-build>
+Date: Wed, 24 Apr 2024 04:24:16 +0200
+Subject: [PATCH] Fix xml tests
+
+---
+ Lib/test/test_pyexpat.py   | 3 +++
+ Lib/test/test_sax.py       | 2 ++
+ Lib/test/test_xml_etree.py | 6 ++++++
+ 3 files changed, 11 insertions(+)
+
+diff --git a/Lib/test/test_pyexpat.py b/Lib/test/test_pyexpat.py
+index 44bd1de..5976fa0 100644
+--- a/Lib/test/test_pyexpat.py
++++ b/Lib/test/test_pyexpat.py
+@@ -3,6 +3,7 @@
+ 
+ import os
+ import platform
++import pyexpat
+ import sys
+ import sysconfig
+ import unittest
+@@ -793,6 +794,8 @@ class ReparseDeferralTest(unittest.TestCase):
+ 
+         self.assertEqual(started, ['doc'])
+ 
++    @unittest.skipIf(pyexpat.version_info < (2, 6, 0),
++                     "Reparse deferral not defined for libexpat < 2.6.0")
+     def test_reparse_deferral_disabled(self):
+         started = []
+ 
+diff --git a/Lib/test/test_sax.py b/Lib/test/test_sax.py
+index 9b3014a..5960de1 100644
+--- a/Lib/test/test_sax.py
++++ b/Lib/test/test_sax.py
+@@ -1240,6 +1240,8 @@ class ExpatReaderTest(XmlTestBase):
+ 
+         self.assertEqual(result.getvalue(), start + b"<doc></doc>")
+ 
++    @unittest.skipIf(pyexpat.version_info < (2, 6, 0),
++                     "Reparse deferral not defined for libexpat < 2.6.0")
+     def test_flush_reparse_deferral_disabled(self):
+         result = BytesIO()
+         xmlgen = XMLGenerator(result)
+diff --git a/Lib/test/test_xml_etree.py b/Lib/test/test_xml_etree.py
+index 8becafb..5e9b6b5 100644
+--- a/Lib/test/test_xml_etree.py
++++ b/Lib/test/test_xml_etree.py
+@@ -1424,9 +1424,13 @@ class XMLPullParserTest(unittest.TestCase):
+         self.assert_event_tags(parser, [('end', 'root')])
+         self.assertIsNone(parser.close())
+ 
++    @unittest.skipIf(pyexpat.version_info < (2, 6, 0),
++        "test not compatible with the latest expat security release")
+     def test_simple_xml_chunk_1(self):
+         self.test_simple_xml(chunk_size=1, flush=True)
+ 
++    @unittest.skipIf(pyexpat.version_info < (2, 6, 0),
++        "test not compatible with the latest expat security release")
+     def test_simple_xml_chunk_5(self):
+         self.test_simple_xml(chunk_size=5, flush=True)
+ 
+@@ -1651,6 +1655,8 @@ class XMLPullParserTest(unittest.TestCase):
+ 
+         self.assert_event_tags(parser, [('end', 'doc')])
+ 
++    @unittest.skipIf(pyexpat.version_info < (2, 6, 0),
++                     "Reparse deferral not defined for libexpat < 2.6.0")
+     def test_flush_reparse_deferral_disabled(self):
+         parser = ET.XMLPullParser(events=('start', 'end'))
+ 
+-- 
+2.44.0
+
diff --git a/SOURCES/Python-3.11.9.tar.xz.asc b/SOURCES/Python-3.11.9.tar.xz.asc
new file mode 100644
index 0000000000000000000000000000000000000000..c79d99badbc32f6eec9b33733508a1f0344c3575
--- /dev/null
+++ b/SOURCES/Python-3.11.9.tar.xz.asc
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCAAdFiEEz9yiRbEEPPKl+Xhl/+h0BBaL2EcFAmYNMEcACgkQ/+h0BBaL
+2EeHhxAAuuIM9bl0dgAWOjbgRjCeXR8aFdfcI4dkO7bZrUy8eKbM+XCvPUUvloRJ
+vzGkxYyTmI4kcNPOHfscUwH7AVVij8nGv7WeaXBUZGIXNwfHwvqOxvYvSsNNNFnr
+70yJB7Df8/2s0XqFx3X1aWcnyMDerWKpfJ/VI/NPmCVxkYXGshuTTSFcCMTSFBQB
+sNrIb5NWAsBF4R85uRQDlCg1AoyaKOdJNQkPo1Nrjol1ExJ+MHE7+E+QL9pQkUWG
+SBISPUhJySBAegxolw6YR5dz1L4nukueQDJz3NizUeQGDvH7h1ImY8cypRi44U61
+SUUHhBfmUBiC2dS/tTQawySULWcgbkV4GJ6cJZfDd95uffd4S/GDJCa2wCE2UTlA
+XzQHwbcnIeoL064gX7ruBuFHJ6n/Oz7nZkFqbH2aqLTAWgLiUq31xH3HY734sL6X
+zIJQRbcK1EM7cnNjKMVPlnHpAeKbsbHbU6yzWwZ7reIoyWlZ7vEGrfXO7Kmul93K
+wVaWu0AiOY566ugekdDx4cKV+FQN6oppAN63yTfPJ2Ddcmxs4KNrtozw9OAgDTPE
+GTPFD6V1CMuyQj/jOpAmbj+4bRD4Mx3u2PSittvrIeopxrXPsGGSZ5kdl62Xa2+A
+DzKyYNXzcmxqS9lGdFb+OWCTyAIXxwZrdz1Q61g5xDvR9z/wZiI=
+=Br9/
+-----END PGP SIGNATURE-----
diff --git a/SPECS/python3.11.spec b/SPECS/python3.11.spec
index 52c189df783abbd5d05e35e5824724f6459c8c8d..1efededac4da0678ec0a98c06e4ae70fd7b6b693 100644
--- a/SPECS/python3.11.spec
+++ b/SPECS/python3.11.spec
@@ -16,7 +16,7 @@ URL: https://www.python.org/
 
 #  WARNING  When rebasing to a new Python version,
 #           remember to update the python3-docs package as well
-%global general_version %{pybasever}.7
+%global general_version %{pybasever}.9
 #global prerel ...
 %global upstream_version %{general_version}%{?prerel}
 Version: %{general_version}%{?prerel:~%{prerel}}
@@ -63,7 +63,7 @@ License: Python
 # If the rpmwheels condition is disabled, we use the bundled wheel packages
 # from Python with the versions below.
 # This needs to be manually updated when we update Python.
-%global pip_version 23.2.1
+%global pip_version 24.0
 %global setuptools_version 65.5.0
 
 # Expensive optimizations (mainly, profile-guided optimizations)
@@ -385,6 +385,12 @@ Patch397: 00397-tarfile-filter.patch
 # config file or environment variable.
 Patch415: 00415-cve-2023-27043-gh-102988-reject-malformed-addresses-in-email-parseaddr-111116.patch
 
+# 00422 #
+# Fix the test suite for releases of expat < 2.6.0
+# which backport the CVE-2023-52425 fix.
+# Downstream only.
+Patch422: 00422-fix-expat-tests.patch
+
 # (New patches go here ^^^)
 #
 # When adding new patches to "python" and "python3" in Fedora, EL, etc.,
@@ -1839,6 +1845,12 @@ fi
 # ======================================================
 
 %changelog
+* Mon Apr 22 2024 Charalampos Stratakis <cstratak@redhat.com> - 3.11.9-1
+- Rebase to 3.11.9
+- Security fixes for CVE-2023-6597 and CVE-2024-0450
+- Fix expat tests for the latest expat security release
+Resolves: RHEL-33672, RHEL-33684
+
 * Mon Jan 22 2024 Charalampos Stratakis <cstratak@redhat.com> - 3.11.7-1
 - Rebase to 3.11.7
 Resolves: RHEL-21915