diff --git a/.python3.11.metadata b/.python3.11.metadata
index 7802c5c11740b890b243fb0272a87a5665445cbe..019ffb6091d8b6c7d7d621fea02453d9ea61bbea 100644
--- a/.python3.11.metadata
+++ b/.python3.11.metadata
@@ -1,2 +1,2 @@
-85cd12e9cf1d6d5a45f17f7afe1cebe7ee628d3282281c492e86adf636defa3f SOURCES/Python-3.11.5.tar.xz
+18e1aa7e66ff3a58423d59ed22815a6954e53342122c45df20c96877c062b9b7 SOURCES/Python-3.11.7.tar.xz
 fb28243ffeb9725b14b60586a9a123682a89604c025b7a9d4bcdeb67078203c6 SOURCES/pgp_keys.asc
diff --git a/SOURCES/00329-fips.patch b/SOURCES/00329-fips.patch
index b4763dd997e2bb89b8ab02b11f623c144aa8bbda..256d214e657edec760b93d9db87a23b61e69c172 100644
--- a/SOURCES/00329-fips.patch
+++ b/SOURCES/00329-fips.patch
@@ -1,4 +1,4 @@
-From c96f1bea2ffc5c0ca849d5406236c07ea229a64f Mon Sep 17 00:00:00 2001
+From ecc5137120f471c22ff6dcb1bd128561c31e023c Mon Sep 17 00:00:00 2001
 From: Charalampos Stratakis <cstratak@redhat.com>
 Date: Thu, 12 Dec 2019 16:58:31 +0100
 Subject: [PATCH 1/7] Expose blake2b and blake2s hashes from OpenSSL
@@ -29,10 +29,10 @@ index 67becdd..6607ef7 100644
              computed = m.hexdigest() if not shake else m.hexdigest(length)
              self.assertEqual(
 diff --git a/Modules/_hashopenssl.c b/Modules/_hashopenssl.c
-index 3c40f09..e819d02 100644
+index 57d64bd..d0c3b9e 100644
 --- a/Modules/_hashopenssl.c
 +++ b/Modules/_hashopenssl.c
-@@ -1077,6 +1077,41 @@ _hashlib_openssl_sha512_impl(PyObject *module, PyObject *data_obj,
+@@ -1078,6 +1078,41 @@ _hashlib_openssl_sha512_impl(PyObject *module, PyObject *data_obj,
  }
  
  
@@ -74,7 +74,7 @@ index 3c40f09..e819d02 100644
  #ifdef PY_OPENSSL_HAS_SHA3
  
  /*[clinic input]
-@@ -2065,6 +2100,8 @@ static struct PyMethodDef EVP_functions[] = {
+@@ -2066,6 +2101,8 @@ static struct PyMethodDef EVP_functions[] = {
      _HASHLIB_OPENSSL_SHA256_METHODDEF
      _HASHLIB_OPENSSL_SHA384_METHODDEF
      _HASHLIB_OPENSSL_SHA512_METHODDEF
@@ -205,10 +205,10 @@ index 5d84f4a..011026a 100644
 -/*[clinic end generated code: output=69f2374071bff707 input=a9049054013a1b77]*/
 +/*[clinic end generated code: output=c6a9af5563972eda input=a9049054013a1b77]*/
 -- 
-2.39.1
+2.43.0
 
 
-From 9a7e164840aa35602e1c6dddadd461fafc666a63 Mon Sep 17 00:00:00 2001
+From 0198d467525e79cb4be4418708719af3eaee7a40 Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <pviktori@redhat.com>
 Date: Thu, 1 Aug 2019 17:57:05 +0200
 Subject: [PATCH 2/7] Use a stronger hash in multiprocessing handshake
@@ -220,10 +220,10 @@ https://bugs.python.org/issue17258
  1 file changed, 6 insertions(+), 2 deletions(-)
 
 diff --git a/Lib/multiprocessing/connection.py b/Lib/multiprocessing/connection.py
-index b08144f..0497557 100644
+index 8b81f99..69c0b7e 100644
 --- a/Lib/multiprocessing/connection.py
 +++ b/Lib/multiprocessing/connection.py
-@@ -42,6 +42,10 @@ BUFSIZE = 8192
+@@ -43,6 +43,10 @@ BUFSIZE = 8192
  # A very generous timeout when it comes to local connections...
  CONNECTION_TIMEOUT = 20.
  
@@ -234,7 +234,7 @@ index b08144f..0497557 100644
  _mmap_counter = itertools.count()
  
  default_family = 'AF_INET'
-@@ -735,7 +739,7 @@ def deliver_challenge(connection, authkey):
+@@ -752,7 +756,7 @@ def deliver_challenge(connection, authkey):
              "Authkey must be bytes, not {0!s}".format(type(authkey)))
      message = os.urandom(MESSAGE_LENGTH)
      connection.send_bytes(CHALLENGE + message)
@@ -243,7 +243,7 @@ index b08144f..0497557 100644
      response = connection.recv_bytes(256)        # reject large message
      if response == digest:
          connection.send_bytes(WELCOME)
-@@ -751,7 +755,7 @@ def answer_challenge(connection, authkey):
+@@ -768,7 +772,7 @@ def answer_challenge(connection, authkey):
      message = connection.recv_bytes(256)         # reject large message
      assert message[:len(CHALLENGE)] == CHALLENGE, 'message = %r' % message
      message = message[len(CHALLENGE):]
@@ -253,10 +253,10 @@ index b08144f..0497557 100644
      response = connection.recv_bytes(256)        # reject large message
      if response != WELCOME:
 -- 
-2.39.1
+2.43.0
 
 
-From 10b91783a2f22153738c5658a98daf7475ad9a8c Mon Sep 17 00:00:00 2001
+From a7822e2e1f21529e9730885bd8c9c6ab7c704d5b Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <pviktori@redhat.com>
 Date: Thu, 25 Jul 2019 17:19:06 +0200
 Subject: [PATCH 3/7] Disable Python's hash implementations in FIPS mode,
@@ -359,7 +359,7 @@ index c2cac98..55b1677 100644
  
      if (self->lock == NULL && buf.len >= HASHLIB_GIL_MINSIZE)
 diff --git a/Modules/_blake2/blake2module.c b/Modules/_blake2/blake2module.c
-index 44d783b..d247e44 100644
+index 93478f5..e3a024d 100644
 --- a/Modules/_blake2/blake2module.c
 +++ b/Modules/_blake2/blake2module.c
 @@ -13,6 +13,7 @@
@@ -370,7 +370,7 @@ index 44d783b..d247e44 100644
  #include "blake2module.h"
  
  extern PyType_Spec blake2b_type_spec;
-@@ -77,6 +78,7 @@ _blake2_free(void *module)
+@@ -83,6 +84,7 @@ _blake2_free(void *module)
  static int
  blake2_exec(PyObject *m)
  {
@@ -378,7 +378,7 @@ index 44d783b..d247e44 100644
      Blake2State* st = blake2_get_state(m);
  
      st->blake2b_type = (PyTypeObject *)PyType_FromModuleAndSpec(
-@@ -145,5 +147,6 @@ static struct PyModuleDef blake2_module = {
+@@ -154,5 +156,6 @@ static struct PyModuleDef blake2_module = {
  PyMODINIT_FUNC
  PyInit__blake2(void)
  {
@@ -446,10 +446,10 @@ index 56ae7a5..45fb403 100644
 +    if (_Py_hashlib_fips_error(exc, name)) return NULL; \
 +} while (0)
 diff --git a/configure.ac b/configure.ac
-index c62a565..861f7a0 100644
+index 52d5c1f..56aff78 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -7044,7 +7044,8 @@ PY_STDLIB_MOD([_sha512], [test "$with_builtin_sha512" = yes])
+@@ -7069,7 +7069,8 @@ PY_STDLIB_MOD([_sha512], [test "$with_builtin_sha512" = yes])
  PY_STDLIB_MOD([_sha3], [test "$with_builtin_sha3" = yes])
  PY_STDLIB_MOD([_blake2],
    [test "$with_builtin_blake2" = yes], [],
@@ -460,10 +460,10 @@ index c62a565..861f7a0 100644
  PY_STDLIB_MOD([_crypt],
    [], [test "$ac_cv_crypt_crypt" = yes],
 -- 
-2.39.1
+2.43.0
 
 
-From e26066b1c05c9768e38cb6f45d6a01058de55b3f Mon Sep 17 00:00:00 2001
+From e9ce6d33544559172dbebbe0c0dfba2757c62331 Mon Sep 17 00:00:00 2001
 From: Charalampos Stratakis <cstratak@redhat.com>
 Date: Fri, 29 Jan 2021 14:16:21 +0100
 Subject: [PATCH 4/7] Use python's fall back crypto implementations only if we
@@ -623,10 +623,10 @@ index 01d12f5..a7cdb07 100644
      def test_pbkdf2_hmac_py(self):
          with warnings_helper.check_warnings():
 -- 
-2.39.1
+2.43.0
 
 
-From 9ccbd22b8538fee379717c8b2916dc1ff8b96f07 Mon Sep 17 00:00:00 2001
+From 641c617775b6973ed84711a2602ba190fe064474 Mon Sep 17 00:00:00 2001
 From: Charalampos Stratakis <cstratak@redhat.com>
 Date: Wed, 31 Jul 2019 15:43:43 +0200
 Subject: [PATCH 5/7] Test equivalence of hashes for the various digests with
@@ -783,10 +783,10 @@ index a7cdb07..c071f28 100644
  class KDFTests(unittest.TestCase):
  
 -- 
-2.39.1
+2.43.0
 
 
-From c3b8d6ecc76c87e8b05fd2cb212d5dece50ce0b1 Mon Sep 17 00:00:00 2001
+From a706c8342f0f9307d44c43c203702e1476fe73b4 Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <pviktori@redhat.com>
 Date: Mon, 26 Aug 2019 19:39:48 +0200
 Subject: [PATCH 6/7] Guard against Python HMAC in FIPS mode
@@ -844,7 +844,7 @@ index 8b4f920..20ef96c 100644
              digest_cons = digestmod
          elif isinstance(digestmod, str):
 diff --git a/Lib/test/test_hmac.py b/Lib/test/test_hmac.py
-index 7cf9973..a9e4e39 100644
+index a39a2c4..0742a1c 100644
 --- a/Lib/test/test_hmac.py
 +++ b/Lib/test/test_hmac.py
 @@ -5,6 +5,7 @@ import hashlib
@@ -875,7 +875,7 @@ index 7cf9973..a9e4e39 100644
          with warnings.catch_warnings():
              warnings.simplefilter('error', RuntimeWarning)
              with self.assertRaises(RuntimeWarning):
-@@ -443,6 +450,7 @@ class ConstructorTestCase(unittest.TestCase):
+@@ -453,6 +460,7 @@ class ConstructorTestCase(unittest.TestCase):
          with self.assertRaisesRegex(TypeError, "immutable type"):
              C_HMAC.value = None
  
@@ -883,7 +883,7 @@ index 7cf9973..a9e4e39 100644
      @unittest.skipUnless(sha256_module is not None, 'need _sha256')
      def test_with_sha256_module(self):
          h = hmac.HMAC(b"key", b"hash this!", digestmod=sha256_module.sha256)
-@@ -471,6 +479,7 @@ class SanityTestCase(unittest.TestCase):
+@@ -481,6 +489,7 @@ class SanityTestCase(unittest.TestCase):
  
  class CopyTestCase(unittest.TestCase):
  
@@ -891,7 +891,7 @@ index 7cf9973..a9e4e39 100644
      @hashlib_helper.requires_hashdigest('sha256')
      def test_attributes_old(self):
          # Testing if attributes are of same type.
-@@ -482,6 +491,7 @@ class CopyTestCase(unittest.TestCase):
+@@ -492,6 +501,7 @@ class CopyTestCase(unittest.TestCase):
          self.assertEqual(type(h1._outer), type(h2._outer),
              "Types of outer don't match.")
  
@@ -900,10 +900,10 @@ index 7cf9973..a9e4e39 100644
      def test_realcopy_old(self):
          # Testing if the copy method created a real copy.
 -- 
-2.39.1
+2.43.0
 
 
-From 2b06ee89344e8735cdc8435aadbdf83fe289e934 Mon Sep 17 00:00:00 2001
+From 03f1dedfe5d29af20fb3686d76b045384d41d8dd Mon Sep 17 00:00:00 2001
 From: Petr Viktorin <encukou@gmail.com>
 Date: Wed, 25 Aug 2021 16:44:43 +0200
 Subject: [PATCH 7/7] Disable hash-based PYCs in FIPS mode
@@ -946,11 +946,11 @@ index db52725..5fca65e 100644
          return PycInvalidationMode.CHECKED_HASH
      else:
 diff --git a/Lib/test/support/__init__.py b/Lib/test/support/__init__.py
-index c33f90d..7d40540 100644
+index dc7a6e6..646b328 100644
 --- a/Lib/test/support/__init__.py
 +++ b/Lib/test/support/__init__.py
-@@ -2225,6 +2225,20 @@ def requires_venv_with_pip():
-     return unittest.skipUnless(ctypes, 'venv: pip requires ctypes')
+@@ -2203,6 +2203,20 @@ def sleeping_retry(timeout, err_msg=None, /,
+         delay = min(delay * 2, max_delay)
  
  
 +def fails_in_fips_mode(expected_error):
@@ -971,7 +971,7 @@ index c33f90d..7d40540 100644
  def adjust_int_max_str_digits(max_digits):
      """Temporarily change the integer string conversion length limit."""
 diff --git a/Lib/test/test_cmd_line_script.py b/Lib/test/test_cmd_line_script.py
-index 4dadbc0..7dc7e51 100644
+index 7fcd563..476b557 100644
 --- a/Lib/test/test_cmd_line_script.py
 +++ b/Lib/test/test_cmd_line_script.py
 @@ -286,6 +286,7 @@ class CmdLineTest(unittest.TestCase):
@@ -991,10 +991,10 @@ index 4dadbc0..7dc7e51 100644
          with os_helper.temp_dir() as script_dir:
              script_name = _make_test_script(script_dir, '__main__')
 diff --git a/Lib/test/test_compileall.py b/Lib/test/test_compileall.py
-index 05154c8..c678d4a 100644
+index 9cd92ad..4ec29a1 100644
 --- a/Lib/test/test_compileall.py
 +++ b/Lib/test/test_compileall.py
-@@ -800,14 +800,23 @@ class CommandLineTestsBase:
+@@ -806,14 +806,23 @@ class CommandLineTestsBase:
          out = self.assertRunOK('badfilename')
          self.assertRegex(out, b"Can't list 'badfilename'")
  
@@ -1020,10 +1020,10 @@ index 05154c8..c678d4a 100644
          with open(pyc, 'rb') as fp:
              data = fp.read()
 diff --git a/Lib/test/test_imp.py b/Lib/test/test_imp.py
-index 4bb0390..ff62483 100644
+index 4062afd..6bc276d 100644
 --- a/Lib/test/test_imp.py
 +++ b/Lib/test/test_imp.py
-@@ -350,6 +350,7 @@ class ImportTests(unittest.TestCase):
+@@ -352,6 +352,7 @@ class ImportTests(unittest.TestCase):
          import _frozen_importlib
          self.assertEqual(_frozen_importlib.__spec__.origin, "frozen")
  
@@ -1031,7 +1031,7 @@ index 4bb0390..ff62483 100644
      def test_source_hash(self):
          self.assertEqual(_imp.source_hash(42, b'hi'), b'\xfb\xd9G\x05\xaf$\x9b~')
          self.assertEqual(_imp.source_hash(43, b'hi'), b'\xd0/\x87C\xccC\xff\xe2')
-@@ -369,6 +370,7 @@ class ImportTests(unittest.TestCase):
+@@ -371,6 +372,7 @@ class ImportTests(unittest.TestCase):
              res = script_helper.assert_python_ok(*args)
              self.assertEqual(res.out.strip().decode('utf-8'), expected)
  
@@ -1092,10 +1092,10 @@ index 378dcbe..7b223a1 100644
          with util.create_modules('_temp') as mapping:
              bc_path = self.manipulate_bytecode(
 diff --git a/Lib/test/test_py_compile.py b/Lib/test/test_py_compile.py
-index e53f5d9..7266212 100644
+index 9b420d2..dd6460a 100644
 --- a/Lib/test/test_py_compile.py
 +++ b/Lib/test/test_py_compile.py
-@@ -141,13 +141,16 @@ class PyCompileTestsBase:
+@@ -143,13 +143,16 @@ class PyCompileTestsBase:
              importlib.util.cache_from_source(bad_coding)))
  
      def test_source_date_epoch(self):
@@ -1113,7 +1113,7 @@ index e53f5d9..7266212 100644
              expected_flags = 0b11
          else:
              expected_flags = 0b00
-@@ -178,7 +181,8 @@ class PyCompileTestsBase:
+@@ -180,7 +183,8 @@ class PyCompileTestsBase:
          # Specifying optimized bytecode should lead to a path reflecting that.
          self.assertIn('opt-2', py_compile.compile(self.source_path, optimize=2))
  
@@ -1123,7 +1123,7 @@ index e53f5d9..7266212 100644
          py_compile.compile(
              self.source_path,
              invalidation_mode=py_compile.PycInvalidationMode.CHECKED_HASH,
-@@ -187,6 +191,9 @@ class PyCompileTestsBase:
+@@ -189,6 +193,9 @@ class PyCompileTestsBase:
              flags = importlib._bootstrap_external._classify_pyc(
                  fp.read(), 'test', {})
          self.assertEqual(flags, 0b11)
@@ -1154,10 +1154,10 @@ index 59a5200..81fadb3 100644
      def test_checked_hash_based_change_pyc(self):
          source = b"state = 'old'"
 diff --git a/Python/import.c b/Python/import.c
-index 07a8b90..e97b47b 100644
+index 39144d3..b439059 100644
 --- a/Python/import.c
 +++ b/Python/import.c
-@@ -2437,6 +2437,26 @@ static PyObject *
+@@ -2449,6 +2449,26 @@ static PyObject *
  _imp_source_hash_impl(PyObject *module, long key, Py_buffer *source)
  /*[clinic end generated code: output=edb292448cf399ea input=9aaad1e590089789]*/
  {
@@ -1185,5 +1185,5 @@ index 07a8b90..e97b47b 100644
          uint64_t x;
          char data[sizeof(uint64_t)];
 -- 
-2.39.1
+2.43.0
 
diff --git a/SOURCES/00415-cve-2023-27043-gh-102988-reject-malformed-addresses-in-email-parseaddr-111116.patch b/SOURCES/00415-cve-2023-27043-gh-102988-reject-malformed-addresses-in-email-parseaddr-111116.patch
index 9f8d3793b5b9fec8cb1e2204a5926f78547e89ef..73bf9b76d06f56fe1ddcc46a5240e819c18553c1 100644
--- a/SOURCES/00415-cve-2023-27043-gh-102988-reject-malformed-addresses-in-email-parseaddr-111116.patch
+++ b/SOURCES/00415-cve-2023-27043-gh-102988-reject-malformed-addresses-in-email-parseaddr-111116.patch
@@ -1,8 +1,8 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From d8b0fafb202bf884135a3f7f0ce0b086217a2da2 Mon Sep 17 00:00:00 2001
 From: Victor Stinner <vstinner@python.org>
 Date: Fri, 15 Dec 2023 16:10:40 +0100
-Subject: [PATCH] 00415: [CVE-2023-27043] gh-102988: Reject malformed addresses
- in email.parseaddr() (#111116)
+Subject: [PATCH 1/2] 00415: [CVE-2023-27043] gh-102988: Reject malformed
+ addresses in email.parseaddr() (#111116)
 
 Detect email address parsing errors and return empty tuple to
 indicate the parsing error (old API). Add an optional 'strict'
@@ -19,7 +19,7 @@ Co-Authored-By: Thomas Dwyer <github@tomd.tel>
  create mode 100644 Misc/NEWS.d/next/Library/2023-10-20-15-28-08.gh-issue-102988.dStNO7.rst
 
 diff --git a/Doc/library/email.utils.rst b/Doc/library/email.utils.rst
-index 0e266b6a45..6723dc4f13 100644
+index 0e266b6..6723dc4 100644
 --- a/Doc/library/email.utils.rst
 +++ b/Doc/library/email.utils.rst
 @@ -60,13 +60,18 @@ of the new API.
@@ -72,10 +72,10 @@ index 0e266b6a45..6723dc4f13 100644
  .. function:: parsedate(date)
  
 diff --git a/Lib/email/utils.py b/Lib/email/utils.py
-index cfdfeb3f1a..9522341fab 100644
+index cfdfeb3..9522341 100644
 --- a/Lib/email/utils.py
 +++ b/Lib/email/utils.py
-@@ -48,6 +48,7 @@
+@@ -48,6 +48,7 @@ TICK = "'"
  specialsre = re.compile(r'[][\\()<>@,:;".]')
  escapesre = re.compile(r'[\\"]')
  
@@ -100,12 +100,7 @@ index cfdfeb3f1a..9522341fab 100644
 +            yield (pos, ch)
 +    if escape:
 +        yield (pos, '\\')
- 
--def getaddresses(fieldvalues):
--    """Return a list of (REALNAME, EMAIL) for each fieldvalue."""
--    all = COMMASPACE.join(str(v) for v in fieldvalues)
--    a = _AddressList(all)
--    return a.addresslist
++
 +
 +def _strip_quoted_realnames(addr):
 +    """Strip real names between quotes."""
@@ -130,7 +125,12 @@ index cfdfeb3f1a..9522341fab 100644
 +        result.append(addr[start:])
 +
 +    return ''.join(result)
-+
+ 
+-def getaddresses(fieldvalues):
+-    """Return a list of (REALNAME, EMAIL) for each fieldvalue."""
+-    all = COMMASPACE.join(str(v) for v in fieldvalues)
+-    a = _AddressList(all)
+-    return a.addresslist
 +
 +supports_strict_parsing = True
 +
@@ -255,10 +255,10 @@ index cfdfeb3f1a..9522341fab 100644
  
  
 diff --git a/Lib/test/test_email/test_email.py b/Lib/test/test_email/test_email.py
-index 677f2094b8..20b67792ea 100644
+index 677f209..20b6779 100644
 --- a/Lib/test/test_email/test_email.py
 +++ b/Lib/test/test_email/test_email.py
-@@ -17,6 +17,7 @@
+@@ -17,6 +17,7 @@ from unittest.mock import patch
  
  import email
  import email.policy
@@ -266,7 +266,7 @@ index 677f2094b8..20b67792ea 100644
  
  from email.charset import Charset
  from email.generator import Generator, DecodedGenerator, BytesGenerator
-@@ -3321,15 +3322,154 @@ def test_getaddresses(self):
+@@ -3321,15 +3322,154 @@ Foo
             [('Al Person', 'aperson@dom.ain'),
              ('Bud Person', 'bperson@dom.ain')])
  
@@ -429,7 +429,7 @@ index 677f2094b8..20b67792ea 100644
  
      def test_getaddresses_embedded_comment(self):
          """Test proper handling of a nested comment"""
-@@ -3520,6 +3660,54 @@ def test_mime_classes_policy_argument(self):
+@@ -3520,6 +3660,54 @@ multipart/report
                  m = cls(*constructor, policy=email.policy.default)
                  self.assertIs(m.policy, email.policy.default)
  
@@ -486,7 +486,7 @@ index 677f2094b8..20b67792ea 100644
  class TestIterators(TestEmailBase):
 diff --git a/Misc/NEWS.d/next/Library/2023-10-20-15-28-08.gh-issue-102988.dStNO7.rst b/Misc/NEWS.d/next/Library/2023-10-20-15-28-08.gh-issue-102988.dStNO7.rst
 new file mode 100644
-index 0000000000..3d0e9e4078
+index 0000000..3d0e9e4
 --- /dev/null
 +++ b/Misc/NEWS.d/next/Library/2023-10-20-15-28-08.gh-issue-102988.dStNO7.rst
 @@ -0,0 +1,8 @@
@@ -498,18 +498,21 @@ index 0000000000..3d0e9e4078
 +``getattr(email.utils, 'supports_strict_parsing', False)`` can be use to check
 +if the *strict* paramater is available. Patch by Thomas Dwyer and Victor
 +Stinner to improve the CVE-2023-27043 fix.
+-- 
+2.43.0
 
 
-From 84627ff5841b6715edc47a643225195a0718de99 Mon Sep 17 00:00:00 2001
+From 6c34f5b95da90bd494e29776c0e807af44689fae Mon Sep 17 00:00:00 2001
 From: Lumir Balhar <lbalhar@redhat.com>
 Date: Wed, 10 Jan 2024 08:53:53 +0100
-Subject: [PATCH] Make it possible to disable strict parsing in email module
+Subject: [PATCH 2/2] Make it possible to disable strict parsing in email
+ module
 
 ---
  Doc/library/email.utils.rst       | 26 +++++++++++
- Lib/email/utils.py                | 54 ++++++++++++++++++++++-
- Lib/test/test_email/test_email.py | 72 ++++++++++++++++++++++++++++++-
- 3 files changed, 149 insertions(+), 3 deletions(-)
+ Lib/email/utils.py                | 54 +++++++++++++++++++++-
+ Lib/test/test_email/test_email.py | 74 ++++++++++++++++++++++++++++++-
+ 3 files changed, 150 insertions(+), 4 deletions(-)
 
 diff --git a/Doc/library/email.utils.rst b/Doc/library/email.utils.rst
 index 6723dc4..c89602d 100644
@@ -649,7 +652,7 @@ index 9522341..2e30e09 100644
          addrs = _AddressList(addr).addresslist
          if not addrs:
 diff --git a/Lib/test/test_email/test_email.py b/Lib/test/test_email/test_email.py
-index a1a7859..f4e8c7f 100644
+index 20b6779..d7d99f0 100644
 --- a/Lib/test/test_email/test_email.py
 +++ b/Lib/test/test_email/test_email.py
 @@ -8,6 +8,9 @@ import base64
@@ -662,17 +665,18 @@ index a1a7859..f4e8c7f 100644
  
  from io import StringIO, BytesIO
  from itertools import chain
-@@ -40,7 +43,7 @@ from email import iterators
- from email import quoprimime
+@@ -41,8 +44,8 @@ from email import quoprimime
  from email import utils
  
+ from test import support
 -from test.support import threading_helper
 -from test.support.os_helper import unlink
 +from test.support import threading_helper, swap_attr
 +from test.support.os_helper import unlink, EnvironmentVarGuard
  from test.test_email import openfile, TestEmailBase
  
-@@ -3426,6 +3429,73 @@ Foo
+ # These imports are documented to work, but we are testing them using a
+@@ -3427,6 +3430,73 @@ Foo
          # Test email.utils.supports_strict_parsing attribute
          self.assertEqual(email.utils.supports_strict_parsing, True)
  
diff --git a/SOURCES/Python-3.11.7.tar.xz.asc b/SOURCES/Python-3.11.7.tar.xz.asc
new file mode 100644
index 0000000000000000000000000000000000000000..5d3dcbe779339fde01e875e8f1076f8ff541ef23
--- /dev/null
+++ b/SOURCES/Python-3.11.7.tar.xz.asc
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCAAdFiEEz9yiRbEEPPKl+Xhl/+h0BBaL2EcFAmVuFigACgkQ/+h0BBaL
+2EeHPg/+LU5xs2ZDrQogDcH+A1v8RyursiggypdM5hXTrsFsTCIk4iekcI9xkhG1
+ltNX4UuCe5PUEbTgtaWP0ncXARrUnPCoQaQ1sHVDTYoHegancsk+sXZc1JM7qr0p
+Y4Ig6mKjuHFMXCInQSI2GaH4t5r4Z1jGk/PGrecIHOPJgqfA/6Z3TBF5N+y3jEvS
+2QazMB298q4RDhh9m3REe8LwFPHDlfw9eRohv0MB8xygg9KtxhLZrN7gLBQZvKGD
+ihNw6EgJj5OZ0dvwKCCXnlZuwknuJW7vAOPHhYeenPdVdYCGoRSyN7JdD07L+5AG
+O14l2rqZrz5Eu28by+kAUrcPYAfAXekw1PmtT3HSd9U/nqnUiTkkJcjyGG/e3cjJ
+sUDKMNCSBq0G7j5DB3bB6VHkZjVuz+T+iR5QdfJ4kI2pYSuE/rUj1rhkUXApYsHl
+7Wff0QbOW6QT1wCtQcMpJSzkTDVJVYxiqrko/ihlOhphDHYLdOIGOrxWAUwc06x/
+BhJD6tM1kEVZvifoJp1OsNwDzZ/Ku6CUs05E1vWxdeNVeANyKAgCZ5hOVmhnv866
+11zfgo/znRsMzMIyJuy0bhO0C6omVLzzfhipAbZM2jDorn37xxV0v/I0pceNtLrp
+YR7Tjs7+Ihe6/oItjW53j9T7ANdgQ1RVDg98lKlPFNL+hxfctwY=
+=0Pkd
+-----END PGP SIGNATURE-----
diff --git a/SOURCES/check-pyc-timestamps.py b/SOURCES/check-pyc-timestamps.py
index 5b4c809343dd0e6e119c468e94d8e95607034407..d619dae50f633349dc2ca66f5167a5625f0434a6 100644
--- a/SOURCES/check-pyc-timestamps.py
+++ b/SOURCES/check-pyc-timestamps.py
@@ -17,9 +17,9 @@ LEVELS = (None, 1, 2)
 not_compiled = [
     '/usr/bin/*',
     '/usr/lib/rpm/redhat/*',
-    '*/test/bad_coding.py',
-    '*/test/bad_coding2.py',
-    '*/test/badsyntax_*.py',
+    '*/test/*/bad_coding.py',
+    '*/test/*/bad_coding2.py',
+    '*/test/*/badsyntax_*.py',
     '*/lib2to3/tests/data/bom.py',
     '*/lib2to3/tests/data/crlf.py',
     '*/lib2to3/tests/data/different_encoding.py',
diff --git a/SPECS/python3.11.spec b/SPECS/python3.11.spec
index 5efb2cc662211eb3383d66e30b30097f7705c461..52c189df783abbd5d05e35e5824724f6459c8c8d 100644
--- a/SPECS/python3.11.spec
+++ b/SPECS/python3.11.spec
@@ -16,11 +16,11 @@ URL: https://www.python.org/
 
 #  WARNING  When rebasing to a new Python version,
 #           remember to update the python3-docs package as well
-%global general_version %{pybasever}.5
+%global general_version %{pybasever}.7
 #global prerel ...
 %global upstream_version %{general_version}%{?prerel}
 Version: %{general_version}%{?prerel:~%{prerel}}
-Release: 2%{?dist}
+Release: 1%{?dist}
 License: Python
 
 
@@ -1023,6 +1023,10 @@ for tool in pygettext msgfmt; do
   ln -s ${tool}%{pybasever}.py %{buildroot}%{_bindir}/${tool}3.py
 done
 
+# Install missing test data
+# Fixed upstream: https://github.com/python/cpython/pull/112784
+cp -rp Lib/test/regrtestdata/ %{buildroot}%{pylibdir}/test/
+
 # Switch all shebangs to refer to the specific Python version.
 # This currently only covers files matching ^[a-zA-Z0-9_]+\.py$,
 # so handle files named using other naming scheme separately.
@@ -1835,6 +1839,10 @@ fi
 # ======================================================
 
 %changelog
+* Mon Jan 22 2024 Charalampos Stratakis <cstratak@redhat.com> - 3.11.7-1
+- Rebase to 3.11.7
+Resolves: RHEL-21915
+
 * Tue Jan 09 2024 Lumír Balhar <lbalhar@redhat.com> - 3.11.5-2
 - Security fix for CVE-2023-27043
 Resolves: RHEL-7842