From b90ffffaa2fc5b94987bc1ff2b224517605fb6be Mon Sep 17 00:00:00 2001
From: Peridot Bot <rockyautomation@rockylinux.org>
Date: Wed, 2 Nov 2022 15:56:13 +0000
Subject: [PATCH] import zlib-1.2.11-32.el9_0

---
 SOURCES/zlib-1.2.11-cve-2022-37434.patch   | 35 ++++++++++++++++++++++
 SOURCES/zlib-1.2.11-cve-2022-37434_2.patch | 32 ++++++++++++++++++++
 SPECS/zlib.spec                            | 13 +++++++-
 3 files changed, 79 insertions(+), 1 deletion(-)
 create mode 100644 SOURCES/zlib-1.2.11-cve-2022-37434.patch
 create mode 100644 SOURCES/zlib-1.2.11-cve-2022-37434_2.patch

diff --git a/SOURCES/zlib-1.2.11-cve-2022-37434.patch b/SOURCES/zlib-1.2.11-cve-2022-37434.patch
new file mode 100644
index 0000000..1f3aa8d
--- /dev/null
+++ b/SOURCES/zlib-1.2.11-cve-2022-37434.patch
@@ -0,0 +1,35 @@
+From eff308af425b67093bab25f80f1ae950166bece1 Mon Sep 17 00:00:00 2001
+From: Mark Adler <fork@madler.net>
+Date: Sat, 30 Jul 2022 15:51:11 -0700
+Subject: [PATCH] Fix a bug when getting a gzip header extra field with
+ inflate().
+
+If the extra field was larger than the space the user provided with
+inflateGetHeader(), and if multiple calls of inflate() delivered
+the extra header data, then there could be a buffer overflow of the
+provided space. This commit assures that provided space is not
+exceeded.
+---
+ inflate.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/inflate.c b/inflate.c
+index 7be8c63..7a72897 100644
+--- a/inflate.c
++++ b/inflate.c
+@@ -763,9 +763,10 @@ int flush;
+                 copy = state->length;
+                 if (copy > have) copy = have;
+                 if (copy) {
++                    len = state->head->extra_len - state->length;
+                     if (state->head != Z_NULL &&
+-                        state->head->extra != Z_NULL) {
+-                        len = state->head->extra_len - state->length;
++                        state->head->extra != Z_NULL &&
++                        len < state->head->extra_max) {
+                         zmemcpy(state->head->extra + len, next,
+                                 len + copy > state->head->extra_max ?
+                                 state->head->extra_max - len : copy);
+-- 
+2.35.3
+
diff --git a/SOURCES/zlib-1.2.11-cve-2022-37434_2.patch b/SOURCES/zlib-1.2.11-cve-2022-37434_2.patch
new file mode 100644
index 0000000..d0e9d1b
--- /dev/null
+++ b/SOURCES/zlib-1.2.11-cve-2022-37434_2.patch
@@ -0,0 +1,32 @@
+From 1eb7682f845ac9e9bf9ae35bbfb3bad5dacbd91d Mon Sep 17 00:00:00 2001
+From: Mark Adler <fork@madler.net>
+Date: Mon, 8 Aug 2022 10:50:09 -0700
+Subject: [PATCH] Fix extra field processing bug that dereferences NULL
+ state->head.
+
+The recent commit to fix a gzip header extra field processing bug
+introduced the new bug fixed here.
+---
+ inflate.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/inflate.c b/inflate.c
+index 7a72897..2a3c4fe 100644
+--- a/inflate.c
++++ b/inflate.c
+@@ -763,10 +763,10 @@ int flush;
+                 copy = state->length;
+                 if (copy > have) copy = have;
+                 if (copy) {
+-                    len = state->head->extra_len - state->length;
+                     if (state->head != Z_NULL &&
+                         state->head->extra != Z_NULL &&
+-                        len < state->head->extra_max) {
++                        (len = state->head->extra_len - state->length) <
++                            state->head->extra_max) {
+                         zmemcpy(state->head->extra + len, next,
+                                 len + copy > state->head->extra_max ?
+                                 state->head->extra_max - len : copy);
+-- 
+2.35.3
+
diff --git a/SPECS/zlib.spec b/SPECS/zlib.spec
index 45c9bdc..4dc1591 100644
--- a/SPECS/zlib.spec
+++ b/SPECS/zlib.spec
@@ -2,7 +2,7 @@
 
 Name:    zlib
 Version: 1.2.11
-Release: 31%{?dist}.1
+Release: 32%{?dist}
 Summary: Compression and decompression library
 # /contrib/dotzlib/ have Boost license
 License: zlib and Boost
@@ -37,6 +37,11 @@ Patch15: zlib-1.2.11-covscan-issues-rhel9.patch
 Patch16: zlib-1.2.11-s390x-vectorize-crc32.patch
 Patch18: zlib-1.2.11-CVE-2018-25032.patch
 
+# Fix for CVE-2022-37434
+Patch19: zlib-1.2.11-cve-2022-37434.patch
+Patch20: zlib-1.2.11-cve-2022-37434_2.patch
+
+
 BuildRequires: make
 BuildRequires: automake, autoconf, libtool
 
@@ -105,6 +110,8 @@ developing applications which use minizip.
 %patch15 -p1
 %patch16 -p1
 %patch18 -p1
+%patch19 -p1
+%patch20 -p1
 
 
 iconv -f iso-8859-2 -t utf-8 < ChangeLog > ChangeLog.tmp
@@ -182,6 +189,10 @@ find $RPM_BUILD_ROOT -name '*.la' -delete
 
 
 %changelog
+* Wed Aug 10 2022 Matej Mužila <mmuzila@redhat.com> - 1.2.11-32
+- Fix heap-based buffer over-read or buffer overflow in inflate in inflate.c
+- Resolves: CVE-2022-37434
+
 * Mon Apr 25 2022 Matej Mužila <mmuzila@redhat.com> - 1.2.11-31.1
 - Fix CVE-2018-25032
   Resolves: CVE-2018-25032
-- 
GitLab