diff --git a/.gitignore b/.gitignore
index 0144cb890624c8880ea3dbdf07c3dc5a57476d33..9a334a052509f72eb8f6cbf7b80c8eab29299813 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1 @@
-SOURCES/go-go-1.13.4-1-openssl-fips.tar.gz
+SOURCES/go-go-1.13.15-1-openssl-fips.tar.gz
diff --git a/.golang.metadata b/.golang.metadata
index c6b3f801cb05ebea82a0d10e04ccd3e0353c41f9..703b625e247d149bdf5ad79505b8da73e71b841e 100644
--- a/.golang.metadata
+++ b/.golang.metadata
@@ -1 +1 @@
-c9f2a53028d012c6db32a34a9345e08aba31a771 SOURCES/go-go-1.13.4-1-openssl-fips.tar.gz
+574abf1c8b1891c9b37c09a231365d2b78a5faaa SOURCES/go-go-1.13.15-1-openssl-fips.tar.gz
diff --git a/SPECS/golang.spec b/SPECS/golang.spec
index 8b341e5ffd67d5cf7a2f14ec39ab5862597e6fc3..112b0a447536ee160adbabc25bc69c1595a4657f 100644
--- a/SPECS/golang.spec
+++ b/SPECS/golang.spec
@@ -29,7 +29,7 @@
 # Define GOROOT macros
 %global goroot          %{_prefix}/lib/%{name}
 %global gopath          %{_datadir}/gocode
-%global golang_arches   %{ix86} x86_64 aarch64 ppc64le s390x %{arm}
+%global golang_arches   %{ix86} x86_64 aarch64 ppc64le s390x
 %global golibdir        %{_libdir}/%{name}
 
 # Golang build options.
@@ -56,7 +56,7 @@
 %endif
 
 # Controls what ever we fail on failed tests
-%ifarch %{ix86} x86_64 aarch64 ppc64le
+%ifarch %{ix86} x86_64 %{arm} aarch64 ppc64le
 %global fail_on_tests 1
 %else
 %global fail_on_tests 0
@@ -99,12 +99,12 @@
 %endif
 
 %global go_api 1.13
-%global go_version 1.13.4
+%global go_version 1.13.15
 %global pkg_release 1
 
 Name:           golang
 Version:        %{go_version}
-Release:        2%{?dist}
+Release:        1%{?dist}
 Summary:        The Go Programming Language
 # source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
 License:        BSD and Public Domain
@@ -505,6 +505,23 @@ cd ..
 %endif
 
 %changelog
+* Fri Aug 14 2020 Alejandro Sáez <asm@redhat.com> - 1.13.15-1
+- Rebase to 1.13.15
+- Related: rhbz#1865875
+- Related: rhbz#1865873
+
+* Sat Aug 08 2020 Alejandro Sáez <asm@redhat.com> - 1.13.14-2
+- Rebase to 1.13.14
+- Bump up x/text to v0.3.3 fixing. This should have been done in the previous
+  commit
+- Resolves: rhbz#1865875
+- Resolves: rhbz#1865873
+
+* Wed Aug 05 2020 Alejandro Sáez <asm@redhat.com> - 1.13.14-1
+- Rebase to 1.13.14
+- Resolves: rhbz#1865875
+- Resolves: rhbz#1865873
+
 * Wed Nov 27 2019 Alejandro Sáez <asm@redhat.com> - 1.13.4-2
 - Remove patches
 - Related: rhbz#1747150