diff --git a/SPECS/golang.spec b/SPECS/golang.spec
index e8e78793e3e1d38d1df2306f6a8d99d08f13e55b..288113e6d24cf8bbddc7251ab8e917a5dc7f7c75 100644
--- a/SPECS/golang.spec
+++ b/SPECS/golang.spec
@@ -29,7 +29,7 @@
 # Define GOROOT macros
 %global goroot          %{_prefix}/lib/%{name}
 %global gopath          %{_datadir}/gocode
-%global golang_arches   %{ix86} x86_64 aarch64 ppc64le s390x
+%global golang_arches   %{ix86} x86_64 aarch64 ppc64le s390x %{arm}
 %global golibdir        %{_libdir}/%{name}
 
 # Golang build options.
@@ -56,7 +56,7 @@
 %endif
 
 # Controls what ever we fail on failed tests
-%ifarch %{ix86} x86_64 %{arm} aarch64 ppc64le
+%ifarch %{ix86} x86_64 aarch64 ppc64le
 %global fail_on_tests 1
 %else
 %global fail_on_tests 0