From 64b15080b88e47b03e091123b5c6bd34d0cfb99e Mon Sep 17 00:00:00 2001
From: importbot <releng@rockylinux.org>
Date: Thu, 24 Oct 2024 18:57:58 +0000
Subject: [PATCH] import java-21-openjdk-21.0.5.0.11-2.el10

---
 .java-21-openjdk.checksum                 |   2 +-
 .java-21-openjdk.metadata                 |   2 +-
 SOURCES/NEWS                              |   1 +
 SOURCES/java-21-openjdk-portable.specfile |  11 +-
 SOURCES/jdk8327501-8328366-revert.patch   |  49 --------
 SPECS/java-21-openjdk.spec                | 135 +++++++++++-----------
 6 files changed, 75 insertions(+), 125 deletions(-)
 delete mode 100644 SOURCES/jdk8327501-8328366-revert.patch

diff --git a/.java-21-openjdk.checksum b/.java-21-openjdk.checksum
index 867cbab..54495ba 100644
--- a/.java-21-openjdk.checksum
+++ b/.java-21-openjdk.checksum
@@ -1 +1 @@
-7fbc4d1523de02eecbe06e434ba398a0639f8fb1a76c64cb3ac6c26a66577c56
+Direct Git Import
diff --git a/.java-21-openjdk.metadata b/.java-21-openjdk.metadata
index 2365781..1cc0ffa 100644
--- a/.java-21-openjdk.metadata
+++ b/.java-21-openjdk.metadata
@@ -1,2 +1,2 @@
-4892cc53511a8c9fe97ac7fe3fb9fe40ad21d04fa3f2f8fabe614187984f1de1  SOURCES/openjdk-21.0.5+10.tar.xz
+8a5d8be31d83edead93b02c7495960f969ddea38b59426a8d7b45aaadd82a960  SOURCES/openjdk-21.0.5+11.tar.xz
 d8a785cc9cc71745c17ecb9e5f0f919e7776b2f21584634f1eb71e4c7e813d6f  SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
diff --git a/SOURCES/NEWS b/SOURCES/NEWS
index a98df8b..14892cb 100644
--- a/SOURCES/NEWS
+++ b/SOURCES/NEWS
@@ -376,6 +376,7 @@ Live versions of these release notes can be found at:
   - JDK-8341057: Add 2 SSL.com TLS roots
   - JDK-8341059: Change Entrust TLS distrust date to November 12, 2024
   - JDK-8341674: [21u] Remove designator DEFAULT_PROMOTED_VERSION_PRE=ea for release 21.0.5
+  - JDK-8341989: [21u] Back out JDK-8327501 and JDK-8328366
 
 Notes on individual issues:
 ===========================
diff --git a/SOURCES/java-21-openjdk-portable.specfile b/SOURCES/java-21-openjdk-portable.specfile
index ec8c58b..3c0a46a 100644
--- a/SOURCES/java-21-openjdk-portable.specfile
+++ b/SOURCES/java-21-openjdk-portable.specfile
@@ -381,7 +381,7 @@
 %global origin_nice     OpenJDK
 %global top_level_dir_name   %{vcstag}
 %global top_level_dir_name_backup %{top_level_dir_name}-backup
-%global buildver        10
+%global buildver        11
 %global rpmrelease      1
 #%%global tagsuffix     %%{nil}
 # Priority must be 8 digits in total; up to openjdk 1.8, we were using 18..... so when we moved to 11, we had to add another digit
@@ -652,8 +652,6 @@ Patch1001: fips-%{featurever}u-%{fipsver}.patch
 # OpenJDK patches in need of upstreaming
 #
 #############################################
-# Revert backport of JDK-8327501 & JDK-8328366
-Patch2001: jdk8327501-8328366-revert.patch
 
 # Currently empty
 
@@ -963,8 +961,6 @@ sh %{SOURCE12} %{top_level_dir_name}
 pushd %{top_level_dir_name}
 # Add crypto policy and FIPS support
 %patch -P1001 -p1
-# Backport reversion
-%patch -P2001 -p1
 popd # openjdk
 
 
@@ -1842,6 +1838,11 @@ done
 %endif
 
 %changelog
+* Wed Oct 16 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.11-1
+- Update to jdk-21.0.5+11 (GA)
+- Update release notes to 21.0.5+11
+- Remove local JDK-8327501 & JDK-8328366 backport as this is now upstream.
+
 * Sat Oct 12 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.10-1
 - Update to jdk-21.0.5+10 (GA)
 - Update release notes to 21.0.5+10
diff --git a/SOURCES/jdk8327501-8328366-revert.patch b/SOURCES/jdk8327501-8328366-revert.patch
deleted file mode 100644
index ea5eb16..0000000
--- a/SOURCES/jdk8327501-8328366-revert.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-commit f21b0a990905afe79b56919a5119e2c06e29d61a
-Author: Andrew John Hughes <gnu_andrew@member.fsf.org>
-Date:   Sat Oct 12 02:31:38 2024 +0100
-
-    Revert "8327501: Common ForkJoinPool prevents class unloading in some cases"
-    
-    This reverts commit eb103b0e1abeeee19779cafc763d3d159030fb48.
-
-diff --git a/src/java.base/share/classes/java/util/concurrent/ForkJoinPool.java b/src/java.base/share/classes/java/util/concurrent/ForkJoinPool.java
-index 8aafda5312e..5e698b1540f 100644
---- a/src/java.base/share/classes/java/util/concurrent/ForkJoinPool.java
-+++ b/src/java.base/share/classes/java/util/concurrent/ForkJoinPool.java
-@@ -981,7 +981,9 @@ public class ForkJoinPool extends AbstractExecutorService {
-             boolean isCommon = (pool.workerNamePrefix == null);
-             @SuppressWarnings("removal")
-             SecurityManager sm = System.getSecurityManager();
--            if (sm != null && isCommon)
-+            if (sm == null)
-+                return new ForkJoinWorkerThread(null, pool, true, false);
-+            else if (isCommon)
-                 return newCommonWithACC(pool);
-             else
-                 return newRegularWithACC(pool);
-diff --git a/test/jdk/java/util/concurrent/tck/ForkJoinPool9Test.java b/test/jdk/java/util/concurrent/tck/ForkJoinPool9Test.java
-index a87aa7b916b..266c2a036fe 100644
---- a/test/jdk/java/util/concurrent/tck/ForkJoinPool9Test.java
-+++ b/test/jdk/java/util/concurrent/tck/ForkJoinPool9Test.java
-@@ -79,9 +79,6 @@ public class ForkJoinPool9Test extends JSR166TestCase {
-             assertSame(ForkJoinPool.commonPool(), ForkJoinTask.getPool());
-             Thread currentThread = Thread.currentThread();
- 
--            ClassLoader preexistingContextClassLoader =
--                    currentThread.getContextClassLoader();
--
-             Stream.of(systemClassLoader, null).forEach(cl -> {
-                 if (randomBoolean())
-                     // should always be permitted, without effect
-@@ -98,11 +95,6 @@ public class ForkJoinPool9Test extends JSR166TestCase {
-                     () -> System.getProperty("foo"),
-                     () -> currentThread.setContextClassLoader(
-                         classLoaderDistinctFromSystemClassLoader));
--            else {
--                currentThread.setContextClassLoader(classLoaderDistinctFromSystemClassLoader);
--                assertSame(currentThread.getContextClassLoader(), classLoaderDistinctFromSystemClassLoader);
--                currentThread.setContextClassLoader(preexistingContextClassLoader);
--            }
-             // TODO ?
- //          if (haveSecurityManager
- //              && Thread.currentThread().getClass().getSimpleName()
diff --git a/SPECS/java-21-openjdk.spec b/SPECS/java-21-openjdk.spec
index 96368e0..addd439 100644
--- a/SPECS/java-21-openjdk.spec
+++ b/SPECS/java-21-openjdk.spec
@@ -102,9 +102,9 @@
 # similarly for other %%{_jvmdir}/{jre,java} and %%{_javadocdir}/{java,java-zip}
 %define is_release_build() %( if [ "%{?1}" == "%{debug_suffix_unquoted}" -o "%{?1}" == "%{fastdebug_suffix_unquoted}" ]; then echo "0" ; else echo "1"; fi )
 
-# while JDK is a techpreview(is_system_jdk=0), some provides are turned off. Once jdk stops to be an techpreview, move it to 1
-# as sytem JDK, we mean any JDK which can run whole system java stack without issues (like bytecode issues, module issues, dependencies...)
-%global is_system_jdk 0
+# Indicates whether this is the default JDK on this version of RHEL
+# Only the default/system JDK provides unversioned Provides like 'java', 'jre' and 'java-devel'
+%global is_system_jdk 1
 
 %global aarch64         aarch64 arm64 armv8
 # we need to distinguish between big and little endian PPC64
@@ -365,8 +365,8 @@
 %global origin_nice     OpenJDK
 %global top_level_dir_name   %{vcstag}
 %global top_level_dir_name_backup %{top_level_dir_name}-backup
-%global buildver        10
-%global rpmrelease      3
+%global buildver        11
+%global rpmrelease      2
 # Settings used by the portable build
 %global portablerelease 1
 # Portable suffix differs between RHEL and CentOS
@@ -1420,8 +1420,6 @@ Patch1001: fips-%{featurever}u-%{fipsver}.patch
 # OpenJDK patches in need of upstreaming
 #
 #############################################
-# Revert backport of JDK-8327501 & JDK-8328366
-Patch2001: jdk8327501-8328366-revert.patch
 
 # Currently empty
 
@@ -1897,8 +1895,6 @@ sh %{SOURCE12} %{top_level_dir_name}
 pushd %{top_level_dir_name}
 # Add crypto policy and FIPS support
 %patch -P1001 -p1
-# Backport reversion
-%patch -P2001 -p1
 popd # openjdk
 
 
@@ -2536,10 +2532,17 @@ cjc.mainProgram(args)
 %endif
 
 %changelog
+* Wed Oct 16 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.11-2
+- Update to jdk-21.0.5+11 (GA)
+- Update release notes to 21.0.5+11
+- Remove local JDK-8327501 & JDK-8328366 backport as this is now upstream.
+- Sync the copy of the portable specfile with the latest update
+- Related: RHEL-61276
+
 * Sun Oct 13 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.10-3
 - Sync the copy of the portable specfile with the latest update
 - ** This tarball is embargoed until 2024-10-15 @ 1pm PT. **
-- Related: RHEL-61344
+- Related: RHEL-61276
 
 * Sat Oct 12 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.10-2
 - Update to jdk-21.0.5+10 (GA)
@@ -2547,9 +2550,9 @@ cjc.mainProgram(args)
 - Switch to GA mode.
 - Revert JDK-8327501 & JDK-8328366 backport until more mature.
 - ** This tarball is embargoed until 2024-10-15 @ 1pm PT. **
-- Resolves: RHEL-61344
+- Resolves: RHEL-61276
 
-* Fri Oct 11 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.9-0.2.ea
+* Fri Oct 11 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.9-0.1.ea
 - Update to jdk-21.0.5+9 (EA)
 - Update release notes to 21.0.5+9
 - Switch to EA mode
@@ -2558,35 +2561,32 @@ cjc.mainProgram(args)
 - Sync with RHEL 7 portable build:
   - Use ExclusiveArch over ExcludeArch
   - pkgos definition needs to be early enough to be used in portablesuffix
+- Add build scripts to repository to ease remembering all CentOS & RHEL targets and options
 - Make build scripts executable
 - Sync the copy of the portable specfile with the latest update
-- Resolves: RHEL-58797
-- Resolves: RHEL-17191
+- Resolves: RHEL-62239
+- Resolves: RHEL-62241
 
-* Mon Oct 07 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.4.0.7-2
-- Vary portablesuffix depending on whether we are on RHEL ('el8') or CentOS ('el9')
-- Handle debugedit being a separate package installed in /usr on RHEL/CentOS 10
-- Add build scripts to repository to ease remembering all CentOS & RHEL targets and options
-- Related: RHEL-58797
-
-* Fri Jul 12 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.4.0.7-1
+* Sun Aug 04 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.4.0.7-1
 - Update to jdk-21.0.4+7 (GA)
 - Update release notes to 21.0.4+7
 - Switch to GA mode.
 - Sync the copy of the portable specfile with the latest update
 - Add missing section headers in NEWS
+- Vary portablesuffix depending on whether we are on RHEL ('el8') or CentOS ('el9')
 - ** This tarball is embargoed until 2024-07-16 @ 1pm PT. **
-- Resolves: RHEL-47023
+- Resolves: RHEL-47024
 
-* Wed Jun 26 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.4.0.5-0.1.ea
+* Sun Aug 04 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.4.0.5-0.1.ea
 - Update to jdk-21.0.4+5 (EA)
 - Update release notes to 21.0.4+5
 - Limit Java only tests to one architecture using jdk_test_arch
 - Actually require tzdata 2024a now it is available in the buildroot
-- Resolves: RHEL-45355
-- Resolves: RHEL-47395
+- Resolves: RHEL-45357
+- Resolves: RHEL-52735
+- Related: RHEL-52723
 
-* Sat Jun 22 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.4.0.1-0.1.ea
+* Sun Aug 04 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.4.0.1-0.1.ea
 - Update to jdk-21.0.4+1 (EA)
 - Update release notes to 21.0.4+1
 - Switch to EA mode
@@ -2594,27 +2594,27 @@ cjc.mainProgram(args)
 - Add zlib build requirement or bundled version (1.3.1), depending on system_libs setting
 - Restore NEWS file so portable can be rebuilt
 - Sync the copy of the portable specfile with the latest update
-- Related: RHEL-45355
-- Resolves: RHEL-46029
+- Related: RHEL-45357
+- Resolves: RHEL-46026
 
-* Sun Apr 14 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.3.0.9-1
+* Sun Aug 04 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.3.0.9-1
 - Update to jdk-21.0.3+9 (GA)
 - Update release notes to 21.0.3+9
 - Switch to GA mode.
 - Sync the copy of the portable specfile with the latest update
 - ** This tarball is embargoed until 2024-04-16 @ 1pm PT. **
-- Resolves: RHEL-32424
+- Resolves: RHEL-32427
 
-* Sun Apr 14 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.3.0.7-0.1.ea
+* Sun Aug 04 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.3.0.7-0.1.ea
 - Update to jdk-21.0.3+7 (EA)
 - Update release notes to 21.0.3+7
 - Require tzdata 2024a due to upstream inclusion of JDK-8322725
 - Only require tzdata 2023d for now as 2024a is unavailable in buildroot
 - Drop JDK-8009550 which is now available upstream
 - Re-generate FIPS patch against 21.0.3+7 following backport of JDK-8325254
-- Resolves: RHEL-30946
+- Resolves: RHEL-52723
 
-* Sun Apr 14 2024 Thomas Fitzsimmons <fitzsim@redhat.com> - 1:21.0.3.0.1-0.2.ea
+* Sat Aug 03 2024 Thomas Fitzsimmons <fitzsim@redhat.com> - 1:21.0.3.0.1-0.1.ea
 - Invoke xz in multi-threaded mode
 - generate_source_tarball.sh: Add WITH_TEMP environment variable
 - generate_source_tarball.sh: Multithread xz on all available cores
@@ -2643,9 +2643,14 @@ cjc.mainProgram(args)
 - generate_source_tarball.sh: Use long-style argument to grep
 - generate_source_tarball.sh: Add license
 - generate_source_tarball.sh: Add indentation instructions for Emacs
-- Related: RHEL-30946
+- Related: RHEL-52723
 
-* Sun Apr 14 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.3.0.1-0.2.ea
+* Sat Aug 03 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.3.0.1-0.1.ea
+- Update to jdk-21.0.3+1 (EA)
+- Update release notes to 21.0.3+1
+- Switch to EA mode
+- Require tzdata 2023d due to local inclusion of JDK-8322725
+- Bump FreeType version to 2.13.2 following JDK-8316028
 - Install alt-java man page from the misc tarball as it is no longer in the JDK image
 - generate_source_tarball.sh: Update examples in header for clarity
 - generate_source_tarball.sh: Cleanup message issued when checkout already exists
@@ -2667,19 +2672,18 @@ cjc.mainProgram(args)
 - generate_source_tarball.sh: Output values of new options WITH_TEMP and OPENJDK_LATEST
 - generate_source_tarball.sh: Double-quote DEPTH reference (SC2086)
 - generate_source_tarball.sh: Avoid empty DEPTH reference while still appeasing shellcheck
-- Related: RHEL-30946
+- Related: RHEL-52723
 
-* Sun Apr 14 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.3.0.1-0.1.ea
-- Update to jdk-21.0.3+1 (EA)
-- Update release notes to 21.0.3+1
-- Switch to EA mode
-- Require tzdata 2023d due to upstream inclusion of JDK-8322725
-- Bump FreeType version to 2.13.2 following JDK-8316028
-- Related: RHEL-30946
+* Tue Jul 30 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.2.0.13-3
+- Fix gating.yaml to reference RHEL 10
+- Set this to be the default/system JDK providing 'java', 'jre', 'java-devel' ,etc.
+- Resolves: RHEL-34597
+- Resolves: RHEL-51617
 
 * Fri Apr 12 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.2.0.13-2
 - Define portablesuffix according to whether pkgos is defined or not
-- Related: RHEL-30946
+- Handle debugedit being a separate package installed in /usr on RHEL/CentOS 10
+- Related: RHEL-45217
 
 * Tue Jan 09 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.2.0.13-1
 - Update to jdk-21.0.2+13 (GA)
@@ -2688,16 +2692,16 @@ cjc.mainProgram(args)
 - Bump HarfBuzz version to 8.2.2 following JDK-8313643
 - Drop local JDK-8311630 patch which is now upstream
 - ** This tarball is embargoed until 2024-01-16 @ 1pm PT. **
-- Resolves: RHEL-20999
+- Resolves: RHEL-45217
 
 * Mon Nov 06 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.1.0.12-3
 - Include JDK-8311630 patch to implement Foreign Function & Memory preview API on s390x
 - Sync the copy of the portable specfile with the latest update
-- Resolves: RHEL-16290
+- Related: RHEL-45217
 
 * Mon Oct 30 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.1.0.12-2
 - Define pkgnameroot to simplify build requirements and allow '-rhel7' suffix on RHEL
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Fri Oct 27 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.1.0.12-1
 - Update to jdk-21.0.1.0+12 (GA)
@@ -2719,21 +2723,15 @@ cjc.mainProgram(args)
 - Add missing jfr, jpackage and jwebserver alternative ghosts
 - Move jcmd to the headless package
 - Revert alt-java binary location to being within the JDK tree
-- Resolves: RHEL-12998
-- Resolves: RHEL-14953
-- Resolves: RHEL-13925
-- Resolves: RHEL-14957
-- Related: RHEL-14945
-- Resolves: RHEL-11321
-- Resolves: RHEL-14947
+- Related: RHEL-45217
 
 * Fri Oct 27 2023 Jiri Vanek <jvanek@redhat.com> - 1:21.0.1.0.12-1
 - Exclude classes_nocoops.jsa on i686 and arm32
-- Related: RHEL-14945
+- Related: RHEL-45217
 
 * Fri Oct 27 2023 Severin Gehwolf <sgehwolf@redhat.com> - 1:21.0.1.0.12-1
 - Fix packaging of CDS archives
-- Resolves: RHEL-14945
+- Resolves: RHEL-45217
 
 * Thu Aug 24 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.0.0.35-2
 - Update documentation (README.md)
@@ -2744,7 +2742,7 @@ cjc.mainProgram(args)
 - * No use of system libjpeg turbo to warrant RH649512 patch any more
 - Replace RH1684077 pcsc-lite-libs patch with better JDK-8009550 fix being upstreamed
 - Adapt alt-java test to new binary where there is always a set_speculation function
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Mon Aug 21 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.0.0.35-1
 - Update to jdk-21.0.0+35
@@ -2756,12 +2754,11 @@ cjc.mainProgram(args)
 - Re-enable tzdata tests now we are on the latest JDK and things are back in sync
 - Install jaxp.properties introduced by JDK-8303530
 - Install lible.so introduced by JDK-8306983
-- Related: RHEL-12998
-- Resolves: RHEL-41087
+- Related: RHEL-45217
 
 * Mon Aug 21 2023 Petra Alice Mikova <pmikova@redhat.com> - 1:21.0.0.0.35-1
 - Replace smoke test files used in the staticlibs test, as fdlibm was removed by JDK-8303798
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Wed Aug 16 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:20.0.0.0.36-1
 - Update to jdk-20.0.2+9
@@ -2769,12 +2766,12 @@ cjc.mainProgram(args)
 - Update system crypto policy & FIPS patch from new fips-20u tree
 - Update generate_tarball.sh ICEDTEA_VERSION
 - Update CLDR reference data following update to 42 (Rocky Mountain-Normalzeit => Rocky-Mountain-Normalzeit)
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Wed Aug 16 2023 Jiri Vanek <jvanek@redhat.com> - 1:20.0.0.0.36-1
 - Dropped JDK-8295447, JDK-8296239 & JDK-8299439 patches now upstream
 - Adapted rh1750419-redhat_alt_java.patch
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Tue Aug 15 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:19.0.1.0.10-1
 - Update to jdk-19.0.2 release
@@ -2783,7 +2780,7 @@ cjc.mainProgram(args)
 - Remove references to sample directory removed by JDK-8284999
 - Add local patch JDK-8295447 (javac NPE) which was accepted into 19u upstream but not in the GA tag
 - Add local patches for JDK-8296239 & JDK-8299439 (Croatia Euro update) which are present in 8u, 11u & 17u releases
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Thu Aug 10 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:18.0.2.0.9-1
 - Update to jdk-18.0.2 release
@@ -2794,26 +2791,26 @@ cjc.mainProgram(args)
 - Drop tzdata patches added for 17.0.7 which will eventually appear in the upstream tarball when we reach OpenJDK 21
 - Disable tzdata tests until we are on the latest JDK and things are back in sync
 - Use empty nss.fips.cfg until it is again available via the FIPS patch
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Thu Aug 10 2023 Petra Alice Mikova <pmikova@redhat.com> - 1:18.0.2.0.9-1
 - Update to ea version of jdk18
 - Add new slave jwebserver and corresponding manpage
 - Adjust rh1684077-openjdk_should_depend_on_pcsc-lite-libs_instead_of_pcsc-lite-devel.patch
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Thu Aug 10 2023 FeRD (Frank Dana) <ferdnyc@gmail.com> - 1:18.0.2.0.9-1
 - Add javaver- and origin-specific javadoc and javadoczip alternatives.
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Tue Aug 08 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.7.0.7-4
 - Set portablerelease and portablerhel to use the CentOS 9 build
-- Related: RHEL-12998
+- Related: RHEL-45217
 
 * Tue Aug 08 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.7.0.7-4
 - Add files missed by centpkg import.
-- Related: rhbz#2192748
+- Related: RHEL-45217
 
 * Fri Aug 04 2023 Andrew Hughes <gnu.andrew@redhat.com> - 1:17.0.7.0.7-3
 - Create java-21-openjdk package based on java-17-openjdk
-- Related: rhbz#2192748
+- Related: RHEL-45217
-- 
GitLab