From d82771818e190efb5aecc24dae89a93efc596760 Mon Sep 17 00:00:00 2001
From: importbot <releng@rockylinux.org>
Date: Tue, 12 Nov 2024 11:18:08 +0000
Subject: [PATCH] import java-21-openjdk-21.0.5.0.11-2.el9

---
 .java-21-openjdk.checksum                 |  2 +-
 .java-21-openjdk.metadata                 |  2 +-
 SOURCES/NEWS                              |  1 +
 SOURCES/java-21-openjdk-portable.specfile | 11 ++---
 SOURCES/jdk8327501-8328366-revert.patch   | 49 -----------------------
 SPECS/java-21-openjdk.spec                | 15 ++++---
 6 files changed, 18 insertions(+), 62 deletions(-)
 delete mode 100644 SOURCES/jdk8327501-8328366-revert.patch

diff --git a/.java-21-openjdk.checksum b/.java-21-openjdk.checksum
index 867cbab..4cc0814 100644
--- a/.java-21-openjdk.checksum
+++ b/.java-21-openjdk.checksum
@@ -1 +1 @@
-7fbc4d1523de02eecbe06e434ba398a0639f8fb1a76c64cb3ac6c26a66577c56
+6025a4f3a087159ce67e0f54b645f679c1293283af488fe4ce0f13bdbb35497f
diff --git a/.java-21-openjdk.metadata b/.java-21-openjdk.metadata
index 2365781..1cc0ffa 100644
--- a/.java-21-openjdk.metadata
+++ b/.java-21-openjdk.metadata
@@ -1,2 +1,2 @@
-4892cc53511a8c9fe97ac7fe3fb9fe40ad21d04fa3f2f8fabe614187984f1de1  SOURCES/openjdk-21.0.5+10.tar.xz
+8a5d8be31d83edead93b02c7495960f969ddea38b59426a8d7b45aaadd82a960  SOURCES/openjdk-21.0.5+11.tar.xz
 d8a785cc9cc71745c17ecb9e5f0f919e7776b2f21584634f1eb71e4c7e813d6f  SOURCES/tapsets-icedtea-6.0.0pre00-c848b93a8598.tar.xz
diff --git a/SOURCES/NEWS b/SOURCES/NEWS
index a98df8b..14892cb 100644
--- a/SOURCES/NEWS
+++ b/SOURCES/NEWS
@@ -376,6 +376,7 @@ Live versions of these release notes can be found at:
   - JDK-8341057: Add 2 SSL.com TLS roots
   - JDK-8341059: Change Entrust TLS distrust date to November 12, 2024
   - JDK-8341674: [21u] Remove designator DEFAULT_PROMOTED_VERSION_PRE=ea for release 21.0.5
+  - JDK-8341989: [21u] Back out JDK-8327501 and JDK-8328366
 
 Notes on individual issues:
 ===========================
diff --git a/SOURCES/java-21-openjdk-portable.specfile b/SOURCES/java-21-openjdk-portable.specfile
index ec8c58b..3c0a46a 100644
--- a/SOURCES/java-21-openjdk-portable.specfile
+++ b/SOURCES/java-21-openjdk-portable.specfile
@@ -381,7 +381,7 @@
 %global origin_nice     OpenJDK
 %global top_level_dir_name   %{vcstag}
 %global top_level_dir_name_backup %{top_level_dir_name}-backup
-%global buildver        10
+%global buildver        11
 %global rpmrelease      1
 #%%global tagsuffix     %%{nil}
 # Priority must be 8 digits in total; up to openjdk 1.8, we were using 18..... so when we moved to 11, we had to add another digit
@@ -652,8 +652,6 @@ Patch1001: fips-%{featurever}u-%{fipsver}.patch
 # OpenJDK patches in need of upstreaming
 #
 #############################################
-# Revert backport of JDK-8327501 & JDK-8328366
-Patch2001: jdk8327501-8328366-revert.patch
 
 # Currently empty
 
@@ -963,8 +961,6 @@ sh %{SOURCE12} %{top_level_dir_name}
 pushd %{top_level_dir_name}
 # Add crypto policy and FIPS support
 %patch -P1001 -p1
-# Backport reversion
-%patch -P2001 -p1
 popd # openjdk
 
 
@@ -1842,6 +1838,11 @@ done
 %endif
 
 %changelog
+* Wed Oct 16 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.11-1
+- Update to jdk-21.0.5+11 (GA)
+- Update release notes to 21.0.5+11
+- Remove local JDK-8327501 & JDK-8328366 backport as this is now upstream.
+
 * Sat Oct 12 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.10-1
 - Update to jdk-21.0.5+10 (GA)
 - Update release notes to 21.0.5+10
diff --git a/SOURCES/jdk8327501-8328366-revert.patch b/SOURCES/jdk8327501-8328366-revert.patch
deleted file mode 100644
index ea5eb16..0000000
--- a/SOURCES/jdk8327501-8328366-revert.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-commit f21b0a990905afe79b56919a5119e2c06e29d61a
-Author: Andrew John Hughes <gnu_andrew@member.fsf.org>
-Date:   Sat Oct 12 02:31:38 2024 +0100
-
-    Revert "8327501: Common ForkJoinPool prevents class unloading in some cases"
-    
-    This reverts commit eb103b0e1abeeee19779cafc763d3d159030fb48.
-
-diff --git a/src/java.base/share/classes/java/util/concurrent/ForkJoinPool.java b/src/java.base/share/classes/java/util/concurrent/ForkJoinPool.java
-index 8aafda5312e..5e698b1540f 100644
---- a/src/java.base/share/classes/java/util/concurrent/ForkJoinPool.java
-+++ b/src/java.base/share/classes/java/util/concurrent/ForkJoinPool.java
-@@ -981,7 +981,9 @@ public class ForkJoinPool extends AbstractExecutorService {
-             boolean isCommon = (pool.workerNamePrefix == null);
-             @SuppressWarnings("removal")
-             SecurityManager sm = System.getSecurityManager();
--            if (sm != null && isCommon)
-+            if (sm == null)
-+                return new ForkJoinWorkerThread(null, pool, true, false);
-+            else if (isCommon)
-                 return newCommonWithACC(pool);
-             else
-                 return newRegularWithACC(pool);
-diff --git a/test/jdk/java/util/concurrent/tck/ForkJoinPool9Test.java b/test/jdk/java/util/concurrent/tck/ForkJoinPool9Test.java
-index a87aa7b916b..266c2a036fe 100644
---- a/test/jdk/java/util/concurrent/tck/ForkJoinPool9Test.java
-+++ b/test/jdk/java/util/concurrent/tck/ForkJoinPool9Test.java
-@@ -79,9 +79,6 @@ public class ForkJoinPool9Test extends JSR166TestCase {
-             assertSame(ForkJoinPool.commonPool(), ForkJoinTask.getPool());
-             Thread currentThread = Thread.currentThread();
- 
--            ClassLoader preexistingContextClassLoader =
--                    currentThread.getContextClassLoader();
--
-             Stream.of(systemClassLoader, null).forEach(cl -> {
-                 if (randomBoolean())
-                     // should always be permitted, without effect
-@@ -98,11 +95,6 @@ public class ForkJoinPool9Test extends JSR166TestCase {
-                     () -> System.getProperty("foo"),
-                     () -> currentThread.setContextClassLoader(
-                         classLoaderDistinctFromSystemClassLoader));
--            else {
--                currentThread.setContextClassLoader(classLoaderDistinctFromSystemClassLoader);
--                assertSame(currentThread.getContextClassLoader(), classLoaderDistinctFromSystemClassLoader);
--                currentThread.setContextClassLoader(preexistingContextClassLoader);
--            }
-             // TODO ?
- //          if (haveSecurityManager
- //              && Thread.currentThread().getClass().getSimpleName()
diff --git a/SPECS/java-21-openjdk.spec b/SPECS/java-21-openjdk.spec
index 96368e0..8e6725b 100644
--- a/SPECS/java-21-openjdk.spec
+++ b/SPECS/java-21-openjdk.spec
@@ -365,8 +365,8 @@
 %global origin_nice     OpenJDK
 %global top_level_dir_name   %{vcstag}
 %global top_level_dir_name_backup %{top_level_dir_name}-backup
-%global buildver        10
-%global rpmrelease      3
+%global buildver        11
+%global rpmrelease      2
 # Settings used by the portable build
 %global portablerelease 1
 # Portable suffix differs between RHEL and CentOS
@@ -1420,8 +1420,6 @@ Patch1001: fips-%{featurever}u-%{fipsver}.patch
 # OpenJDK patches in need of upstreaming
 #
 #############################################
-# Revert backport of JDK-8327501 & JDK-8328366
-Patch2001: jdk8327501-8328366-revert.patch
 
 # Currently empty
 
@@ -1897,8 +1895,6 @@ sh %{SOURCE12} %{top_level_dir_name}
 pushd %{top_level_dir_name}
 # Add crypto policy and FIPS support
 %patch -P1001 -p1
-# Backport reversion
-%patch -P2001 -p1
 popd # openjdk
 
 
@@ -2536,6 +2532,13 @@ cjc.mainProgram(args)
 %endif
 
 %changelog
+* Wed Oct 16 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.11-2
+- Update to jdk-21.0.5+11 (GA)
+- Update release notes to 21.0.5+11
+- Remove local JDK-8327501 & JDK-8328366 backport as this is now upstream.
+- Sync the copy of the portable specfile with the latest update
+- Related: RHEL-61344
+
 * Sun Oct 13 2024 Andrew Hughes <gnu.andrew@redhat.com> - 1:21.0.5.0.10-3
 - Sync the copy of the portable specfile with the latest update
 - ** This tarball is embargoed until 2024-10-15 @ 1pm PT. **
-- 
GitLab