From adf69eb368ce1a6e6b93edfb6869fec32b3803f2 Mon Sep 17 00:00:00 2001
From: importbot <releng@rockylinux.org>
Date: Tue, 3 Sep 2024 17:58:43 +0000
Subject: [PATCH] import systemd-252-32.el9_4.7

---
 .systemd.checksum                             |  2 +-
 ...ne-generator_open_unit_file-and-gene.patch | 52 +++++++++++++++++++
 SPECS/systemd.spec                            |  6 ++-
 3 files changed, 58 insertions(+), 2 deletions(-)
 create mode 100644 SOURCES/0732-generator-uninline-generator_open_unit_file-and-gene.patch

diff --git a/.systemd.checksum b/.systemd.checksum
index 82b1c77..cdae112 100644
--- a/.systemd.checksum
+++ b/.systemd.checksum
@@ -1 +1 @@
-60896e38f575e84cfe4d9cc713e94a4cd86196638cf9693a2bf91986e5994e99
+06d6012342057d8f66d2c0f56e8bb1150fbf856a0f4f6d41516a9f683e062302
diff --git a/SOURCES/0732-generator-uninline-generator_open_unit_file-and-gene.patch b/SOURCES/0732-generator-uninline-generator_open_unit_file-and-gene.patch
new file mode 100644
index 0000000..9816868
--- /dev/null
+++ b/SOURCES/0732-generator-uninline-generator_open_unit_file-and-gene.patch
@@ -0,0 +1,52 @@
+From 657e89e5893fac4711fc9984bdb4861a66f84c5d Mon Sep 17 00:00:00 2001
+From: Michal Sekletar <msekleta@redhat.com>
+Date: Tue, 16 Jul 2024 18:19:45 +0200
+Subject: [PATCH] generator: "uninline" generator_open_unit_file and
+ generator_add_symlink
+
+Inlining of these functions changed ABI of libsystemd-shared which
+causes issue on update when generators packaged in systemd-udev
+subpackage fail to execute because of ABI change. systemd and the
+library are already updated while systemd-udev subpackage is not and
+hence old generators can't be started when systemd is reexecuting
+due to internal library incompatibility.
+
+rhel-only: bugfix
+
+Resolves: RHEL-49495
+---
+ src/shared/generator.c | 4 ++++
+ src/shared/generator.h | 5 +----
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/shared/generator.c b/src/shared/generator.c
+index 284e5fc580..7f5ceb7128 100644
+--- a/src/shared/generator.c
++++ b/src/shared/generator.c
+@@ -109,6 +109,10 @@ int generator_add_symlink_full(
+         return 0;
+ }
+ 
++int generator_add_symlink(const char *dir, const char *dst, const char *dep_type, const char *src) {
++        return generator_add_symlink_full(dir, dst, dep_type, src, NULL);
++}
++
+ static int generator_add_ordering(
+                 const char *dir,
+                 const char *src,
+diff --git a/src/shared/generator.h b/src/shared/generator.h
+index 111900fd45..61bc79f0f7 100644
+--- a/src/shared/generator.h
++++ b/src/shared/generator.h
+@@ -13,10 +13,7 @@ int generator_open_unit_file(
+         FILE **file);
+ 
+ int generator_add_symlink_full(const char *dir, const char *dst, const char *dep_type, const char *src, const char *instance);
+-
+-static inline int generator_add_symlink(const char *dir, const char *dst, const char *dep_type, const char *src) {
+-        return generator_add_symlink_full(dir, dst, dep_type, src, NULL);
+-}
++int generator_add_symlink(const char *dir, const char *dst, const char *dep_type, const char *src);
+ 
+ int generator_write_fsck_deps(
+         FILE *f,
diff --git a/SPECS/systemd.spec b/SPECS/systemd.spec
index 5dc6085..5c8ffb1 100644
--- a/SPECS/systemd.spec
+++ b/SPECS/systemd.spec
@@ -25,7 +25,7 @@
 Name:           systemd
 Url:            https://systemd.io
 Version:        252
-Release:        32%{?dist}.6
+Release:        32%{?dist}.7
 # For a breakdown of the licensing, see README
 License:        LGPLv2+ and MIT and GPLv2+
 Summary:        System and Service Manager
@@ -820,6 +820,7 @@ Patch0728: 0728-kernel-install-fix-uki-copy-deinstall.patch
 Patch0729: 0729-cryptsetup-do-not-assert-when-unsealing-token-withou.patch
 Patch0730: 0730-cryptsetup-check-the-existence-of-salt-by-salt_size-.patch
 Patch0731: 0731-bootspec-fix-null-dereference-read.patch
+Patch0732: 0732-generator-uninline-generator_open_unit_file-and-gene.patch
 
 # Downstream-only patches (9000–9999)
 
@@ -1699,6 +1700,9 @@ systemd-hwdb update &>/dev/null || :
 %{_prefix}/lib/dracut/modules.d/70rhel-net-naming-sysattrs/*
 
 %changelog
+* Thu Jul 18 2024 systemd maintenance team <systemd-maint@redhat.com> - 252-32.7
+- generator: "uninline" generator_open_unit_file and generator_add_symlink (RHEL-49495)
+
 * Wed Jun 12 2024 systemd maintenance team <systemd-maint@redhat.com> - 252-32.6
 - cryptsetup: do not assert when unsealing token without salt (RHEL-40119)
 - cryptsetup: check the existence of salt by salt_size > 0 (RHEL-40119)
-- 
GitLab