Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openvswitch
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
SIG
nfv
rpms
openvswitch
Commits
615f55e2
Verified
Commit
615f55e2
authored
3 years ago
by
Louis Abel
Browse files
Options
Downloads
Patches
Plain Diff
update
parent
a02ea11d
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/openvswitch-2.13.0.patch
+30
-8
30 additions, 8 deletions
SOURCES/openvswitch-2.13.0.patch
SPECS/openvswitch2.13.spec
+5
-1
5 additions, 1 deletion
SPECS/openvswitch2.13.spec
with
35 additions
and
9 deletions
SOURCES/openvswitch-2.13.0.patch
+
30
−
8
View file @
615f55e2
...
...
@@ -1237,7 +1237,7 @@ index 92b52f6712..0dc2a7dbca 100644
OVS_CHECK_PRAGMA_MESSAGE
AC_SUBST([OVS_CFLAGS])
diff --git a/datapath-windows/ovsext/Actions.c b/datapath-windows/ovsext/Actions.c
index 5c9b5c3a0c..
ced1d2957d
100644
index 5c9b5c3a0c..
f1f2c03197
100644
--- a/datapath-windows/ovsext/Actions.c
+++ b/datapath-windows/ovsext/Actions.c
@@ -1259,6 +1259,7 @@ OvsActionMplsPush(OvsForwardingContext *ovsFwdCtx,
...
...
@@ -1313,7 +1313,29 @@ index 5c9b5c3a0c..ced1d2957d 100644
}
return NDIS_STATUS_SUCCESS;
@@ -1579,6 +1590,7 @@ OvsUpdateAddressAndPort(OvsForwardingContext *ovsFwdCtx,
@@ -1539,9 +1550,21 @@ OvsUpdateAddressAndPort(OvsForwardingContext *ovsFwdCtx,
if (tcpHdr) {
portField = &tcpHdr->dest;
checkField = &tcpHdr->check;
+ l4Offload = isTx ? (BOOLEAN)csumInfo.Transmit.TcpChecksum :
+ ((BOOLEAN)csumInfo.Receive.TcpChecksumSucceeded ||
+ (BOOLEAN)csumInfo.Receive.TcpChecksumFailed);
} else if (udpHdr) {
portField = &udpHdr->dest;
checkField = &udpHdr->check;
+ l4Offload = isTx ? (BOOLEAN)csumInfo.Transmit.UdpChecksum :
+ ((BOOLEAN)csumInfo.Receive.UdpChecksumSucceeded ||
+ (BOOLEAN)csumInfo.Receive.UdpChecksumFailed);
+ }
+
+ if (l4Offload) {
+ *checkField = IPPseudoChecksum(&ipHdr->saddr, &newAddr,
+ tcpHdr ? IPPROTO_TCP : IPPROTO_UDP,
+ ntohs(ipHdr->tot_len) - ipHdr->ihl * 4);
}
}
@@ -1579,6 +1602,7 @@ OvsUpdateAddressAndPort(OvsForwardingContext *ovsFwdCtx,
*/
NDIS_STATUS
OvsUpdateIPv4Header(OvsForwardingContext *ovsFwdCtx,
...
...
@@ -1321,7 +1343,7 @@ index 5c9b5c3a0c..ced1d2957d 100644
const struct ovs_key_ipv4 *ipAttr)
{
PUINT8 bufferStart;
@@ -1632,6 +16
44
,7 @@ OvsUpdateIPv4Header(OvsForwardingContext *ovsFwdCtx,
@@ -1632,6 +16
56
,7 @@ OvsUpdateIPv4Header(OvsForwardingContext *ovsFwdCtx,
ipAttr->ipv4_src);
}
ipHdr->saddr = ipAttr->ipv4_src;
...
...
@@ -1329,7 +1351,7 @@ index 5c9b5c3a0c..ced1d2957d 100644
}
if (ipHdr->daddr != ipAttr->ipv4_dst) {
if (tcpHdr) {
@@ -1647,6 +16
60
,7 @@ OvsUpdateIPv4Header(OvsForwardingContext *ovsFwdCtx,
@@ -1647,6 +16
72
,7 @@ OvsUpdateIPv4Header(OvsForwardingContext *ovsFwdCtx,
ipAttr->ipv4_dst);
}
ipHdr->daddr = ipAttr->ipv4_dst;
...
...
@@ -1337,7 +1359,7 @@ index 5c9b5c3a0c..ced1d2957d 100644
}
if (ipHdr->protocol != ipAttr->ipv4_proto) {
UINT16 oldProto = (ipHdr->protocol << 16) & 0xff00;
@@ -1661,6 +167
5
,7 @@ OvsUpdateIPv4Header(OvsForwardingContext *ovsFwdCtx,
@@ -1661,6 +16
8
7,7 @@ OvsUpdateIPv4Header(OvsForwardingContext *ovsFwdCtx,
ipHdr->check = ChecksumUpdate16(ipHdr->check, oldProto, newProto);
}
ipHdr->protocol = ipAttr->ipv4_proto;
...
...
@@ -1345,7 +1367,7 @@ index 5c9b5c3a0c..ced1d2957d 100644
}
if (ipHdr->ttl != ipAttr->ipv4_ttl) {
UINT16 oldTtl = (ipHdr->ttl) & 0xff;
@@ -1669,6 +16
84
,7 @@ OvsUpdateIPv4Header(OvsForwardingContext *ovsFwdCtx,
@@ -1669,6 +16
96
,7 @@ OvsUpdateIPv4Header(OvsForwardingContext *ovsFwdCtx,
ipHdr->check = ChecksumUpdate16(ipHdr->check, oldTtl, newTtl);
}
ipHdr->ttl = ipAttr->ipv4_ttl;
...
...
@@ -1353,7 +1375,7 @@ index 5c9b5c3a0c..ced1d2957d 100644
}
return NDIS_STATUS_SUCCESS;
@@ -1691,12 +17
07
,12 @@ OvsExecuteSetAction(OvsForwardingContext *ovsFwdCtx,
@@ -1691,12 +17
19
,12 @@ OvsExecuteSetAction(OvsForwardingContext *ovsFwdCtx,
switch (type) {
case OVS_KEY_ATTR_ETHERNET:
...
...
@@ -1368,7 +1390,7 @@ index 5c9b5c3a0c..ced1d2957d 100644
NlAttrGetUnspec(a, sizeof(struct ovs_key_ipv4)));
break;
@@ -1709,16 +17
25
,17 @@ OvsExecuteSetAction(OvsForwardingContext *ovsFwdCtx,
@@ -1709,16 +17
37
,17 @@ OvsExecuteSetAction(OvsForwardingContext *ovsFwdCtx,
status = SUCCEEDED(convertStatus) ? NDIS_STATUS_SUCCESS : NDIS_STATUS_FAILURE;
ASSERT(status == NDIS_STATUS_SUCCESS);
RtlCopyMemory(&ovsFwdCtx->tunKey, &tunKey, sizeof ovsFwdCtx->tunKey);
This diff is collapsed.
Click to expand it.
SPECS/openvswitch2.13.spec
+
5
−
1
View file @
615f55e2
...
...
@@ -59,7 +59,7 @@ Summary: Open vSwitch
Group: System Environment/Daemons daemon/database/utilities
URL: http://www.openvswitch.org/
Version: 2.13.0
Release: 11
7
%{?commit0:.%{date}git%{shortcommit0}}%{?commit1:dpdk%{shortcommit1}}%{?dist}
Release: 11
8
%{?commit0:.%{date}git%{shortcommit0}}%{?commit1:dpdk%{shortcommit1}}%{?dist}
# Nearly all of openvswitch is ASL 2.0. The bugtool is LGPLv2+, and the
# lib/sflow*.[ch] files are SISSL
...
...
@@ -710,6 +710,10 @@ exit 0
%endif
%changelog
* Wed Jul 21 2021 Open vSwitch CI <ovs-ci@redhat.com> - 2.13.0-118
- Merging upstream branch-2.13
[d613ce404a9f86e8ff209fe3b17c76a231258bdf]
* Sat Jul 17 2021 Open vSwitch CI <ovs-ci@redhat.com> - 2.13.0-117
- Merging upstream branch-2.13
[1dbd295283c1533e979c2d7694168a6737c8d645]
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment