Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
openvswitch
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
SIG
nfv
rpms
openvswitch
Commits
75b3ba47
Verified
Commit
75b3ba47
authored
3 years ago
by
Louis Abel
Browse files
Options
Downloads
Patches
Plain Diff
update openvswitch 2.13
parent
78ba684f
No related branches found
Branches containing commit
Tags
imports/c8/java-11-openjdk-11.0.2.7-2.el8
Tags containing commit
No related merge requests found
Changes
3
Expand all
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
.openvswitch.metadata
+5
-5
5 additions, 5 deletions
.openvswitch.metadata
SOURCES/openvswitch-2.13.0.patch
+39
-3
39 additions, 3 deletions
SOURCES/openvswitch-2.13.0.patch
SPECS/openvswitch2.13.spec
+1600
-235
1600 additions, 235 deletions
SPECS/openvswitch2.13.spec
with
1644 additions
and
243 deletions
.openvswitch.metadata
+
5
−
5
View file @
75b3ba47
085d42061d9336f768cb56038ff3456f21667f56dfba0a0449e115f773bcf7ae SOURCES/
docutils-0.12.tar.gz
d8293c765539d47cf93736fcfe9182b711876d22d447c2d20450748c024f57d5 SOURCES/openvswitch-2.13.0
.tar.
g
z
3be1033bfeeab7f88a934f66958941baa0204277723b4f14c5701cac771e093f SOURCES/Pygments-1.4
.tar.gz
c11016bd195f49663889c67956bf2875baf9a98c91683bee322d7fc7ead07c07 SOURCES/Sphinx-1.1.3
.tar.gz
467133968843677bb1c276bb74a3458aa7c002cc21e295c51e3bd65497b112ab SOURCES/dpdk
-1
9
.1
1
.tar.
x
z
c7db717810ab6965f66c8cf0398a98c9d8df982da39b4cd7f162911eb89596fa
docutils-0.12.tar.gz
467133968843677bb1c276bb74a3458aa7c002cc21e295c51e3bd65497b112ab dpdk-19.11
.tar.
x
z
64397bc58cd74878fc113ba6bcbee3ad1a0ac96ef158714e7a85f1588e4e4748 openvswitch-2.13.0
.tar.gz
bbff02dc309e52846dd963d29483a7295fcc021624738d33359c43971080f9ab Pygments-1.4
.tar.gz
34dc95b70a2b07a61b5d61034c34b05f82514aab54ad27adedb49cee911bb8e9 Sphinx
-1.1
.3
.tar.
g
z
This diff is collapsed.
Click to expand it.
SOURCES/openvswitch-2.13.0.patch
+
39
−
3
View file @
75b3ba47
...
...
@@ -81566,6 +81566,21 @@ index 4df8f7c8b7..31d3139845 100644
const struct flow *flow; /* Flow extracted from 'packet'. */
/* Input, but possibly modified as a side effect of execution. */
diff --git a/lib/dynamic-string.c b/lib/dynamic-string.c
index 6f7b610a99..fd0127ed17 100644
--- a/lib/dynamic-string.c
+++ b/lib/dynamic-string.c
@@ -460,6 +460,10 @@ ds_chomp(struct ds *ds, int c)
void
ds_clone(struct ds *dst, struct ds *source)
{
+ if (!source->allocated) {
+ ds_init(dst);
+ return;
+ }
dst->length = source->length;
dst->allocated = dst->length;
dst->string = xmalloc(dst->allocated + 1);
diff --git a/lib/flow.c b/lib/flow.c
index 45bb96b543..353d5cd3ed 100644
--- a/lib/flow.c
...
...
@@ -83006,6 +83021,19 @@ index f95b19af4d..8c44eee8e9 100644
}
return true;
diff --git a/lib/netlink-socket.c b/lib/netlink-socket.c
index 47077e9478..5cb96fa6ec 100644
--- a/lib/netlink-socket.c
+++ b/lib/netlink-socket.c
@@ -917,7 +917,7 @@ nl_sock_transact_multiple__(struct nl_sock *sock,
}
if (txn->error) {
VLOG_DBG_RL(&rl, "received NAK error=%d (%s)",
- error, ovs_strerror(txn->error));
+ txn->error, ovs_strerror(txn->error));
}
} else {
txn->error = 0;
diff --git a/lib/netlink.c b/lib/netlink.c
index de3ebcd0e7..26ab20bb4b 100644
--- a/lib/netlink.c
...
...
@@ -84671,7 +84699,7 @@ index eda265dfc5..a635ff7689 100644
#define SHA1_FMT \
"%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x" \
diff --git a/lib/tc.c b/lib/tc.c
index 12af0192b6..
65938d7bee
100644
index 12af0192b6..
1acca38218
100644
--- a/lib/tc.c
+++ b/lib/tc.c
@@ -60,12 +60,6 @@ VLOG_DEFINE_THIS_MODULE(tc);
...
...
@@ -84730,7 +84758,15 @@ index 12af0192b6..65938d7bee 100644
return 0;
}
@@ -2645,6 +2643,7 @@ nl_msg_put_flower_options(struct ofpbuf *request, struct tc_flower *flower)
@@ -2462,6 +2460,7 @@ nl_msg_put_flower_acts(struct ofpbuf *request, struct tc_flower *flower)
if (!released && flower->tunnel) {
act_offset = nl_msg_start_nested(request, act_index++);
nl_msg_put_act_tunnel_key_release(request);
+ nl_msg_put_act_flags(request);
nl_msg_end_nested(request, act_offset);
released = true;
}
@@ -2645,6 +2644,7 @@ nl_msg_put_flower_options(struct ofpbuf *request, struct tc_flower *flower)
bool is_vlan = eth_type_vlan(flower->key.eth_type);
bool is_qinq = is_vlan && eth_type_vlan(flower->key.encap_eth_type[0]);
bool is_mpls = eth_type_mpls(flower->key.eth_type);
...
...
@@ -84738,7 +84774,7 @@ index 12af0192b6..65938d7bee 100644
int err;
/* need to parse acts first as some acts require changing the matching
@@ -2762,7 +276
1
,11 @@ nl_msg_put_flower_options(struct ofpbuf *request, struct tc_flower *flower)
@@ -2762,7 +276
2
,11 @@ nl_msg_put_flower_options(struct ofpbuf *request, struct tc_flower *flower)
}
}
This diff is collapsed.
Click to expand it.
SPECS/openvswitch2.13.spec
+
1600
−
235
View file @
75b3ba47
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment