Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
C
curl
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
curl
Commits
b4f8d0d1
Commit
b4f8d0d1
authored
7 months ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import curl-8.9.1-2.el10
parent
2cda6476
No related branches found
Branches containing commit
Tags
imports/r8/curl-7.61.1-34.el8_10.2
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/0001-curl-8.9.1-sigpipe-init-the-struct-so-that-first-apply-ignores.patch
+35
-0
35 additions, 0 deletions
...sigpipe-init-the-struct-so-that-first-apply-ignores.patch
SPECS/curl.spec
+8
-1
8 additions, 1 deletion
SPECS/curl.spec
with
43 additions
and
1 deletion
SOURCES/0001-curl-8.9.1-sigpipe-init-the-struct-so-that-first-apply-ignores.patch
0 → 100644
+
35
−
0
View file @
b4f8d0d1
From 3eec5afbd0b6377eca893c392569b2faf094d970 Mon Sep 17 00:00:00 2001
From: Daniel Stenberg <daniel@haxx.se>
Date: Mon, 5 Aug 2024 00:17:17 +0200
Subject: [PATCH] sigpipe: init the struct so that first apply ignores
Initializes 'no_signal' to TRUE, so that a call to sigpipe_apply() after
init ignores the signal (unless CURLOPT_NOSIGNAL) is set.
I have read the existing code multiple times now and I think it gets the
initial state reversed this missing to ignore.
Regression from 17e6f06ea37136c36d27
Reported-by: Rasmus Thomsen
Fixes #14344
Closes #14390
---
lib/sigpipe.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/sigpipe.h b/lib/sigpipe.h
index b91a2f513..d78afd905 100644
--- a/lib/sigpipe.h
+++ b/lib/sigpipe.h
@@ -39,6 +39,7 @@
struct sigpipe_ignore {
static void sigpipe_init(struct sigpipe_ignore *ig)
{
memset(ig, 0, sizeof(*ig));
+ ig->no_signal = TRUE;
}
/*
--
2.45.2
This diff is collapsed.
Click to expand it.
SPECS/curl.spec
+
8
−
1
View file @
b4f8d0d1
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
Name: curl
Version: 8.9.1
Release:
1
%{?dist}
Release:
2
%{?dist}
License: curl
Source0: https://curl.se/download/%{name}-%{version}.tar.xz
Source1: https://curl.se/download/%{name}-%{version}.tar.xz.asc
...
...
@@ -10,6 +10,9 @@ Source1: https://curl.se/download/%{name}-%{version}.tar.xz.asc
# which points to the GPG key as of April 7th 2016 of https://daniel.haxx.se/mykey.asc
Source2: mykey.asc
# fix crashes with transmission due to SIGPIPE
Patch001: 0001-curl-8.9.1-sigpipe-init-the-struct-so-that-first-apply-ignores.patch
# patch making libcurl multilib ready
Patch101: 0101-curl-7.32.0-multilib.patch
...
...
@@ -398,6 +401,10 @@ rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/mk-ca-bundle.1*
%{_libdir}/libcurl.so.4.[0-9].[0-9].minimal
%changelog
* Fri Aug 02 2024 Jacek Migacz <jmigacz@redhat.com> - 8.9.1-2
- add gating configuration (RHEL-52103)
- sigpipe: init the struct so that first apply ignores (RHEL-53327)
* Wed Jul 31 2024 Jacek Migacz <jmigacz@redhat.com> - 8.9.1-1
- new upstream release (RHEL-50806)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment