Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
git
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
git
Commits
9bdee54f
Commit
9bdee54f
authored
9 months ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import git-2.43.5-1.el9_4
parent
7c1193a5
No related branches found
Branches containing commit
Tags
imports/r10s/git-2.45.2-4.el10
Tags containing commit
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
.git.checksum
+1
-0
1 addition, 0 deletions
.git.checksum
.git.metadata
+3
-2
3 additions, 2 deletions
.git.metadata
SOURCES/git-2.43.0-core-crypto-hmac.patch
+70
-0
70 additions, 0 deletions
SOURCES/git-2.43.0-core-crypto-hmac.patch
SPECS/git.spec
+16
-3
16 additions, 3 deletions
SPECS/git.spec
with
90 additions
and
5 deletions
.git.checksum
0 → 100644
+
1
−
0
View file @
9bdee54f
ca1d24f27e78e423b507052cdffff2fc1a182a74bb5a6876a9f3bed1b2078852
This diff is collapsed.
Click to expand it.
.git.metadata
+
3
−
2
View file @
9bdee54f
7be8575a67477150800814e960e9c8028412d4cd SOURCES/git-2.39.3.tar.xz
87d3a395bad523277647f8614fbd9fefe0450fc6 SOURCES/gpgkey-junio.asc
6609196101487a7235ef0c056ee763c0c6bb3c60af7ecab76676db3df816f094 SOURCES/git-2.43.5.tar.sign
8b7cc3db84c5c6a2eeb39c63686ff5cde26278e32bb0d2226a8b424488420b98 SOURCES/git-2.43.5.tar.xz
c14031c313ee9f73cb551f0e15d66d70980b0238a7409e853d1f684758bd9a1d SOURCES/gpgkey-junio.asc
This diff is collapsed.
Click to expand it.
SOURCES/git-2.43.0-core-crypto-hmac.patch
0 → 100644
+
70
−
0
View file @
9bdee54f
diff -ur b/builtin/receive-pack.c a/builtin/receive-pack.c
--- b/builtin/receive-pack.c 2023-11-20 03:07:41.000000000 +0100
+++ a/builtin/receive-pack.c 2023-12-06 15:34:28.294170714 +0100
@@ -40,6 +40,8 @@
#include "worktree.h"
#include "shallow.h"
#include "parse-options.h"
+#include <openssl/hmac.h>
+#include <openssl/evp.h>
static const char * const receive_pack_usage[] = {
N_("git receive-pack <git-dir>"),
@@ -538,43 +540,11 @@
return 0;
}
-static void hmac_hash(unsigned char *out,
+static inline void hmac_hash(unsigned char *out,
const char *key_in, size_t key_len,
const char *text, size_t text_len)
{
- unsigned char key[GIT_MAX_BLKSZ];
- unsigned char k_ipad[GIT_MAX_BLKSZ];
- unsigned char k_opad[GIT_MAX_BLKSZ];
- int i;
- git_hash_ctx ctx;
-
- /* RFC 2104 2. (1) */
- memset(key, '\0', GIT_MAX_BLKSZ);
- if (the_hash_algo->blksz < key_len) {
- the_hash_algo->init_fn(&ctx);
- the_hash_algo->update_fn(&ctx, key_in, key_len);
- the_hash_algo->final_fn(key, &ctx);
- } else {
- memcpy(key, key_in, key_len);
- }
-
- /* RFC 2104 2. (2) & (5) */
- for (i = 0; i < sizeof(key); i++) {
- k_ipad[i] = key[i] ^ 0x36;
- k_opad[i] = key[i] ^ 0x5c;
- }
-
- /* RFC 2104 2. (3) & (4) */
- the_hash_algo->init_fn(&ctx);
- the_hash_algo->update_fn(&ctx, k_ipad, sizeof(k_ipad));
- the_hash_algo->update_fn(&ctx, text, text_len);
- the_hash_algo->final_fn(out, &ctx);
-
- /* RFC 2104 2. (6) & (7) */
- the_hash_algo->init_fn(&ctx);
- the_hash_algo->update_fn(&ctx, k_opad, sizeof(k_opad));
- the_hash_algo->update_fn(&ctx, out, the_hash_algo->rawsz);
- the_hash_algo->final_fn(out, &ctx);
+ HMAC(EVP_sha1(), key_in, key_len, text, text_len, out, NULL);
}
static char *prepare_push_cert_nonce(const char *path, timestamp_t stamp)
diff -ur b/Makefile a/Makefile
--- b/Makefile 2023-11-20 03:07:41.000000000 +0100
+++ a/Makefile 2023-12-06 15:35:08.506316431 +0100
@@ -2123,6 +2123,8 @@
EXTLIBS += -lcrypto -lssl
endif
+EXTLIBS += -lcrypto
+
ifneq ($(PROCFS_EXECUTABLE_PATH),)
procfs_executable_path_SQ = $(subst ','\'',$(PROCFS_EXECUTABLE_PATH))
BASIC_CFLAGS += '-DPROCFS_EXECUTABLE_PATH="$(procfs_executable_path_SQ)"'
This diff is collapsed.
Click to expand it.
SPECS/git.spec
+
16
−
3
View file @
9bdee54f
...
...
@@ -99,7 +99,7 @@
#global rcrev .rc0
Name: git
Version: 2.
39.3
Version: 2.
43.5
Release: 1%{?rcrev}%{?dist}
Summary: Fast Version Control System
License: GPLv2
...
...
@@ -131,8 +131,9 @@ Source99: print-failed-test-output
# https://bugzilla.redhat.com/490602
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
# https://bugzilla.redhat.com/1956345
Patch1: git-2.
38.1
-core-crypto-hmac.patch
Patch1: git-2.
43.0
-core-crypto-hmac.patch
# https://bugzilla.redhat.com/2114531
# tests: try harder to find open ports for apache, git, and svn
...
...
@@ -1117,9 +1118,21 @@ rmdir --ignore-fail-on-non-empty "$testdir"
%{?with_docs:%{_pkgdocdir}/git-svn.html}
%changelog
* Wed Jun 05 2024 Ondřej Pohořelský <opohorel@redhat.com> - 2.43.5-1
- Update to 2.43.5
- Related: RHEL-36402, RHEL-36414
* Wed May 15 2024 Ondřej Pohořelský <opohorel@redhat.com> - 2.43.4-1
- Update to 2.43.4
- Resolves: RHEL-36402, RHEL-36414
* Wed Dec 06 2023 Ondřej Pohořelský <opohorel@redhat.com> - 2.43.0-1
- Update to 2.43.0
- Resolves: RHEL-17100
* Wed Apr 26 2023 Ondřej Pohořelský <opohorel@redhat.com> - 2.39.3-1
- Update to 2.39.3
- Resolves: #21883
52
, #21883
61
, #2189
976
, #2189
977
- Resolves: #21883
63
, #21883
53
, #2189
872
, #2189
873
* Thu Jan 19 2023 Ondřej Pohořelský <opohorel@redhat.com> - 2.39.1-1
- Update to 2.39.1
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment