Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
git
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
git
Commits
f5c1db05
Commit
f5c1db05
authored
9 months ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import git-2.43.5-1.el8_10
parent
894c3eac
No related branches found
Branches containing commit
Tags
imports/r10s/git-2.45.2-4.el10
Tags containing commit
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
.git.checksum
+1
-0
1 addition, 0 deletions
.git.checksum
.git.metadata
+3
-2
3 additions, 2 deletions
.git.metadata
SOURCES/git-2.43.0-core-crypto-hmac.patch
+70
-0
70 additions, 0 deletions
SOURCES/git-2.43.0-core-crypto-hmac.patch
SPECS/git.spec
+14
-2
14 additions, 2 deletions
SPECS/git.spec
with
88 additions
and
4 deletions
.git.checksum
0 → 100644
+
1
−
0
View file @
f5c1db05
394010de74eb28415fda1cfdd44f27ca365d7ebb2fb6e183d3fa95b8e36efc35
This diff is collapsed.
Click to expand it.
.git.metadata
+
3
−
2
View file @
f5c1db05
7be8575a67477150800814e960e9c8028412d4cd SOURCES/git-2.39.3.tar.xz
87d3a395bad523277647f8614fbd9fefe0450fc6 SOURCES/gpgkey-junio.asc
6609196101487a7235ef0c056ee763c0c6bb3c60af7ecab76676db3df816f094 SOURCES/git-2.43.5.tar.sign
8b7cc3db84c5c6a2eeb39c63686ff5cde26278e32bb0d2226a8b424488420b98 SOURCES/git-2.43.5.tar.xz
c14031c313ee9f73cb551f0e15d66d70980b0238a7409e853d1f684758bd9a1d SOURCES/gpgkey-junio.asc
This diff is collapsed.
Click to expand it.
SOURCES/git-2.43.0-core-crypto-hmac.patch
0 → 100644
+
70
−
0
View file @
f5c1db05
diff -ur b/builtin/receive-pack.c a/builtin/receive-pack.c
--- b/builtin/receive-pack.c 2023-11-20 03:07:41.000000000 +0100
+++ a/builtin/receive-pack.c 2023-12-06 15:34:28.294170714 +0100
@@ -40,6 +40,8 @@
#include "worktree.h"
#include "shallow.h"
#include "parse-options.h"
+#include <openssl/hmac.h>
+#include <openssl/evp.h>
static const char * const receive_pack_usage[] = {
N_("git receive-pack <git-dir>"),
@@ -538,43 +540,11 @@
return 0;
}
-static void hmac_hash(unsigned char *out,
+static inline void hmac_hash(unsigned char *out,
const char *key_in, size_t key_len,
const char *text, size_t text_len)
{
- unsigned char key[GIT_MAX_BLKSZ];
- unsigned char k_ipad[GIT_MAX_BLKSZ];
- unsigned char k_opad[GIT_MAX_BLKSZ];
- int i;
- git_hash_ctx ctx;
-
- /* RFC 2104 2. (1) */
- memset(key, '\0', GIT_MAX_BLKSZ);
- if (the_hash_algo->blksz < key_len) {
- the_hash_algo->init_fn(&ctx);
- the_hash_algo->update_fn(&ctx, key_in, key_len);
- the_hash_algo->final_fn(key, &ctx);
- } else {
- memcpy(key, key_in, key_len);
- }
-
- /* RFC 2104 2. (2) & (5) */
- for (i = 0; i < sizeof(key); i++) {
- k_ipad[i] = key[i] ^ 0x36;
- k_opad[i] = key[i] ^ 0x5c;
- }
-
- /* RFC 2104 2. (3) & (4) */
- the_hash_algo->init_fn(&ctx);
- the_hash_algo->update_fn(&ctx, k_ipad, sizeof(k_ipad));
- the_hash_algo->update_fn(&ctx, text, text_len);
- the_hash_algo->final_fn(out, &ctx);
-
- /* RFC 2104 2. (6) & (7) */
- the_hash_algo->init_fn(&ctx);
- the_hash_algo->update_fn(&ctx, k_opad, sizeof(k_opad));
- the_hash_algo->update_fn(&ctx, out, the_hash_algo->rawsz);
- the_hash_algo->final_fn(out, &ctx);
+ HMAC(EVP_sha1(), key_in, key_len, text, text_len, out, NULL);
}
static char *prepare_push_cert_nonce(const char *path, timestamp_t stamp)
diff -ur b/Makefile a/Makefile
--- b/Makefile 2023-11-20 03:07:41.000000000 +0100
+++ a/Makefile 2023-12-06 15:35:08.506316431 +0100
@@ -2123,6 +2123,8 @@
EXTLIBS += -lcrypto -lssl
endif
+EXTLIBS += -lcrypto
+
ifneq ($(PROCFS_EXECUTABLE_PATH),)
procfs_executable_path_SQ = $(subst ','\'',$(PROCFS_EXECUTABLE_PATH))
BASIC_CFLAGS += '-DPROCFS_EXECUTABLE_PATH="$(procfs_executable_path_SQ)"'
This diff is collapsed.
Click to expand it.
SPECS/git.spec
+
14
−
2
View file @
f5c1db05
...
...
@@ -92,7 +92,7 @@
#global rcrev .rc0
Name: git
Version: 2.
39.3
Version: 2.
43.5
Release: 1%{?rcrev}%{?dist}
Summary: Fast Version Control System
License: GPLv2
...
...
@@ -126,7 +126,7 @@ Source99: print-failed-test-output
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
Patch1: 0001-Switch-git-instaweb-default-to-apache-2.26.2.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1619113
Patch2: git-2.
38.1
-core-crypto-hmac.patch
Patch2: git-2.
43.0
-core-crypto-hmac.patch
# https://bugzilla.redhat.com/2114531
# tests: try harder to find open ports for apache, git, and svn
...
...
@@ -1099,6 +1099,18 @@ rmdir --ignore-fail-on-non-empty "$testdir"
%{?with_docs:%{_pkgdocdir}/git-svn.html}
%changelog
* Wed Jun 05 2024 Ondřej Pohořelský <opohorel@redhat.com> - 2.43.5-1
- Update to 2.43.5
- Related: RHEL-36399, RHEL-36411
* Wed May 15 2024 Ondřej Pohořelský <opohorel@redhat.com> - 2.43.4-1
- Update to 2.43.4
- Resolves: RHEL-36399, RHEL-36411
* Wed Dec 06 2023 Ondřej Pohořelský <opohorel@redhat.com> - 2.43.0-1
- Update to 2.43.0
- Resolves: RHEL-17103
* Thu Apr 27 2023 Ondřej Pohořelský <opohorel@redhat.com> - 2.39.3-1
- Update to 2.39.3
- Resolves: #2188364, #2188373, #2190157, #2190158
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment