Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
glibc
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
glibc
Commits
fc4ccb03
Commit
fc4ccb03
authored
1 year ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import glibc-2.28-250.el8
parent
3e2767ee
No related branches found
Branches containing commit
Tags
imports/r10s/grub2-2.12-13.el10
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/glibc-RHEL-19445.patch
+31
-0
31 additions, 0 deletions
SOURCES/glibc-RHEL-19445.patch
SPECS/glibc.spec
+5
-1
5 additions, 1 deletion
SPECS/glibc.spec
with
36 additions
and
1 deletion
SOURCES/glibc-RHEL-19445.patch
0 → 100644
+
31
−
0
View file @
fc4ccb03
Based on the following commit, adjusted for glibc-2.28 in RHEL-8:
commit 5eabdb6a6ac1599d23dd5966a37417215950245f
Author: Andreas Schwab <schwab@suse.de>
Date: Wed Dec 6 14:48:22 2023 +0100
getaddrinfo: translate ENOMEM to EAI_MEMORY (bug 31163)
When __resolv_context_get returns NULL due to out of memory, translate it
to a return value of EAI_MEMORY.
diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
index 46046504a6858f2e..d0708f3e84e20025 100644
--- a/sysdeps/posix/getaddrinfo.c
+++ b/sysdeps/posix/getaddrinfo.c
@@ -777,7 +777,14 @@
gaih_inet (const char *name, const struct gaih_service *service,
res_ctx = __resolv_context_get ();
res_enable_inet6 = __resolv_context_disable_inet6 (res_ctx);
if (res_ctx == NULL)
- no_more = 1;
+ {
+ if (errno == ENOMEM)
+ {
+ result = -EAI_MEMORY;
+ goto free_and_return;
+ }
+ no_more = 1;
+ }
while (!no_more)
{
This diff is collapsed.
Click to expand it.
SPECS/glibc.spec
+
5
−
1
View file @
fc4ccb03
%define glibcsrcdir glibc-2.28
%define glibcversion 2.28
%define glibcrelease 2
49
%{?dist}
%define glibcrelease 2
50
%{?dist}
# Pre-release tarballs are pulled in from git using a command that is
# effectively:
#
...
...
@@ -1181,6 +1181,7 @@ Patch993: glibc-RHEL-19824.patch
Patch994: glibc-RHEL-3010-1.patch
Patch995: glibc-RHEL-3010-2.patch
Patch996: glibc-RHEL-3010-3.patch
Patch997: glibc-RHEL-19445.patch
##############################################################################
# Continued list of core "glibc" package information:
...
...
@@ -3012,6 +3013,9 @@ fi
%files -f compat-libpthread-nonshared.filelist -n compat-libpthread-nonshared
%changelog
* Wed Jan 10 2024 Arjun Shankar <arjun@redhat.com> - 2.28-250
- getaddrinfo: Return correct error EAI_MEMORY when out-of-memory (RHEL-19445)
* Wed Jan 3 2024 Florian Weimer <fweimer@redhat.com> - 2.28-249
- Updates for AMD cache size computation (RHEL-3010)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment