Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
gnome-kiosk
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
gnome-kiosk
Commits
1000ca0f
Commit
1000ca0f
authored
2 weeks ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import gnome-kiosk-47.0-9.el10
parent
96d77275
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/0001-input-sources-manager-Do-not-crash-if-there-is-no-X1.patch
+42
-0
42 additions, 0 deletions
...nput-sources-manager-Do-not-crash-if-there-is-no-X1.patch
SPECS/gnome-kiosk.spec
+6
-1
6 additions, 1 deletion
SPECS/gnome-kiosk.spec
with
48 additions
and
1 deletion
SOURCES/0001-input-sources-manager-Do-not-crash-if-there-is-no-X1.patch
0 → 100644
+
42
−
0
View file @
1000ca0f
From 269cf451feb18206f9a8326d8fa36bc36f9b1897 Mon Sep 17 00:00:00 2001
From: Olivier Fourdan <ofourdan@redhat.com>
Date: Wed, 19 Mar 2025 14:41:15 +0100
Subject: [PATCH] input-sources-manager: Do not crash if there is no X11Layouts
When queried for the X11Layout property, localed will try to get the
configuration from /etc/X11/xorg.conf.d/00-keyboard.conf.
If for some reason (the system was misconfigured or the installation was
altered), that directory is not accessible or not present, localed will
return a NULL string instead of the actual X11 layouts or even an empty
string if no X11 layout was ever configured.
In such a case, gnome-kiosk will segfault.
To avoid that potential problem, check for the X11 layouts to be not
NULL or return early if that's not the case.
Fixes: 38407233 - input-sources-manager: Add APIs for setting keymap
Part-of: <https://gitlab.gnome.org/GNOME/gnome-kiosk/-/merge_requests/68>
---
compositor/kiosk-input-sources-manager.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/compositor/kiosk-input-sources-manager.c b/compositor/kiosk-input-sources-manager.c
index 31dab12..6200af5 100644
--- a/compositor/kiosk-input-sources-manager.c
+++ b/compositor/kiosk-input-sources-manager.c
@@ -869,6 +869,10 @@
kiosk_input_sources_manager_set_input_sources_from_system_configuration (KioskIn
g_debug ("KioskInputSourcesManager: Setting keymap from system configuration");
layouts_string = sd_locale1_get_x11_layout (self->locale_proxy);
+ if (layouts_string == NULL) {
+ g_debug ("KioskInputSourcesManager: No layouts defined");
+ return FALSE;
+ }
g_debug ("KioskInputSourcesManager: System layout is '%s'", layouts_string);
layouts = g_strsplit (layouts_string, ",", -1);
--
2.49.0
This diff is collapsed.
Click to expand it.
SPECS/gnome-kiosk.spec
+
6
−
1
View file @
1000ca0f
...
...
@@ -2,7 +2,7 @@
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number =
8
;
release_number =
9
;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
...
...
@@ -63,6 +63,8 @@ Patch: 0001-search-app-Add-systemd-session-files.patch
Patch: 0002-search-app-Update-desktop-file-definition.patch
# https://issues.redhat.com/browse/RHEL-36521
Patch: 0001-search-app-Use-firefox-from-flatpak.patch
# https://issues.redhat.com/browse/RHEL-84829
Patch: 0001-input-sources-manager-Do-not-crash-if-there-is-no-X1.patch
%description
GNOME Kiosk provides a desktop enviroment suitable for fixed purpose, or
...
...
@@ -133,6 +135,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/org.gnome.Kiosk.Searc
%changelog
## START: Generated by rpmautospec
* Wed Mar 26 2025 Olivier Fourdan <ofourdan@redhat.com> - 47.0-9
- Fix crash on missing systemd files
* Thu Mar 06 2025 Olivier Fourdan <ofourdan@redhat.com> - 47.0-8
- search-app: Add systemd session files
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment