Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
gnome-kiosk
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
gnome-kiosk
Commits
9a40554d
Commit
9a40554d
authored
1 year ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import gnome-kiosk-40.0-5.el9
parent
188daf39
Branches
r9
Tags
imports/r9/gnome-kiosk-40.0-5.el9
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/0001-compositor-Be-more-permissive-about-what-s-considere.patch
+89
-0
89 additions, 0 deletions
...ompositor-Be-more-permissive-about-what-s-considere.patch
SPECS/gnome-kiosk.spec
+6
-4
6 additions, 4 deletions
SPECS/gnome-kiosk.spec
with
95 additions
and
4 deletions
SOURCES/0001-compositor-Be-more-permissive-about-what-s-considere.patch
0 → 100644
+
89
−
0
View file @
9a40554d
From a57b5436cdce6b09daf968d1ff563b0b2e233daa Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Thu, 6 Oct 2022 11:01:20 -0400
Subject: [PATCH] compositor: Be more permissive about what's considered
fullscreen
GNOME Kiosk will automatically fullscreen the application started
for it, but sometimes that application will start another app.
The second app should not be automatically fullscreened.
Some apps go fullscreen without actually going fullscreen though.
They just go monitor sized.
This commit makes sure those apps count as fullscreen too.
---
compositor/kiosk-compositor.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/compositor/kiosk-compositor.c b/compositor/kiosk-compositor.c
index 2db58ed..c611bb9 100644
--- a/compositor/kiosk-compositor.c
+++ b/compositor/kiosk-compositor.c
@@ -282,61 +282,61 @@
kiosk_compositor_size_change (MetaPlugin *plugin,
static gboolean
kiosk_compositor_wants_window_fullscreen (KioskCompositor *self,
MetaWindow *window)
{
MetaWindowType window_type;
g_autoptr (GList) windows = NULL;
GList *node;
if (!meta_window_allows_resize (window)) {
g_debug ("KioskCompositor: Window does not allow resizes");
return FALSE;
}
if (meta_window_is_override_redirect (window)) {
g_debug ("KioskCompositor: Window is override redirect");
return FALSE;
}
window_type = meta_window_get_window_type (window);
if (window_type != META_WINDOW_NORMAL) {
g_debug ("KioskCompositor: Window is not normal");
return FALSE;
}
windows = meta_display_get_tab_list (self->display, META_TAB_LIST_NORMAL_ALL, NULL);
for (node = windows; node != NULL; node = node->next) {
MetaWindow *existing_window = node->data;
- if (meta_window_is_fullscreen (existing_window)) {
+ if (meta_window_is_monitor_sized (existing_window)) {
return FALSE;
}
}
return TRUE;
}
static gboolean
kiosk_compositor_wants_window_above (KioskCompositor *self,
MetaWindow *window)
{
if (meta_window_is_screen_sized (window)) {
return FALSE;
}
if (meta_window_is_monitor_sized (window)) {
return FALSE;
}
return TRUE;
}
static void
on_faded_in (KioskCompositor *self,
ClutterTransition *transition)
{
MetaWindowActor *actor = g_object_get_data (G_OBJECT (transition), "actor");
meta_plugin_map_completed (META_PLUGIN (self), actor);
}
--
2.35.1
This diff is collapsed.
Click to expand it.
SPECS/gnome-kiosk.spec
+
6
−
4
View file @
9a40554d
...
...
@@ -12,7 +12,7 @@
Name: gnome-kiosk
Version: 40.0
Release:
4
%{?dist}
.1
Release:
5
%{?dist}
Summary: Window management and application launching for GNOME
License: GPLv2+
...
...
@@ -49,6 +49,8 @@ Patch20004: 0004-kiosk-script-Give-xsession-and-wayland-session-file-.patch
Patch20005: 0005-kiosk-script-Add-a-hint-about-using-firefox-to-the-k.patch
Patch20006: 0006-kiosk-script-Send-SIGHUP-to-script-at-shutdown-time.patch
Patch30001: 0001-compositor-Be-more-permissive-about-what-s-considere.patch
%description
GNOME Kiosk provides a desktop enviroment suitable for fixed purpose, or
single application deployments like wall displays and point-of-sale systems.
...
...
@@ -114,9 +116,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/org.gnome.Kiosk.Searc
%{_datadir}/wayland-sessions/org.gnome.Kiosk.SearchApp.Session.desktop
%changelog
*
Thu Aug 18
2022 Ray Strode <rstrode@redhat.com> - 40.0-
4.1
-
Rebuild
Re
lated: #2119427
*
Wed Nov 09
2022 Ray Strode <rstrode@redhat.com> - 40.0-
5
-
Detect anaconda as the kiosk app better
Re
solves: #1999060
* Wed Aug 11 2021 Ray Strode <rstrode@redhat.com> - 40.0-4
- Fix crash when hitting alt-f2
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment