Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
gnome-shell-extensions
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
gnome-shell-extensions
Commits
0302cc0b
Commit
0302cc0b
authored
4 months ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import gnome-shell-extensions-47.1-1.el10
parent
f168567d
No related branches found
Branches containing commit
Tags
imports/r8/gnome-shell-extensions-3.32.1-11.el8
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
.gnome-shell-extensions.metadata
+1
-1
1 addition, 1 deletion
.gnome-shell-extensions.metadata
SOURCES/window-list-reordering.patch
+41
-375
41 additions, 375 deletions
SOURCES/window-list-reordering.patch
SPECS/gnome-shell-extensions.spec
+6
-3
6 additions, 3 deletions
SPECS/gnome-shell-extensions.spec
with
48 additions
and
379 deletions
.gnome-shell-extensions.metadata
+
1
−
1
View file @
0302cc0b
50f04f7ba50eded10cea07a4705fb3363e86926d10011be5b25037566770834f
SOURCES/gnome-shell-extensions-47.
0
.tar.xz
e9438cc5d39f9875dfd04ea0abb51e5962eaad5c20274123243b1612098b3a85
SOURCES/gnome-shell-extensions-47.
1
.tar.xz
This diff is collapsed.
Click to expand it.
SOURCES/window-list-reordering.patch
+
41
−
375
View file @
0302cc0b
From 21e087ef90891e703338b00cea0cf38e11feae8f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 25 Sep 2024 03:36:08 +0200
Subject: [PATCH 01/22] window-list: Small stylesheet cleanup
The light stylesheet duplicates some declarations, and the
last occurrence matches what we already inherit from the
dark stylesheet.
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/337>
---
extensions/window-list/stylesheet-light.css | 10 ----------
1 file changed, 10 deletions(-)
diff --git a/extensions/window-list/stylesheet-light.css b/extensions/window-list/stylesheet-light.css
index 375fd1bf..f9c51f8e 100644
--- a/extensions/window-list/stylesheet-light.css
+++ b/extensions/window-list/stylesheet-light.css
@@ -21,21 +21,11 @@
text-shadow: none;
}
- .bottom-panel .window-button > StWidget {
- -st-natural-width: 18.7em;
- max-width: 18.75em;
- }
-
.window-button > StWidget {
color: #000;
background-color: transparent;
}
-.window-button > StWidget {
- -st-natural-width: 18.75em;
- max-width: 18.75em;
-}
-
.window-button:hover > StWidget {
background-color: st-darken(#eee,5%);
}
--
2.47.0
From 5ac12f0ec7c378e4b65073823b0e03a0e9c219eb Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 25 Sep 2024 02:14:47 +0200
Subject: [PATCH 02/22] window-list: Don't recreate icons on theme changes
All icons use `StIcon`, which already updates itself correctly
on icon theme changes.
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/337>
---
extensions/window-list/extension.js | 9 ---------
1 file changed, 9 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index 3edbf8bf..9441fad1 100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -125,10 +125,6 @@
class WindowTitle extends St.BoxLayout {
this.label_actor.clutter_text.single_line_mode = true;
this.add_child(this.label_actor);
- this._textureCache = St.TextureCache.get_default();
- this._textureCache.connectObject('icon-theme-changed',
- () => this._updateIcon(), this);
-
this._metaWindow.connectObject(
'notify::wm-class',
() => this._updateIcon(), GObject.ConnectFlags.AFTER,
@@ -591,11 +587,6 @@
class AppButton extends BaseButton {
this._appContextMenu.actor.hide();
Main.uiGroup.add_child(this._appContextMenu.actor);
- this._textureCache = St.TextureCache.get_default();
- this._textureCache.connectObject('icon-theme-changed', () => {
- this._icon.child = app.create_icon_texture(ICON_TEXTURE_SIZE);
- }, this);
-
this.app.connectObject('windows-changed',
() => this._windowsChanged(), this);
this._windowsChanged();
--
2.47.0
From 8c3a3f3b8a625bcfeedcfa367866f37ae9087c72 Mon Sep 17 00:00:00 2001
From 3c701ae01af9eb1ece8599f715fab3782739832e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 25 Sep 2024 02:23:41 +0200
Subject: [PATCH 0
3/22
] window-list: Split out AppTitle class
Subject: [PATCH 0
1/14
] window-list: Split out AppTitle class
Even though it's just a box with icon and label, it's cleaner to
have a dedicated class.
...
...
@@ -100,7 +12,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 30 insertions(+), 17 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
9441fad1..a5bb55f6
100644
index
cd0a6d98..b70982fb
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -166,6 +166,35 @@
class WindowTitle extends St.BoxLayout {
...
...
@@ -170,10 +82,10 @@ index 9441fad1..a5bb55f6 100644
2.47.0
From
0cc25fbf6e996e3d9b0352b728a23f8c308f01e5
Mon Sep 17 00:00:00 2001
From
33bc13810ad40b3b29d564633b90183f83ea2539
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 25 Sep 2024 02:55:14 +0200
Subject: [PATCH 0
4/22
] window-list: Simplify app button
Subject: [PATCH 0
2/14
] window-list: Simplify app button
Depending on the number of windows, the button either shows the
title of the lone window, or the app title for multiple windows.
...
...
@@ -190,7 +102,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 25 insertions(+), 46 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
a5bb55f6..9b9ea7b9
100644
index
b70982fb..b03c1fed
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -574,17 +574,6 @@
class AppButton extends BaseButton {
...
...
@@ -291,256 +203,10 @@ index a5bb55f6..9b9ea7b9 100644
2.47.0
From 88d42e3ac829f90a3b3e1b56fcfac483a8563449 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Mon, 7 Oct 2024 17:22:04 +0200
Subject: [PATCH 05/22] window-list: Fix minimized styling
Commit 039c66e7b7c wrapped the button in a container to
animate transitions, but didn't adjust the `.minimized`
styling to still apply to the button (where it is
expected) rather than the wrapper.
Fix this just like commit c72b8b21 did for the
`.focused` styling.
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/342>
---
extensions/window-list/extension.js | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index 9b9ea7b9..3a8f612a 100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -478,9 +478,9 @@
class WindowButton extends BaseButton {
super._updateStyle();
if (this.metaWindow.minimized)
- this.add_style_class_name('minimized');
+ this._button.add_style_class_name('minimized');
else
- this.remove_style_class_name('minimized');
+ this._button.remove_style_class_name('minimized');
}
_windowEnteredOrLeftMonitor(metaDisplay, monitorIndex, metaWindow) {
--
2.47.0
From ce37919c1e3643363858f67fc749981a0afc1b8d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Mon, 7 Oct 2024 17:10:43 +0200
Subject: [PATCH 06/22] window-list: Fix active state
Commit c72b8b21 fixed the styling of the active window's button,
but missed that the `active` property uses the style information
as well.
Adjust it to use the correct actor when checking for the style class.
Closes https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/issues/529
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/342>
---
extensions/window-list/extension.js | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index 3a8f612a..e7a1c777 100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -252,7 +252,7 @@
class BaseButton extends DashItemContainer {
}
get active() {
- return this.has_style_class_name('focused');
+ return this._button.has_style_class_name('focused');
}
// eslint-disable-next-line camelcase
--
2.47.0
From 0c0115c847188838c3132dbba5fc99c7a6052f8e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 1 Oct 2024 14:52:02 +0200
Subject: [PATCH 07/22] window-list: Add missing action
Commit 24ba03fe9 added a new setting, but forgot to create the
corresponding action.
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/341>
---
extensions/window-list/prefs.js | 2 ++
1 file changed, 2 insertions(+)
diff --git a/extensions/window-list/prefs.js b/extensions/window-list/prefs.js
index 194d1f9d..5da645df 100644
--- a/extensions/window-list/prefs.js
+++ b/extensions/window-list/prefs.js
@@ -30,6 +30,8 @@
class WindowListPrefsWidget extends Adw.PreferencesPage {
this._settings.create_action('show-on-all-monitors'));
this._actionGroup.add_action(
this._settings.create_action('display-all-workspaces'));
+ this._actionGroup.add_action(
+ this._settings.create_action('embed-previews'));
const groupingGroup = new Adw.PreferencesGroup({
title: _('Window Grouping'),
--
2.47.0
From b3401e8354892c82e0198bb8fb4d99210a9fc494 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 1 Oct 2024 14:46:15 +0200
Subject: [PATCH 08/22] window-list: Remove superfluous bindings
The setting is already bound to the switch via the corresponding action,
no need to also set up a binding.
In fact, the second binding is actively harmful, as it keeps the
connection alive until dispose, so the setting is reset on
garbage collection.
Closes https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/issues/511
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/341>
---
extensions/window-list/prefs.js | 4 ----
1 file changed, 4 deletions(-)
diff --git a/extensions/window-list/prefs.js b/extensions/window-list/prefs.js
index 5da645df..cf56be5b 100644
--- a/extensions/window-list/prefs.js
+++ b/extensions/window-list/prefs.js
@@ -75,8 +75,6 @@
class WindowListPrefsWidget extends Adw.PreferencesPage {
action_name: 'window-list.display-all-workspaces',
valign: Gtk.Align.CENTER,
});
- this._settings.bind('display-all-workspaces',
- toggle, 'active', Gio.SettingsBindFlags.DEFAULT);
row = new Adw.ActionRow({
title: _('Show windows from all workspaces'),
activatable_widget: toggle,
@@ -88,8 +86,6 @@
class WindowListPrefsWidget extends Adw.PreferencesPage {
action_name: 'window-list.embed-previews',
valign: Gtk.Align.CENTER,
});
- this._settings.bind('embed-previews',
- toggle, 'active', Gio.SettingsBindFlags.DEFAULT);
row = new Adw.ActionRow({
title: _('Show workspace previews'),
activatable_widget: toggle,
--
2.47.0
From 101043326755dda2144e9939681e5f6be4ed116d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 1 Oct 2024 14:55:44 +0200
Subject: [PATCH 09/22] window-list: Switch to Adw.SwitchRow
libadwaita fixed the actionable implementation of Adw.SwitchRow,
so can use the convenience widget instead of composing our own.
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/341>
---
extensions/window-list/prefs.js | 27 ++++++---------------------
1 file changed, 6 insertions(+), 21 deletions(-)
diff --git a/extensions/window-list/prefs.js b/extensions/window-list/prefs.js
index cf56be5b..0633d590 100644
--- a/extensions/window-list/prefs.js
+++ b/extensions/window-list/prefs.js
@@ -60,37 +60,22 @@
class WindowListPrefsWidget extends Adw.PreferencesPage {
const miscGroup = new Adw.PreferencesGroup();
this.add(miscGroup);
- let toggle = new Gtk.Switch({
- action_name: 'window-list.show-on-all-monitors',
- valign: Gtk.Align.CENTER,
- });
- let row = new Adw.ActionRow({
+ let row = new Adw.SwitchRow({
title: _('Show on all monitors'),
- activatable_widget: toggle,
+ action_name: 'window-list.show-on-all-monitors',
});
- row.add_suffix(toggle);
miscGroup.add(row);
- toggle = new Gtk.Switch({
- action_name: 'window-list.display-all-workspaces',
- valign: Gtk.Align.CENTER,
- });
- row = new Adw.ActionRow({
+ row = new Adw.SwitchRow({
title: _('Show windows from all workspaces'),
- activatable_widget: toggle,
+ action_name: 'window-list.display-all-workspaces',
});
- row.add_suffix(toggle);
miscGroup.add(row);
- toggle = new Gtk.Switch({
- action_name: 'window-list.embed-previews',
- valign: Gtk.Align.CENTER,
- });
- row = new Adw.ActionRow({
+ row = new Adw.SwitchRow({
title: _('Show workspace previews'),
- activatable_widget: toggle,
+ action_name: 'window-list.embed-previews',
});
- row.add_suffix(toggle);
miscGroup.add(row);
}
}
--
2.47.0
From 1774cead56dcda6abdce8a1e6427dbeb866d7a0d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 15 Oct 2024 17:48:52 +0200
Subject: [PATCH 10/22] window-list: Remove outdated style
A long time ago, the window list used to embed the bottom message
tray, which caused notifications to inherit the window-list's
font style.
Since that's no longer the case, we have no business in messing
with notification styling, so stop doing that.
Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests/338>
---
extensions/window-list/stylesheet-dark.css | 4 ----
1 file changed, 4 deletions(-)
diff --git a/extensions/window-list/stylesheet-dark.css b/extensions/window-list/stylesheet-dark.css
index b9087971..f02fca60 100644
--- a/extensions/window-list/stylesheet-dark.css
+++ b/extensions/window-list/stylesheet-dark.css
@@ -81,7 +81,3 @@
width: 24px;
height: 24px;
}
-
-.notification {
- font-weight: normal;
-}
--
2.47.0
From cba87ff1919c3075ee428a73d3870c92cc5e214b Mon Sep 17 00:00:00 2001
From d5216a406bc7eb74d94dc176e3ea8210e6b1b79d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Thu, 26 Sep 2024 19:07:11 +0200
Subject: [PATCH
11/22
] window-list: Split out some common code
Subject: [PATCH
03/14
] window-list: Split out some common code
Adding an app button and adding a window button involves some
shared steps, move those to a shared `_addButton()` method.
...
...
@@ -551,7 +217,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
e7a1c777..6eb08da0
100644
index
b03c1fed..447fb859
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -964,14 +964,18 @@
class WindowList extends St.Widget {
...
...
@@ -593,10 +259,10 @@ index e7a1c777..6eb08da0 100644
2.47.0
From
02f295445a3383d2cf346860fefeace65be28c2c
Mon Sep 17 00:00:00 2001
From
2573c40e28b47e218757e7cc544057b3d0eb2ae8
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Thu, 3 Oct 2024 17:19:31 +0200
Subject: [PATCH
12/22
] window-list: Split out common TitleWidget class
Subject: [PATCH
04/14
] window-list: Split out common TitleWidget class
Both app- and window title use the same structure, so add a shared
base class.
...
...
@@ -607,7 +273,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 32 insertions(+), 29 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
6eb08da0..383d0b72
100644
index
447fb859..95785fed
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -105,25 +105,42 @@
class WindowContextMenu extends PopupMenu.PopupMenu {
...
...
@@ -715,10 +381,10 @@ index 6eb08da0..383d0b72 100644
2.47.0
From
426f72d1991316b927495ca7385d95b15022da77
Mon Sep 17 00:00:00 2001
From
5ae0176968a25cbb742f0225f4f609ffb0d140ed
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Thu, 3 Oct 2024 17:27:57 +0200
Subject: [PATCH
13/22
] window-list: Add TitleWidget:abstract-label property
Subject: [PATCH
05/14
] window-list: Add TitleWidget:abstract-label property
When true, the real label is replaced by a more abstract
representation. When used as drag actor, the focus is not
...
...
@@ -732,7 +398,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
2 files changed, 28 insertions(+)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
383d0b72..3ed1c357
100644
index
95785fed..24eca3ed
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -109,6 +109,12 @@
class TitleWidget extends St.BoxLayout {
...
...
@@ -789,10 +455,10 @@ index f02fca60..fce6bcc5 100644
2.47.0
From
509e41d89e4f7d661ec9a749e04d583e1affada
5 Mon Sep 17 00:00:00 2001
From
87f0ed426f144eea9370f57986314d2640fa147
5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 25 Sep 2024 03:20:52 +0200
Subject: [PATCH
14/22
] window-list: Split out `_createTitleActor()` hook
Subject: [PATCH
06/14
] window-list: Split out `_createTitleActor()` hook
This will allow creating a suitable drag actor that matches the
current title. In particular this allows for a drag actor that
...
...
@@ -806,7 +472,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 20 insertions(+), 3 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
3ed1c357..21823cf8
100644
index
24eca3ed..f0674b94
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -357,6 +357,11 @@
class BaseButton extends DashItemContainer {
...
...
@@ -876,10 +542,10 @@ index 3ed1c357..21823cf8 100644
2.47.0
From
62c8cd20e2c425909ff361ec05cba4e847c12886
Mon Sep 17 00:00:00 2001
From
1fe5971213f24f3d71d685e904cb5b7d793f70df
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 19 Jun 2024 13:01:37 +0200
Subject: [PATCH
15/22
] window-list: Rename XDND related methods and props
Subject: [PATCH
07/14
] window-list: Rename XDND related methods and props
The window list buttons themselves will become draggable, so
include "xdnd" in the existing drag handling to disambiguate
...
...
@@ -891,7 +557,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
21823cf8..d765f58f
100644
index
f0674b94..d6d50bd4
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -866,12 +866,12 @@
class WindowList extends St.Widget {
...
...
@@ -946,10 +612,10 @@ index 21823cf8..d765f58f 100644
2.47.0
From
d85fae629186c66d7fb2ebf665ee185b8f8763ae
Mon Sep 17 00:00:00 2001
From
a10862dd9a939aaae1e4b160086288fd4e424545
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 25 Sep 2024 04:13:25 +0200
Subject: [PATCH
16/22
] window-list: Allow rearranging window buttons
Subject: [PATCH
08/14
] window-list: Allow rearranging window buttons
We currently sort buttons by the stable sequence to get a persistent
and predictable order. However some users want to customize that
...
...
@@ -968,7 +634,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
3 files changed, 164 insertions(+), 2 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index d
765f58f..bd361646
100644
index d
6d50bd4..02cfd5ff
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -26,12 +26,25 @@
import {WorkspaceIndicator} from './workspaceIndicator.js';
...
...
@@ -1235,10 +901,10 @@ index f9c51f8e..5fb39b2f 100644
2.47.0
From
fc37241b994da3a846f5d7457e4fd21dd2fcf855
Mon Sep 17 00:00:00 2001
From
96985cf67d54b6b6bebc19e7a996a61b03422d37
Mon Sep 17 00:00:00 2001
From: Jakub Steiner <jimmac@gmail.com>
Date: Thu, 3 Oct 2024 14:18:32 +0200
Subject: [PATCH
17/22
] window-list: Indicate drop target more prominently
Subject: [PATCH
09/14
] window-list: Indicate drop target more prominently
The drop target is the main focus of the drag operation, so make
its styling more prominent.
...
...
@@ -1290,10 +956,10 @@ index 5fb39b2f..1ecb83a9 100644
2.47.0
From
e8daa4529a03c863588230fbac55bedf4c821ac3
Mon Sep 17 00:00:00 2001
From
2675b9c856c753a9a7e327263ff04b8ded73a83b
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Thu, 3 Oct 2024 17:05:42 +0200
Subject: [PATCH 1
8/22
] window-list: Fade out drag source during drag
Subject: [PATCH 1
0/14
] window-list: Fade out drag source during drag
During a drag operation, the focus is on the where to drop the dragged
item, not to identify it or its origin.
...
...
@@ -1304,7 +970,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 16 insertions(+), 2 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
bd361646..7825710f
100644
index
02cfd5ff..92a3edfc
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -28,6 +28,9 @@
const DND_ACTIVATE_TIMEOUT = 500;
...
...
@@ -1344,10 +1010,10 @@ index bd361646..7825710f 100644
2.47.0
From
58e06bd93f886b31ae24cb6871738dfdd9f60e85
Mon Sep 17 00:00:00 2001
From
91e285b4c9cad8a819d11fee8b505b3fd7e50bc4
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 9 Oct 2024 19:15:16 +0200
Subject: [PATCH 1
9/22
] window-list: Shrink drag-actor size during drags
Subject: [PATCH 1
1/14
] window-list: Shrink drag-actor size during drags
Like the previous commit, this helps with putting the focus on
the target location instead of the dragged item.
...
...
@@ -1358,7 +1024,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 31 insertions(+), 2 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
7825710f..43395d1c
100644
index
92a3edfc..5a1cdca2
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -31,6 +31,8 @@
const MIN_DRAG_UPDATE_INTERVAL = 500 * GLib.TIME_SPAN_MILLISECOND;
...
...
@@ -1426,10 +1092,10 @@ index 7825710f..43395d1c 100644
2.47.0
From
be0234ced2cb32e7ae253097d5ba8a285ca78c5d
Mon Sep 17 00:00:00 2001
From
24581e748ecea9aaa2497184624b5316ae6b5209
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 8 Oct 2024 19:25:53 +0200
Subject: [PATCH
20/22
] window-list: Handle DND events near the drop target
Subject: [PATCH
12/14
] window-list: Handle DND events near the drop target
Even with the previous change, the dragged actor has the tendency
of obscuring the possible drop target. To alleviate this, handle
...
...
@@ -1441,7 +1107,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 24 insertions(+), 2 deletions(-)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
43395d1c..169b5518
100644
index
5a1cdca2..080080af
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -33,6 +33,8 @@
const DRAG_FADE_DURATION = 200;
...
...
@@ -1498,10 +1164,10 @@ index 43395d1c..169b5518 100644
2.47.0
From
3e707e6fa6ee4c23e3f6f220a93fdbc651757763
Mon Sep 17 00:00:00 2001
From
e92a4f33f51399af4a61601be341be4f90a5a9c7
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Wed, 26 Jun 2024 00:58:18 +0200
Subject: [PATCH
21/22
] window-list: Add `id` property to buttons
Subject: [PATCH
13/14
] window-list: Add `id` property to buttons
A string ID that uniquely identifies a button will allow to
serialize/deserialize the positions in the next commit.
...
...
@@ -1512,7 +1178,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 8 insertions(+)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
169b5518..b5be15e6
100644
index
080080af..d83ca7a8
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -575,6 +575,10 @@
class WindowButton extends BaseButton {
...
...
@@ -1541,10 +1207,10 @@ index 169b5518..b5be15e6 100644
2.47.0
From
f6f3176f3fb004a5410de83ee1aceae7e594150f
Mon Sep 17 00:00:00 2001
From
94b1836d2e0a6ff975988f98b53f44de9f24537c
Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
Date: Tue, 24 Sep 2024 20:31:06 +0200
Subject: [PATCH
22/22
] window-list: Save and restore positions as runtime
Subject: [PATCH
14/14
] window-list: Save and restore positions as runtime
state
While it doesn't make sense for window list positions to be truly
...
...
@@ -1562,7 +1228,7 @@ Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell-extensions/-/merge_requests
1 file changed, 28 insertions(+)
diff --git a/extensions/window-list/extension.js b/extensions/window-list/extension.js
index
b5be15e6..885bb5ac
100644
index
d83ca7a8..a4268589
100644
--- a/extensions/window-list/extension.js
+++ b/extensions/window-list/extension.js
@@ -35,6 +35,8 @@
const DRAG_RESIZE_DURATION = 400;
...
...
This diff is collapsed.
Click to expand it.
SPECS/gnome-shell-extensions.spec
+
6
−
3
View file @
0302cc0b
## START: Set by rpmautospec
## (rpmautospec version 0.7.
2
)
## (rpmautospec version 0.7.
3
)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number =
3
;
release_number =
1
;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
...
...
@@ -22,7 +22,7 @@
%endif
Name: gnome-shell-extensions
Version: 47.
0
Version: 47.
1
Release: %autorelease
Summary: Modify and extend GNOME Shell functionality and behavior
...
...
@@ -430,6 +430,9 @@ rm -rf %{buildroot}/%{_datadir}/xsessions
%changelog
## START: Generated by rpmautospec
* Wed Nov 06 2024 Florian Müllner <fmuellner@redhat.com> - 47.1-1
- Update to 47.1
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 47.0-3
- Bump release for October 2024 mass rebuild:
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment