Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
google-noto-fonts
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
google-noto-fonts
Commits
c71b273b
Commit
c71b273b
authored
7 months ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import google-noto-fonts-20240401-3.el10
parent
d87d76ae
No related branches found
Branches containing commit
Tags
imports/r10s/google-noto-fonts-20240401-3.el10
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
SPECS/google-noto-fonts.spec
+12
-88
12 additions, 88 deletions
SPECS/google-noto-fonts.spec
with
12 additions
and
88 deletions
SPECS/google-noto-fonts.spec
+
12
−
88
View file @
c71b273b
...
...
@@ -29,7 +29,7 @@ in Unicode.\
Name: %{fontname}-fonts
Version: 20240401
Release:
2
%{?dist}
Release:
3
%{?dist}
Summary: Hinted and Non Hinted OpenType fonts for Unicode scripts
License: OFL-1.1
URL: https://notofonts.github.io/
...
...
@@ -82,7 +82,9 @@ local subpackages = {
{ alias="fantasy", family="Music" },
{ alias="fantasy", family="Sans Symbols" },
{ alias="fantasy", family="Sans Symbols2" },
{ alias="fantasy", family="Sans Symbols 2",
obsoletes={ "sans-symbols2" },
},
{ alias="sans-serif", family="Kufi Arabic" },
...
...
@@ -605,7 +607,9 @@ local subpackages = {
fontname="SansMalayalam-UI",
},
{ alias="sans-serif", variable=true, family="Sans Medefaidrin" },
{ alias="sans-serif", variable=true, family="Sans MeeteiMayek" },
{ alias="sans-serif", variable=true, family="Sans Meetei Mayek",
obsoletes={ "sans-meeteimayek-vf" },
},
{ alias="monospace", variable=true, family="Sans Mono",
default=true
},
...
...
@@ -980,88 +984,6 @@ local function has_value(table, value)
return false
end
local function gentestyaml()
local fcorth = { "aa","ab","af","ak","am","an","ar","as","ast","av","ay","az_az","az_ir","ba","be","ber_dz","ber_ma","bg","bh","bho","bi","bin","bm","bn","bo","br","brx","bs","bua","byn","ca","ce","ch","chm","chr","co","crh","cs","csb","cu","cv","cy","da","de","doi","dv","dz","ee","el","en","eo","es","et","eu","fa","fat","ff","fi","fil","fj","fo","fr","fur","fy","ga","gd","gez","gl","gn","gu","gv","ha","haw","he","hi","hne","ho","hr","hsb","ht","hu","hy","hz","ia","id","ie","ig","ii","ik","io","is","it","iu","ja","jv","ka","kaa","kab","ki","kj","kk","kl","km","kn","ko","kok","kr","ks","ku_am","ku_iq","ku_ir","ku_tr","kum","kv","kw","kwm","ky","la","lah","lb","lez","lg","li","ln","lo","lt","lv","mai","mg","mh","mi","mk","ml","mn_cn","mn_mn","mni","mo","mr","ms","mt","my","na","nb","nds","ne","ng","nl","nn","no","nqo","nr","nso","nv","ny","oc","om","or","os","ota","pa","pa_pk","pap_an","pap_aw","pes","pl","prs","ps_af","ps_pk","pt","qu","quz","rm","rn","ro","ru","rw","sa","sah","sat","sc","sco","sd","se","sel","sg","sh","shs","si","sid","sk","sl","sm","sma","smj","smn","sms","sn","so","sq","sr","ss","st","su","sv","sw","syr","szl","ta","te","tg","th","ti_er","ti_et","tig","tk","tl","tn","to","tr","ts","tt","tw","ty","tyv","ug","uk","und_zmth","und_zsye","ur","uz","ve","vi","vo","vot","wa","wal","wen","wo","xh","yap","yi","yo","za","zh_cn","zh_hk","zh_mo","zh_sg","zh_tw","zu" }
local yaml = [[
- hosts: localhost
tags:
- classic
roles:
- role: custom-test-fonts
required_packages:
]]
local langs = {}
local hash = {}
local files = {}
local exfiles = {}
for i = 1, #subpackages do
if subpackages[i]["lang"] ~= nil then
for _,v in ipairs(subpackages[i].lang) do
-- local f = has_value(fcorth, v)
local f = true
local fname = string.gsub(string.gsub(subpackages[i].filename, "(.*/)(.*)", "%2"), "\\", "")
if f and (not hash[v]) then
langs[#langs+1] = v
hash[v] = true
files[v] = {}
exfiles[v] = {}
elseif (not f) then
io.stderr:write("WARNING: " .. fname .. ": " .. v .. " isn't supported in fontconfig\n")
end
if files[v] ~= nil then
if subpackages[i]["excludeci"] ~= nil then
exfiles[v][#exfiles[v]+1] = fname
else
files[v][#files[v]+1] = fname
end
end
end
end
yaml = yaml .. " - " .. subpackages[i].pkgname .. "\n"
end
yaml = yaml .. " coverage:\n"
for i = 1, #langs do
local f = has_value(fcorth, langs[i])
if f then
yaml = yaml .. " " .. langs[i] .. [[:
path_prefix:
- /usr/share/fonts/google-noto-vf
- /usr/share/fonts/google-noto
include:]] .. "\n"
for j = 1, #files[langs[i]] do
yaml = yaml .. " - " .. files[langs[i]][j] .. "\n"
end
if next(exfiles[langs[i]]) ~= nil then
yaml = yaml .. [[
exclude:]] .. "\n"
for j = 1, #exfiles[langs[i]] do
yaml = yaml .. " - " .. exfiles[langs[i]][j] .. "\n"
end
end
end
end
yaml = yaml .. " families:\n"
for i = 1, #subpackages do
if subpackages[i].lang then
for _,v in ipairs(subpackages[i].lang) do
yaml = yaml .. " - lang: " .. v .. "\n" .. [[
package: ]] .. subpackages[i].pkgname .. "\n" .. [[
alias: ]] .. subpackages[i].alias .. "\n" .. [[
family: Noto ]] .. subpackages[i].family .. "\n"
end
end
end
io.stderr:write("Generating tests.yml...")
local f = io.open("tests/tests.yml", "w")
if f then
f:write(yaml)
f:close()
io.stderr:write("Done!")
else
io.stderr:write("Unable to open tests.yml")
end
end
local function genfilelist(table)
local flist = '$(for f in $(cd %{buildroot}/' .. table.fontdir .. ' && find -regex \'./' .. table.filename .. '\' -print); do echo "' .. table.fontdir .. '$f"; done)' .. '\\\n'
_filelistbuild = _filelistbuild .. "cat<<_EOL_>" .. table.pkgname .. ".list\\\n" .. flist .. "_EOL_\\\n"
...
...
@@ -1152,9 +1074,6 @@ for i = 1, #subpackages do
_filelistbuild = "false"
end
end
if tonumber(rpm.expand("%{cionly}")) == 1 then
gentestyaml()
end
print(rpm.expand([[
...
...
@@ -1269,6 +1188,11 @@ done
%changelog
* Fri Jul 12 2024 Akira TAGOH <tagoh@redhat.com> - 20240401-3
- Fix a typo in config.
- Rename google-noto-sans-symbols2-fonts to google-noto-sans-symbols-2-fonts
- Rename google-noto-sans-meeteimayek-vf-fonts to google-noto-sans-meetei-mayek-vf-fonts
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com>
- Bump release for June 2024 mass rebuild
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment