Skip to content
Snippets Groups Projects
Commit 090d6d4e authored by Rocky Automation's avatar Rocky Automation :tv:
Browse files

import grub2-2.02-123.el8

parent 9a050945
No related branches found
No related tags found
No related merge requests found
Showing
with 49 additions and 49 deletions
......@@ -11,7 +11,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
1 file changed, 13 insertions(+)
diff --git a/grub-core/osdep/linux/getroot.c b/grub-core/osdep/linux/getroot.c
index 90d92d3ad5c..6d9f4e5faa2 100644
index 90d92d3ad..6d9f4e5fa 100644
--- a/grub-core/osdep/linux/getroot.c
+++ b/grub-core/osdep/linux/getroot.c
@@ -921,6 +921,19 @@ grub_util_part_to_disk (const char *os_dev, struct stat *st,
......
......@@ -12,7 +12,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
1 file changed, 27 insertions(+), 7 deletions(-)
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
index 43d98476b88..a8a8e2cf325 100644
index 43d98476b..a8a8e2cf3 100644
--- a/util/grub.d/10_linux.in
+++ b/util/grub.d/10_linux.in
@@ -78,6 +78,32 @@ case x"$GRUB_FS" in
......
......@@ -22,7 +22,7 @@ Resolves: rhbz#985962
create mode 100644 util/grub.d/01_users.in
diff --git a/configure.ac b/configure.ac
index 056df1cbaf9..679f634ce4c 100644
index 056df1cba..679f634ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,7 @@ grub_TRANSFORM([grub-mkrelpath])
......@@ -34,7 +34,7 @@ index 056df1cbaf9..679f634ce4c 100644
grub_TRANSFORM([grub-script-check])
grub_TRANSFORM([grub-set-default])
diff --git a/Makefile.util.def b/Makefile.util.def
index 406d96861b6..fd91045bd6d 100644
index 406d96861..fd91045bd 100644
--- a/Makefile.util.def
+++ b/Makefile.util.def
@@ -440,6 +440,12 @@ script = {
......@@ -65,7 +65,7 @@ index 406d96861b6..fd91045bd6d 100644
name = grub-mkconfig_lib;
common = util/grub-mkconfig_lib.in;
diff --git a/.gitignore b/.gitignore
index fa2e5b609b1..5066689bc0a 100644
index fa2e5b609..5066689bc 100644
--- a/.gitignore
+++ b/.gitignore
@@ -111,6 +111,8 @@ grub-*.tar.*
......@@ -78,7 +78,7 @@ index fa2e5b609b1..5066689bc0a 100644
/grub*-shell-tester
/grub*-sparc64-setup
diff --git a/util/grub-mkconfig.in b/util/grub-mkconfig.in
index f68d4925ee6..bdb9982aefb 100644
index f68d4925e..bdb9982ae 100644
--- a/util/grub-mkconfig.in
+++ b/util/grub-mkconfig.in
@@ -282,6 +282,8 @@ for i in "${grub_mkconfig_dir}"/* ; do
......@@ -92,7 +92,7 @@ index f68d4925ee6..bdb9982aefb 100644
echo
diff --git a/util/grub-setpassword.8 b/util/grub-setpassword.8
new file mode 100644
index 00000000000..49200a848b7
index 000000000..49200a848
--- /dev/null
+++ b/util/grub-setpassword.8
@@ -0,0 +1,28 @@
......@@ -126,7 +126,7 @@ index 00000000000..49200a848b7
+.BR "info grub2-mkpasswd-pbkdf2"
diff --git a/util/grub-setpassword.in b/util/grub-setpassword.in
new file mode 100644
index 00000000000..dd76f00fc0e
index 000000000..dd76f00fc
--- /dev/null
+++ b/util/grub-setpassword.in
@@ -0,0 +1,123 @@
......@@ -255,7 +255,7 @@ index 00000000000..dd76f00fc0e
+echo "GRUB2_PASSWORD=${MYPASS}" > "${grubdir}/user.cfg"
diff --git a/util/grub.d/01_users.in b/util/grub.d/01_users.in
new file mode 100644
index 00000000000..db2f44bfb78
index 000000000..db2f44bfb
--- /dev/null
+++ b/util/grub.d/01_users.in
@@ -0,0 +1,11 @@
......
......@@ -15,7 +15,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
2 files changed, 7 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index 679f634ce4c..71d1056969e 100644
index 679f634ce..71d105696 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1796,7 +1796,7 @@ AC_SUBST([LIBDEVMAPPER])
......@@ -28,7 +28,7 @@ index 679f634ce4c..71d1056969e 100644
fi
diff --git a/util/grub-mkconfig_lib.in b/util/grub-mkconfig_lib.in
index 7fe3598435c..113a41f9409 100644
index 7fe359843..113a41f94 100644
--- a/util/grub-mkconfig_lib.in
+++ b/util/grub-mkconfig_lib.in
@@ -33,6 +33,9 @@ fi
......
......@@ -17,7 +17,7 @@ Signed-off-by: Josef Bacik <jbacik@fb.com>
1 file changed, 29 insertions(+), 13 deletions(-)
diff --git a/grub-core/net/tcp.c b/grub-core/net/tcp.c
index e8ad34b84d4..7d4b822626d 100644
index e8ad34b84..7d4b82262 100644
--- a/grub-core/net/tcp.c
+++ b/grub-core/net/tcp.c
@@ -106,6 +106,18 @@ struct tcphdr
......
......@@ -8,7 +8,7 @@ Subject: [PATCH] efinet: add filter for the first exclusive reopen of SNP
1 file changed, 39 insertions(+)
diff --git a/grub-core/net/drivers/efi/efinet.c b/grub-core/net/drivers/efi/efinet.c
index 5388f952ba9..d15a799f29a 100644
index 5388f952b..d15a799f2 100644
--- a/grub-core/net/drivers/efi/efinet.c
+++ b/grub-core/net/drivers/efi/efinet.c
@@ -383,6 +383,45 @@ grub_efi_net_config_real (grub_efi_handle_t hnd, char **device,
......
......@@ -17,7 +17,7 @@ Signed-off-by: Ismael Ripoll-Ripoll <iripoll@disca.upv.es>
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/grub-core/lib/crypto.c b/grub-core/lib/crypto.c
index ca334d5a40e..e6c78d16d39 100644
index ca334d5a4..e6c78d16d 100644
--- a/grub-core/lib/crypto.c
+++ b/grub-core/lib/crypto.c
@@ -468,7 +468,7 @@ grub_password_get (char buf[], unsigned buf_size)
......@@ -30,7 +30,7 @@ index ca334d5a40e..e6c78d16d39 100644
if (cur_len)
cur_len--;
diff --git a/grub-core/normal/auth.c b/grub-core/normal/auth.c
index 6be678c0de1..c35ce972473 100644
index 6be678c0d..c35ce9724 100644
--- a/grub-core/normal/auth.c
+++ b/grub-core/normal/auth.c
@@ -172,7 +172,7 @@ grub_username_get (char buf[], unsigned buf_size)
......
......@@ -14,7 +14,7 @@ Resolves: rhbz#1290803
1 file changed, 5 insertions(+)
diff --git a/util/grub-setpassword.in b/util/grub-setpassword.in
index dd76f00fc0e..fb9d3a3b6f9 100644
index dd76f00fc..fb9d3a3b6 100644
--- a/util/grub-setpassword.in
+++ b/util/grub-setpassword.in
@@ -121,3 +121,8 @@ fi
......
......@@ -14,7 +14,7 @@ Resolves: rhbz#1290799
2 files changed, 8 insertions(+), 9 deletions(-)
diff --git a/util/grub-setpassword.8 b/util/grub-setpassword.8
index 49200a848b7..dc91dd6697b 100644
index 49200a848..dc91dd669 100644
--- a/util/grub-setpassword.8
+++ b/util/grub-setpassword.8
@@ -19,7 +19,7 @@ Display program usage and exit.
......@@ -27,7 +27,7 @@ index 49200a848b7..dc91dd6697b 100644
.SH SEE ALSO
diff --git a/util/grub-setpassword.in b/util/grub-setpassword.in
index fb9d3a3b6f9..c8c0fa4199d 100644
index fb9d3a3b6..c8c0fa419 100644
--- a/util/grub-setpassword.in
+++ b/util/grub-setpassword.in
@@ -16,15 +16,14 @@ grub_mkpasswd="${bindir}/@grub_mkpasswd_pbkdf2@"
......
......@@ -13,7 +13,7 @@ Resolves: rhbz#1294243
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/util/grub-setpassword.in b/util/grub-setpassword.in
index c8c0fa4199d..d7924af5192 100644
index c8c0fa419..d7924af51 100644
--- a/util/grub-setpassword.in
+++ b/util/grub-setpassword.in
@@ -104,7 +104,7 @@ getpass() {
......
......@@ -12,7 +12,7 @@ Resolves: rhbz#1288608
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/grub-core/efiemu/mm.c b/grub-core/efiemu/mm.c
index 52a032f7b2e..92e7df7e501 100644
index 52a032f7b..92e7df7e5 100644
--- a/grub-core/efiemu/mm.c
+++ b/grub-core/efiemu/mm.c
@@ -410,8 +410,8 @@ fill_hook (grub_uint64_t addr, grub_uint64_t size, grub_memory_type_t type,
......
......@@ -11,7 +11,7 @@ Resolves: rhbz#1288608
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/grub-core/efiemu/mm.c b/grub-core/efiemu/mm.c
index 92e7df7e501..52a032f7b2e 100644
index 92e7df7e5..52a032f7b 100644
--- a/grub-core/efiemu/mm.c
+++ b/grub-core/efiemu/mm.c
@@ -410,8 +410,8 @@ fill_hook (grub_uint64_t addr, grub_uint64_t size, grub_memory_type_t type,
......
......@@ -14,7 +14,7 @@ This reverts commit 147daeab22db793978f952b6f0d832919a1b0081.
1 file changed, 39 deletions(-)
diff --git a/grub-core/net/drivers/efi/efinet.c b/grub-core/net/drivers/efi/efinet.c
index d15a799f29a..5388f952ba9 100644
index d15a799f2..5388f952b 100644
--- a/grub-core/net/drivers/efi/efinet.c
+++ b/grub-core/net/drivers/efi/efinet.c
@@ -383,45 +383,6 @@ grub_efi_net_config_real (grub_efi_handle_t hnd, char **device,
......
......@@ -20,7 +20,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
create mode 100644 include/grub/net/url.h
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
index cd0902b46b8..991891a6e09 100644
index cd0902b46..991891a6e 100644
--- a/grub-core/Makefile.core.def
+++ b/grub-core/Makefile.core.def
@@ -2185,6 +2185,7 @@ module = {
......@@ -32,7 +32,7 @@ index cd0902b46b8..991891a6e09 100644
module = {
diff --git a/grub-core/kern/misc.c b/grub-core/kern/misc.c
index 8344526be7f..f1fab700048 100644
index 8344526be..f1fab7000 100644
--- a/grub-core/kern/misc.c
+++ b/grub-core/kern/misc.c
@@ -296,6 +296,19 @@ grub_strrchr (const char *s, int c)
......@@ -57,7 +57,7 @@ index 8344526be7f..f1fab700048 100644
{
diff --git a/grub-core/net/url.c b/grub-core/net/url.c
new file mode 100644
index 00000000000..146858284cd
index 000000000..146858284
--- /dev/null
+++ b/grub-core/net/url.c
@@ -0,0 +1,861 @@
......@@ -923,7 +923,7 @@ index 00000000000..146858284cd
+}
+#endif
diff --git a/include/grub/misc.h b/include/grub/misc.h
index 83fd69f4ada..fcaf1201e39 100644
index 83fd69f4a..fcaf1201e 100644
--- a/include/grub/misc.h
+++ b/include/grub/misc.h
@@ -85,6 +85,7 @@ int EXPORT_FUNC(grub_strncmp) (const char *s1, const char *s2, grub_size_t n);
......@@ -987,7 +987,7 @@ index 83fd69f4ada..fcaf1201e39 100644
{
diff --git a/include/grub/net/url.h b/include/grub/net/url.h
new file mode 100644
index 00000000000..a215fa27d0a
index 000000000..a215fa27d
--- /dev/null
+++ b/include/grub/net/url.h
@@ -0,0 +1,28 @@
......
......@@ -14,7 +14,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
6 files changed, 478 insertions(+), 14 deletions(-)
diff --git a/grub-core/net/bootp.c b/grub-core/net/bootp.c
index f03eeab2fb4..da3e454466b 100644
index f03eeab2f..da3e45446 100644
--- a/grub-core/net/bootp.c
+++ b/grub-core/net/bootp.c
@@ -23,6 +23,7 @@
......@@ -206,7 +206,7 @@ index f03eeab2fb4..da3e454466b 100644
grub_net_process_dhcp (struct grub_net_buff *nb,
struct grub_net_card *card)
diff --git a/grub-core/net/drivers/efi/efinet.c b/grub-core/net/drivers/efi/efinet.c
index 5388f952ba9..a4daaa460bd 100644
index 5388f952b..a4daaa460 100644
--- a/grub-core/net/drivers/efi/efinet.c
+++ b/grub-core/net/drivers/efi/efinet.c
@@ -18,11 +18,15 @@
......@@ -315,7 +315,7 @@ index 5388f952ba9..a4daaa460bd 100644
}
}
diff --git a/grub-core/net/net.c b/grub-core/net/net.c
index 16d2ce06d5a..4be228d9576 100644
index 16d2ce06d..4be228d95 100644
--- a/grub-core/net/net.c
+++ b/grub-core/net/net.c
@@ -955,6 +955,78 @@ grub_net_network_level_interface_register (struct grub_net_network_level_interfa
......@@ -398,7 +398,7 @@ index 16d2ce06d5a..4be228d9576 100644
grub_err_t
grub_net_add_ipv4_local (struct grub_net_network_level_interface *inter,
diff --git a/grub-core/net/tftp.c b/grub-core/net/tftp.c
index 7d90bf66e76..1157524fc50 100644
index 7d90bf66e..1157524fc 100644
--- a/grub-core/net/tftp.c
+++ b/grub-core/net/tftp.c
@@ -379,19 +379,23 @@ tftp_open (struct grub_file *file, const char *filename)
......@@ -426,7 +426,7 @@ index 7d90bf66e76..1157524fc50 100644
grub_free (data);
return grub_errno;
diff --git a/include/grub/efi/api.h b/include/grub/efi/api.h
index c7c9f0e1db1..28b6adf7648 100644
index c7c9f0e1d..28b6adf76 100644
--- a/include/grub/efi/api.h
+++ b/include/grub/efi/api.h
@@ -572,10 +572,16 @@ typedef void *grub_efi_handle_t;
......@@ -581,7 +581,7 @@ index c7c9f0e1db1..28b6adf7648 100644
typedef struct grub_efi_pxe
diff --git a/include/grub/net.h b/include/grub/net.h
index 50d62ab0c8c..f8f3ec13acc 100644
index 50d62ab0c..f8f3ec13a 100644
--- a/include/grub/net.h
+++ b/include/grub/net.h
@@ -442,6 +442,51 @@ struct grub_net_bootp_packet
......
......@@ -24,7 +24,7 @@ Resolves: rhbz#1226325
create mode 100644 util/grub-get-kernel-settings.in
diff --git a/configure.ac b/configure.ac
index 71d1056969e..aa06ed59c8d 100644
index 71d105696..aa06ed59c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,7 @@ grub_TRANSFORM([grub-install])
......@@ -44,7 +44,7 @@ index 71d1056969e..aa06ed59c8d 100644
grub_TRANSFORM([grub-install.1])
grub_TRANSFORM([grub-kbdcomp.3])
diff --git a/Makefile.util.def b/Makefile.util.def
index fd91045bd6d..2d032643de7 100644
index fd91045bd..2d032643d 100644
--- a/Makefile.util.def
+++ b/Makefile.util.def
@@ -714,6 +714,13 @@ script = {
......@@ -62,7 +62,7 @@ index fd91045bd6d..2d032643de7 100644
name = grub-set-default;
common = util/grub-set-default.in;
diff --git a/.gitignore b/.gitignore
index 5066689bc0a..54795fa60be 100644
index 5066689bc..54795fa60 100644
--- a/.gitignore
+++ b/.gitignore
@@ -68,6 +68,8 @@ grub-*.tar.*
......@@ -75,7 +75,7 @@ index 5066689bc0a..54795fa60be 100644
/grub*-glue-efi.1
/grub*-install
diff --git a/util/bash-completion.d/grub-completion.bash.in b/util/bash-completion.d/grub-completion.bash.in
index 44bf135b9f8..5c4acd496d4 100644
index 44bf135b9..5c4acd496 100644
--- a/util/bash-completion.d/grub-completion.bash.in
+++ b/util/bash-completion.d/grub-completion.bash.in
@@ -264,6 +264,28 @@ have ${__grub_sparc64_setup_program} && \
......@@ -109,7 +109,7 @@ index 44bf135b9f8..5c4acd496d4 100644
#
diff --git a/util/grub-get-kernel-settings.3 b/util/grub-get-kernel-settings.3
new file mode 100644
index 00000000000..ba33330e28d
index 000000000..ba33330e2
--- /dev/null
+++ b/util/grub-get-kernel-settings.3
@@ -0,0 +1,20 @@
......@@ -135,7 +135,7 @@ index 00000000000..ba33330e28d
+.BR "info grub"
diff --git a/util/grub-get-kernel-settings.in b/util/grub-get-kernel-settings.in
new file mode 100644
index 00000000000..12046219878
index 000000000..120462198
--- /dev/null
+++ b/util/grub-get-kernel-settings.in
@@ -0,0 +1,78 @@
......@@ -218,7 +218,7 @@ index 00000000000..12046219878
+ echo export GRUB_LINUX_DEBUG_TITLE_POSTFIX
+fi
diff --git a/util/grub-mkconfig.in b/util/grub-mkconfig.in
index bdb9982aefb..8218f3d477f 100644
index bdb9982ae..8218f3d47 100644
--- a/util/grub-mkconfig.in
+++ b/util/grub-mkconfig.in
@@ -45,6 +45,7 @@ grub_probe="${sbindir}/@grub_probe@"
......@@ -239,7 +239,7 @@ index bdb9982aefb..8218f3d477f 100644
if [ -z "$GRUB_DEVICE_UUID" ]; then
GRUB_DEVICE_UUID="$GRUB_DEVICE_UUID_GENERATED"
diff --git a/util/grub.d/10_linux.in b/util/grub.d/10_linux.in
index a8a8e2cf325..4e49ccdf742 100644
index a8a8e2cf3..4e49ccdf7 100644
--- a/util/grub.d/10_linux.in
+++ b/util/grub.d/10_linux.in
@@ -111,7 +111,8 @@ linux_entry ()
......
......@@ -12,7 +12,7 @@ Signed-off-by: Peter Jones <pjones@redhat.com>
1 file changed, 23 insertions(+), 1 deletion(-)
diff --git a/grub-core/net/tftp.c b/grub-core/net/tftp.c
index 1157524fc50..5ca0a96a6f6 100644
index 1157524fc..5ca0a96a6 100644
--- a/grub-core/net/tftp.c
+++ b/grub-core/net/tftp.c
@@ -300,6 +300,25 @@ destroy_pq (tftp_data_t data)
......
......@@ -16,7 +16,7 @@ Signed-off-by: Mark Salter <msalter@redhat.com>
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/grub-core/net/tftp.c b/grub-core/net/tftp.c
index 5ca0a96a6f6..dcd82494309 100644
index 5ca0a96a6..dcd824943 100644
--- a/grub-core/net/tftp.c
+++ b/grub-core/net/tftp.c
@@ -360,8 +360,8 @@ tftp_open (struct grub_file *file, const char *filename)
......
......@@ -30,7 +30,7 @@ The count of zero with __builtin_clz can be 22. (clz counts the number of one bi
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/grub-core/net/drivers/ieee1275/ofnet.c b/grub-core/net/drivers/ieee1275/ofnet.c
index 002446be1c3..3df75357a70 100644
index 002446be1..3df75357a 100644
--- a/grub-core/net/drivers/ieee1275/ofnet.c
+++ b/grub-core/net/drivers/ieee1275/ofnet.c
@@ -220,8 +220,7 @@ grub_ieee1275_parse_bootpath (const char *devpath, char *bootpath,
......
......@@ -13,7 +13,7 @@ Subject: [PATCH] Make grub_fatal() also backtrace.
create mode 100644 grub-core/lib/arm64/backtrace.c
diff --git a/grub-core/Makefile.core.def b/grub-core/Makefile.core.def
index 991891a6e09..27563743ba9 100644
index 991891a6e..27563743b 100644
--- a/grub-core/Makefile.core.def
+++ b/grub-core/Makefile.core.def
@@ -175,6 +175,9 @@ kernel = {
......@@ -27,7 +27,7 @@ index 991891a6e09..27563743ba9 100644
i386_xen = kern/i386/dl.c;
diff --git a/grub-core/kern/misc.c b/grub-core/kern/misc.c
index f1fab700048..5ce89a40c68 100644
index f1fab7000..5ce89a40c 100644
--- a/grub-core/kern/misc.c
+++ b/grub-core/kern/misc.c
@@ -24,6 +24,7 @@
......@@ -55,7 +55,7 @@ index f1fab700048..5ce89a40c68 100644
#endif
diff --git a/grub-core/lib/arm64/backtrace.c b/grub-core/lib/arm64/backtrace.c
new file mode 100644
index 00000000000..1079b5380e1
index 000000000..1079b5380
--- /dev/null
+++ b/grub-core/lib/arm64/backtrace.c
@@ -0,0 +1,62 @@
......@@ -122,7 +122,7 @@ index 00000000000..1079b5380e1
+}
+
diff --git a/grub-core/lib/backtrace.c b/grub-core/lib/backtrace.c
index 825a8800e25..c0ad6ab8be1 100644
index 825a8800e..c0ad6ab8b 100644
--- a/grub-core/lib/backtrace.c
+++ b/grub-core/lib/backtrace.c
@@ -29,6 +29,7 @@ GRUB_MOD_LICENSE ("GPLv3+");
......@@ -142,7 +142,7 @@ index 825a8800e25..c0ad6ab8be1 100644
}
diff --git a/grub-core/lib/i386/backtrace.c b/grub-core/lib/i386/backtrace.c
index c3e03c7275c..c67273db3ae 100644
index c3e03c727..c67273db3 100644
--- a/grub-core/lib/i386/backtrace.c
+++ b/grub-core/lib/i386/backtrace.c
@@ -15,11 +15,23 @@
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment