Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
grub2
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
grub2
Commits
58ca39df
Commit
58ca39df
authored
1 week ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import grub2-2.12-14.el10
parent
6e006ec0
Branches
r9-beta
Tags
imports/r9-beta/glibc-2.34-122.el9_5
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
SOURCES/0362-ieee1275-ofnet-Fix-grub_malloc-removed-after-added-s.patch
+32
-0
32 additions, 0 deletions
...eee1275-ofnet-Fix-grub_malloc-removed-after-added-s.patch
SOURCES/grub.patches
+1
-0
1 addition, 0 deletions
SOURCES/grub.patches
SPECS/grub2.spec
+6
-2
6 additions, 2 deletions
SPECS/grub2.spec
with
39 additions
and
2 deletions
SOURCES/0362-ieee1275-ofnet-Fix-grub_malloc-removed-after-added-s.patch
0 → 100644
+
32
−
0
View file @
58ca39df
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Nicolas Frayer <nfrayer@redhat.com>
Date: Wed, 19 Mar 2025 17:39:41 +0100
Subject: [PATCH] ieee1275/ofnet: Fix grub_malloc() removed after added safe
math functions
grub_malloc() has been inadvertently removed from the ieee1275/ofnet
code after it has been modified to use safe match function.
Fixes: 4beeff8a (net: Use safe math macros to prevent overflows)
Tested-by: Marta Lewandowska <mlewando@redhat.com>
Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>
Signed-off-by: Nicolas Frayer <nfrayer@redhat.com>
---
grub-core/net/drivers/ieee1275/ofnet.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/grub-core/net/drivers/ieee1275/ofnet.c b/grub-core/net/drivers/ieee1275/ofnet.c
index 3e1b9094e2ab..37bc82467f60 100644
--- a/grub-core/net/drivers/ieee1275/ofnet.c
+++ b/grub-core/net/drivers/ieee1275/ofnet.c
@@ -463,6 +463,9 @@
search_net_devices (struct grub_ieee1275_devalias *alias)
return 0;
}
}
+
+ ofdata->path = grub_malloc(sz);
+
if (!ofdata->path)
{
grub_print_error ();
This diff is collapsed.
Click to expand it.
SOURCES/grub.patches
+
1
−
0
View file @
58ca39df
...
...
@@ -358,3 +358,4 @@ Patch0358: 0358-loader-i386-linux-Cast-left-shift-to-grub_uint32_t.patch
Patch0359: 0359-loader-i386-bsd-Use-safe-math-to-avoid-underflow.patch
Patch0360: 0360-fs-ext2-Rework-out-of-bounds-read-for-inline-and-ext.patch
Patch0361: 0361-powerpc-increase-MIN-RMA-size-for-CAS-negotiation.patch
Patch0362: 0362-ieee1275-ofnet-Fix-grub_malloc-removed-after-added-s.patch
This diff is collapsed.
Click to expand it.
SPECS/grub2.spec
+
6
−
2
View file @
58ca39df
...
...
@@ -17,7 +17,7 @@
Name: grub2
Epoch: 1
Version: 2.12
Release: 1
3
%{?dist}
Release: 1
4
%{?dist}
Summary: Bootloader with support for Linux, Multiboot and more
License: GPL-3.0-or-later
URL: http://www.gnu.org/software/grub/
...
...
@@ -587,11 +587,15 @@ mv ${EFI_HOME}/grub.cfg.stb ${EFI_HOME}/grub.cfg
%endif
%changelog
* Tue Mar
18
2025 Release Engineering <releng@rockylinux.org> - 2.12-1
3
* Tue Mar
25
2025 Release Engineering <releng@rockylinux.org> - 2.12-1
4
- Replace sbat with Rocky Linux sbat (label)
- Change bug tracker URL (label)
- Add missing riscv64 support (label)
* Tue Mar 25 2025 Nicolas Frayer <nfrayer@redhat.com> 2.12-14
- ieee1275/ofnet: Fix grub_malloc() removed after added safe
- Related: #RHEL-80073
* Tue Mar 18 2025 Nicolas Frayer <nfrayer@redhat.com> 2.12-13
- powerpc: increase MIN RMA size for CAS negotiation
- Resolves: #RHEL-76429
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment