Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
grubby
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
grubby
Commits
209034da
Commit
209034da
authored
2 months ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import grubby-8.40-80.el10
parent
a8b0e8e0
No related branches found
Branches containing commit
Tags
imports/r10s/grubby-8.40-80.el10
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/grubby-bls
+15
-21
15 additions, 21 deletions
SOURCES/grubby-bls
SPECS/grubby.spec
+14
-2
14 additions, 2 deletions
SPECS/grubby.spec
with
29 additions
and
23 deletions
SOURCES/grubby-bls
+
15
−
21
View file @
209034da
...
...
@@ -595,33 +595,27 @@ remove_var_prefix() {
update_grubcfg
()
{
# Older ppc64le OPAL firmware
(petitboot version < 1.8.0) don't have BLS support
#
so grub2-mkconfig has to be run
to generate a config with menuentry commands.
# Older ppc64le OPAL firmware
don't have BLS support so grub2-mkconfig has to be run
# to generate a config with menuentry commands.
if
[
"
${
arch
}
"
=
"ppc64le"
]
&&
[
-d
/sys/firmware/opal
]
;
then
RUN_MKCONFIG
=
"true"
petitboot_path
=
"/sys/firmware/devicetree/base/ibm,firmware-versions/petitboot"
if
test
-e
${
petitboot_path
}
;
then
read
-r
-d
''
petitboot_version <
${
petitboot_path
}
petitboot_version
=
"
$(
echo
${
petitboot_version
//v
}
)
"
if
test
-n
${
petitboot_version
}
;
then
major_version
=
"
$(
echo
${
petitboot_version
}
|
cut
-d
.
-f1
)
"
minor_version
=
"
$(
echo
${
petitboot_version
}
|
cut
-d
.
-f2
)
"
re
=
'^[0-9]+$'
if
[[
$major_version
=
~
$re
]]
&&
[[
$minor_version
=
~
$re
]]
&&
([[
${
major_version
}
-gt
1
]]
||
[[
${
major_version
}
-eq
1
&&
${
minor_version
}
-ge
8
]])
;
then
RUN_MKCONFIG
=
"false"
fi
fi
fi
# PV and PVH Xen DomU guests boot with pygrub that doesn't have BLS support,
# also Xen Dom0 use the menuentries from 20_linux_xen and not the ones from
# 10_linux. So grub2-mkconfig has to run for both Xen Dom0 and DomU.
if
[[
-e
/sys/hypervisor/type
]]
&&
grep
-q
"^xen$"
/sys/hypervisor/type
;
then
if
[
!
-e
/sys/hypervisor/guest_type
]
||
!
grep
-q
"^HVM$"
/sys/hypervisor/guest_type
;
then
RUN_MKCONFIG
=
true
fi
fi
if
[[
$RUN_MKCONFIG
=
"true"
]]
;
then
grub2-mkconfig
--no-grubenv-update
-o
"
${
grub_config
}
"
>
& /dev/null
if
[[
$bootloader
=
"zipl"
]]
;
then
zipl
else
grub2-mkconfig
--no-grubenv-update
-o
"
${
grub_config
}
"
&> /dev/null
fi
fi
}
...
...
This diff is collapsed.
Click to expand it.
SPECS/grubby.spec
+
14
−
2
View file @
209034da
...
...
@@ -3,7 +3,7 @@
Name: grubby
Version: 8.40
Release:
77
%{?dist}
Release:
80
%{?dist}
Summary: Command line tool for updating bootloader configs
License: GPL-2.0-or-later
Source1: grubby-bls
...
...
@@ -75,9 +75,21 @@ fi
%{_mandir}/man8/grubby.8*
%changelog
*
Thu Dec
1
2
202
4
Release Engineering <releng@rockylinux.org> - 8.40-
77
*
Fri Jan
1
0
202
5
Release Engineering <releng@rockylinux.org> - 8.40-
80
- Add riscv64 device tree support
* Fri Dec 06 2024 Leo Sandoval <lsandova@redhat.com> - 8.40-80
- grubby-bls: on PPC systems, remove petiboot's version checks
Resolves: #RHEL-70194
* Fri Dec 06 2024 Leo Sandoval <lsandova@redhat.com> - 8.40-79
- grubby-bls: in s390* systems, run zipl on grub cfg update event
Resolves: #RHEL-36092
* Thu Dec 05 2024 Leo Sandoval <lsandova@redhat.com> - 8.40-78
- On grub cfg updates, run grub2-mkconfig for Xen systems
Resolves: #RHEL-70200
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 8.40-77
- Bump release for October 2024 mass rebuild:
Resolves: RHEL-64018
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment