Skip to content
Snippets Groups Projects
Commit bf1fbc18 authored by Rocky Automation's avatar Rocky Automation :tv:
Browse files

import kernel-6.11.0-28.el10

parent d2c09235
No related branches found
Tags imports/r10s/kernel-6.11.0-28.el10
No related merge requests found
diff --git a/tools/lib/bpf/Makefile b/tools/lib/bpf/Makefile
index 1b22f0f37..857a5f7b4 100644
--- a/tools/lib/bpf/Makefile
+++ b/tools/lib/bpf/Makefile
@@ -61,7 +61,8 @@ ifndef VERBOSE
endif
INCLUDES = -I$(or $(OUTPUT),.) \
- -I$(srctree)/tools/include -I$(srctree)/tools/include/uapi
+ -I$(srctree)/tools/include -I$(srctree)/tools/include/uapi \
+ -I$(srctree)/tools/arch/$(SRCARCH)/include
export prefix libdir src obj
diff --git a/tools/testing/selftests/bpf/Makefile b/tools/testing/selftests/bpf/Makefile
index 75016962f..43a029318 100644
--- a/tools/testing/selftests/bpf/Makefile
+++ b/tools/testing/selftests/bpf/Makefile
@@ -10,6 +10,7 @@ TOOLSDIR := $(abspath ../../..)
LIBDIR := $(TOOLSDIR)/lib
BPFDIR := $(LIBDIR)/bpf
TOOLSINCDIR := $(TOOLSDIR)/include
+TOOLSARCHINCDIR := $(TOOLSDIR)/arch/$(SRCARCH)/include
BPFTOOLDIR := $(TOOLSDIR)/bpf/bpftool
APIDIR := $(TOOLSINCDIR)/uapi
ifneq ($(O),)
@@ -44,7 +45,7 @@ CFLAGS += -g $(OPT_FLAGS) -rdynamic \
-Wall -Werror -fno-omit-frame-pointer \
$(GENFLAGS) $(SAN_CFLAGS) $(LIBELF_CFLAGS) \
-I$(CURDIR) -I$(INCLUDE_DIR) -I$(GENDIR) -I$(LIBDIR) \
- -I$(TOOLSINCDIR) -I$(APIDIR) -I$(OUTPUT)
+ -I$(TOOLSINCDIR) -I$(TOOLSARCHINCDIR) -I$(APIDIR) -I$(OUTPUT)
LDFLAGS += $(SAN_LDFLAGS)
LDLIBS += $(LIBELF_LIBS) -lz -lrt -lpthread
......@@ -1022,6 +1022,7 @@ Patch1: patch-%{patchversion}-redhat.patch
# empty final patch to facilitate testing of kernel patches
Patch999999: linux-kernel-test.patch
Patch1000000: 1000-debrand-some-messages.patch
Patch1000001: 1001-fix-riscv.patch
# END OF PATCH DEFINITIONS
......@@ -1862,6 +1863,8 @@ cp -a %{SOURCE1} .
ApplyOptionalPatch patch-%{patchversion}-redhat.patch
%endif
ApplyOptionalPatch 1000-debrand-some-messages.patch
ApplyOptionalPatch 1001-fix-riscv.patch
ApplyOptionalPatch linux-kernel-test.patch
%{log_msg "End of patch applications"}
......@@ -4148,7 +4151,7 @@ fi\
#
#
%changelog
* Tue Nov 05 2024 Release Engineering <releng@rockylinux.org> - 6.11.0-28
* Wed Nov 06 2024 Release Engineering <releng@rockylinux.org> - 6.11.0-28
- Porting to Rocky Linux 10, debranding and Rocky Linux branding
- Add partial riscv64 support for build root
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment