Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
O
osbuild-composer
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
osbuild-composer
Commits
6b7f5f57
Commit
6b7f5f57
authored
9 months ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import osbuild-composer-113-1.el10
parent
0112f842
No related branches found
No related tags found
No related merge requests found
Changes
3
Expand all
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
.osbuild-composer.metadata
+1
-1
1 addition, 1 deletion
.osbuild-composer.metadata
SOURCES/0001-Add-support-for-Rocky-Linux.patch
+364
-117
364 additions, 117 deletions
SOURCES/0001-Add-support-for-Rocky-Linux.patch
SPECS/osbuild-composer.spec
+16
-15
16 additions, 15 deletions
SPECS/osbuild-composer.spec
with
381 additions
and
133 deletions
.osbuild-composer.metadata
+
1
−
1
View file @
6b7f5f57
b5491caee53d594b5c5af8700e27d59514f4ed6d11c0add627a5b8afdc8899a9
SOURCES/osbuild-composer-1
09
.tar.gz
0f87f80dfe4e14c19b242cd0145b5e903114cec7e539128543b90c9b992c821a
SOURCES/osbuild-composer-1
13
.tar.gz
This diff is collapsed.
Click to expand it.
SOURCES/0001-Add-support-for-Rocky-Linux.patch
+
364
−
117
View file @
6b7f5f57
This diff is collapsed.
Click to expand it.
SPECS/osbuild-composer.spec
+
16
−
15
View file @
6b7f5f57
...
...
@@ -12,7 +12,7 @@
%global goipath github.com/osbuild/osbuild-composer
Version: 1
09
Version: 1
13
%gometa
...
...
@@ -25,7 +25,7 @@ It is compatible with composer-cli and cockpit-composer clients.
}
Name: osbuild-composer
Release:
2
%{?dist}.rocky.0.6
Release:
1
%{?dist}.rocky.0.6
Summary: An image building service based on osbuild
# osbuild-composer doesn't have support for building i686 and armv7hl images
...
...
@@ -36,11 +36,8 @@ License: Apache-2.0
URL: %{gourl}
Source0: %{gosource}
# https://github.com/osbuild/osbuild-composer/pull/4179
Patch0: PR-4179.patch
# https://github.com/osbuild/osbuild-composer/pull/4186
Patch1: PR-4186.patch
Patch2: 0001-Add-support-for-Rocky-Linux.patch
Patch1: 0001-Add-support-for-Rocky-Linux.patch
BuildRequires: %{?go_compiler:compiler(go-compiler)}%{!?go_compiler:golang}
BuildRequires: systemd
...
...
@@ -111,6 +108,7 @@ export LDFLAGS="${LDFLAGS} -X 'github.com/osbuild/osbuild-composer/internal/comm
%gobuild ${GOTAGS:+-tags=$GOTAGS} -o _bin/osbuild-composer %{goipath}/cmd/osbuild-composer
%gobuild ${GOTAGS:+-tags=$GOTAGS} -o _bin/osbuild-worker %{goipath}/cmd/osbuild-worker
%gobuild ${GOTAGS:+-tags=$GOTAGS} -o _bin/osbuild-worker-executor %{goipath}/cmd/osbuild-worker-executor
%gobuild ${GOTAGS:+-tags=$GOTAGS} -o _bin/osbuild-jobsite-manager %{goipath}/cmd/osbuild-jobsite-manager
%gobuild ${GOTAGS:+-tags=$GOTAGS} -o _bin/osbuild-jobsite-builder %{goipath}/cmd/osbuild-jobsite-builder
...
...
@@ -151,6 +149,7 @@ go build -tags="integration${GOTAGS:+,$GOTAGS}" -ldflags="${TEST_LDFLAGS}" -o _b
install -m 0755 -vd %{buildroot}%{_libexecdir}/osbuild-composer
install -m 0755 -vp _bin/osbuild-composer %{buildroot}%{_libexecdir}/osbuild-composer/
install -m 0755 -vp _bin/osbuild-worker %{buildroot}%{_libexecdir}/osbuild-composer/
install -m 0755 -vp _bin/osbuild-worker-executor %{buildroot}%{_libexecdir}/osbuild-composer/
install -m 0755 -vp _bin/osbuild-jobsite-manager %{buildroot}%{_libexecdir}/osbuild-composer/
install -m 0755 -vp _bin/osbuild-jobsite-builder %{buildroot}%{_libexecdir}/osbuild-composer/
...
...
@@ -168,13 +167,6 @@ install -m 0644 -vp repositories/centos-* %{buildroot}%
# All other CentOS versions support building for the same version
install -m 0644 -vp repositories/centos-%{centos}* %{buildroot}%{_datadir}/osbuild-composer/repositories/
install -m 0644 -vp repositories/centos-stream-%{centos}* %{buildroot}%{_datadir}/osbuild-composer/repositories/
# CentOS 9 supports building also for CentOS 8
%if 0%{?centos} == 9
install -m 0644 -vp repositories/centos-8* %{buildroot}%{_datadir}/osbuild-composer/repositories/
install -m 0644 -vp repositories/centos-stream-8* %{buildroot}%{_datadir}/osbuild-composer/repositories/
%endif
%endif
%else
...
...
@@ -184,6 +176,11 @@ install -m 0644 -vp repositories/centos-stream-8* %{buildroot}%{
%if 0%{?rhel} >= 10
install -m 0644 -vp repositories/rhel-* %{buildroot}%{_datadir}/osbuild-composer/repositories/
# RHEL-8 auxiliary key is signed using SHA-1, which is not enabled by default on RHEL-10 and later
for REPO_FILE in $(ls repositories/rhel-8*-no-aux-key.json); do
install -m 0644 -vp ${REPO_FILE} %{buildroot}%{_datadir}/osbuild-composer/repositories/$(basename ${REPO_FILE} | sed 's/-no-aux-key//g')
done
%else
# All other RHEL versions support building for the same version
install -m 0644 -vp repositories/rhel-%{rhel}* %{buildroot}%{_datadir}/osbuild-composer/repositories/
...
...
@@ -360,6 +357,7 @@ The worker for osbuild-composer
%files worker
%{_libexecdir}/osbuild-composer/osbuild-worker
%{_libexecdir}/osbuild-composer/osbuild-worker-executor
%{_libexecdir}/osbuild-composer/osbuild-jobsite-manager
%{_libexecdir}/osbuild-composer/osbuild-jobsite-builder
%{_unitdir}/osbuild-worker@.service
...
...
@@ -458,9 +456,12 @@ Integration tests to be run on a pristine-dedicated system to test the osbuild-c
%endif
%changelog
*
Tue Jun 25
2024 Release Engineering <releng@rockylinux.org> - 1
09-2
.rocky.0.6
*
Fri Jul 12
2024 Release Engineering <releng@rockylinux.org> - 1
13-1
.rocky.0.6
- Add Rocky Linux support and host detection
* Fri Jul 12 2024 imagebuilder-bot <imagebuilder-bots+imagebuilder-bot@redhat.com> - 113-1
- New upstream release
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 109-2
- Bump release for June 2024 mass rebuild
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment