Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
P
python3.11
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
python3.11
Commits
4da6fb88
Commit
4da6fb88
authored
2 years ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import python3.11-3.11.1-4.el8
parent
e14f2c5e
No related branches found
Branches containing commit
Tags
imports/c8/ansible-freeipa-1.9.2-1.el8
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
SPECS/python3.11.spec
+11
-15
11 additions, 15 deletions
SPECS/python3.11.spec
with
11 additions
and
15 deletions
SPECS/python3.11.spec
+
11
−
15
View file @
4da6fb88
...
@@ -20,7 +20,7 @@ URL: https://www.python.org/
...
@@ -20,7 +20,7 @@ URL: https://www.python.org/
#global prerel ...
#global prerel ...
%global upstream_version %{general_version}%{?prerel}
%global upstream_version %{general_version}%{?prerel}
Version: %{general_version}%{?prerel:~%{prerel}}
Version: %{general_version}%{?prerel:~%{prerel}}
Release:
2
%{?dist}
Release:
4
%{?dist}
License: Python
License: Python
...
@@ -55,11 +55,11 @@ License: Python
...
@@ -55,11 +55,11 @@ License: Python
# IMPORTANT: When bootstrapping, it's very likely the wheels for pip and
# IMPORTANT: When bootstrapping, it's very likely the wheels for pip and
# setuptools are not available. Turn off the rpmwheels bcond until
# setuptools are not available. Turn off the rpmwheels bcond until
# the two packages are built with wheels to get around the issue.
# the two packages are built with wheels to get around the issue.
%bcond_with
out
bootstrap
%bcond_with bootstrap
# Whether to use RPM build wheels from the python-{pip,setuptools}-wheel package
# Whether to use RPM build wheels from the python-{pip,setuptools}-wheel package
# Uses upstream bundled prebuilt wheels otherwise
# Uses upstream bundled prebuilt wheels otherwise
%bcond_with rpmwheels
%bcond_with
out
rpmwheels
# If the rpmwheels condition is disabled, we use the bundled wheel packages
# If the rpmwheels condition is disabled, we use the bundled wheel packages
# from Python with the versions below.
# from Python with the versions below.
# This needs to be manually updated when we update Python.
# This needs to be manually updated when we update Python.
...
@@ -521,8 +521,6 @@ Requires: %{pkgname}-libs%{?_isa} = %{version}-%{release}
...
@@ -521,8 +521,6 @@ Requires: %{pkgname}-libs%{?_isa} = %{version}-%{release}
# But we want them when packages BuildRequire python3-devel
# But we want them when packages BuildRequire python3-devel
Requires: (python-rpm-macros if rpm-build)
Requires: (python-rpm-macros if rpm-build)
Requires: (python3-rpm-macros if rpm-build)
Requires: (python3-rpm-macros if rpm-build)
Requires: (python-modular-rpm-macros if rpm-build)
Suggests: python3.11-rpm-macros
# Require alternatives version that implements the --keep-foreign flag
# Require alternatives version that implements the --keep-foreign flag
Requires(postun): alternatives >= 1.19.1-1
Requires(postun): alternatives >= 1.19.1-1
...
@@ -796,6 +794,7 @@ BuildPython() {
...
@@ -796,6 +794,7 @@ BuildPython() {
--with-dtrace \
--with-dtrace \
--with-lto \
--with-lto \
--with-ssl-default-suites=openssl \
--with-ssl-default-suites=openssl \
--with-builtin-hashlib-hashes=blake2 \
--without-static-libpython \
--without-static-libpython \
%if %{with rpmwheels}
%if %{with rpmwheels}
--with-wheel-pkg-dir=%{python_wheel_dir} \
--with-wheel-pkg-dir=%{python_wheel_dir} \
...
@@ -1378,11 +1377,6 @@ fi
...
@@ -1378,11 +1377,6 @@ fi
%{pylibdir}/pydoc_data
%{pylibdir}/pydoc_data
%{dynload_dir}/_blake2.%{SOABI_optimized}.so
%{dynload_dir}/_blake2.%{SOABI_optimized}.so
%{dynload_dir}/_md5.%{SOABI_optimized}.so
%{dynload_dir}/_sha1.%{SOABI_optimized}.so
%{dynload_dir}/_sha256.%{SOABI_optimized}.so
%{dynload_dir}/_sha3.%{SOABI_optimized}.so
%{dynload_dir}/_sha512.%{SOABI_optimized}.so
%{dynload_dir}/_asyncio.%{SOABI_optimized}.so
%{dynload_dir}/_asyncio.%{SOABI_optimized}.so
%{dynload_dir}/_bisect.%{SOABI_optimized}.so
%{dynload_dir}/_bisect.%{SOABI_optimized}.so
...
@@ -1673,11 +1667,6 @@ fi
...
@@ -1673,11 +1667,6 @@ fi
# ...with debug builds of the built-in "extension" modules:
# ...with debug builds of the built-in "extension" modules:
%{dynload_dir}/_blake2.%{SOABI_debug}.so
%{dynload_dir}/_blake2.%{SOABI_debug}.so
%{dynload_dir}/_md5.%{SOABI_debug}.so
%{dynload_dir}/_sha1.%{SOABI_debug}.so
%{dynload_dir}/_sha256.%{SOABI_debug}.so
%{dynload_dir}/_sha3.%{SOABI_debug}.so
%{dynload_dir}/_sha512.%{SOABI_debug}.so
%{dynload_dir}/_asyncio.%{SOABI_debug}.so
%{dynload_dir}/_asyncio.%{SOABI_debug}.so
%{dynload_dir}/_bisect.%{SOABI_debug}.so
%{dynload_dir}/_bisect.%{SOABI_debug}.so
...
@@ -1803,6 +1792,13 @@ fi
...
@@ -1803,6 +1792,13 @@ fi
# ======================================================
# ======================================================
%changelog
%changelog
* Tue Jan 31 2023 Charalampos Stratakis <cstratak@redhat.com> - 3.11.1-4
- Disable the builtin hashlib hashes except blake2
* Mon Jan 30 2023 Charalampos Stratakis <cstratak@redhat.com> - 3.11.1-3
- Disable bootstrap
- Revert python3.11-rpm-macros requirement
* Mon Jan 30 2023 Charalampos Stratakis <cstratak@redhat.com> - 3.11.1-2
* Mon Jan 30 2023 Charalampos Stratakis <cstratak@redhat.com> - 3.11.1-2
- Fix macros requirements
- Fix macros requirements
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment