Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
T
thunderbird
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
thunderbird
Commits
956761ba
Commit
956761ba
authored
2 years ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import thunderbird-102.3.0-4.el9_0
parent
6ac7bf89
No related branches found
Branches containing commit
Tags
imports/r9-beta/thunderbird-91.13.0-1.el9
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/D158770.diff
+25
-0
25 additions, 0 deletions
SOURCES/D158770.diff
SPECS/thunderbird.spec
+54
-25
54 additions, 25 deletions
SPECS/thunderbird.spec
with
79 additions
and
25 deletions
SOURCES/D158770.diff
0 → 100644
+
25
−
0
View file @
956761ba
diff --git a/parser/expat/lib/xmlparse.c b/parser/expat/lib/xmlparse.c
--- a/parser/expat/lib/xmlparse.c
+++ b/parser/expat/lib/xmlparse.c
@@ -5652,12 +5652,18 @@
else
#endif /* XML_DTD */
{
processor = contentProcessor;
/* see externalEntityContentProcessor vs contentProcessor */
- return doContent(parser, parentParser ? 1 : 0, encoding, s, end,
- nextPtr, (XML_Bool)!ps_finalBuffer);
+ result = doContent(parser, parser->m_parentParser ? 1 : 0,
+ parser->m_encoding, s, end, nextPtr,
+ (XML_Bool)! parser->m_parsingStatus.finalBuffer);
+ if (result == XML_ERROR_NONE) {
+ if (! storeRawNames(parser))
+ return XML_ERROR_NO_MEMORY;
+ }
+ return result;
}
}
static enum XML_Error PTRCALL
errorProcessor(XML_Parser parser,
This diff is collapsed.
Click to expand it.
SPECS/thunderbird.spec
+
54
−
25
View file @
956761ba
...
@@ -160,7 +160,7 @@ end}
...
@@ -160,7 +160,7 @@ end}
Summary: Mozilla Thunderbird mail/newsgroup client
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
Name: thunderbird
Version: 102.3.0
Version: 102.3.0
Release:
3
%{?dist}%{?with_rlplus:.plus}
Release:
4
%{?dist}%{?with_rlplus:.plus}
URL: http://www.mozilla.org/projects/thunderbird/
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
License: MPLv1.1 or GPLv2+ or LGPLv2+
...
@@ -240,6 +240,7 @@ Patch421: mozilla-s390-context.patch
...
@@ -240,6 +240,7 @@ Patch421: mozilla-s390-context.patch
Patch422: mozilla-s390x-skia-gradient.patch
Patch422: mozilla-s390x-skia-gradient.patch
Patch423: one_swizzle_to_rule_them_all.patch
Patch423: one_swizzle_to_rule_them_all.patch
Patch424: svg-rendering.patch
Patch424: svg-rendering.patch
Patch425: D158770.diff
# PGO/LTO patches
# PGO/LTO patches
Patch600: pgo.patch
Patch600: pgo.patch
...
@@ -297,8 +298,8 @@ BuildRequires: devtoolset-%{dts_version}-libatomic-devel
...
@@ -297,8 +298,8 @@ BuildRequires: devtoolset-%{dts_version}-libatomic-devel
%if 0%{?rhel} == 9
%if 0%{?rhel} == 9
BuildRequires: gcc
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: gcc-c++
BuildRequires: cargo
>= 1.59
BuildRequires: cargo
BuildRequires: rust
>= 1.59
BuildRequires: rust
BuildRequires: clang clang-libs llvm
BuildRequires: clang clang-libs llvm
%endif
%endif
BuildRequires: %{nodejs_rb} >= 10.21
BuildRequires: %{nodejs_rb} >= 10.21
...
@@ -307,17 +308,17 @@ BuildRequires: scl-utils
...
@@ -307,17 +308,17 @@ BuildRequires: scl-utils
BuildRequires: findutils
BuildRequires: findutils
%endif
%endif
%if 0%{?rhel} == 8
%if 0%{?rhel} == 8
BuildRequires: cargo
>= 1.59
BuildRequires: cargo
BuildRequires: rust >=
1.59 >=
%{rust_version}
BuildRequires: rust >= %{rust_version}
BuildRequires: llvm >= %{llvm_version}
BuildRequires: llvm >= %{llvm_version}
BuildRequires: llvm-devel >= %{llvm_version}
BuildRequires: llvm-devel >= %{llvm_version}
BuildRequires: clang >= %{llvm_version}
BuildRequires: clang >= %{llvm_version}
BuildRequires: clang-devel >= %{llvm_version}
BuildRequires: clang-devel >= %{llvm_version}
BuildRequires: rust
>= 1.59
fmt >= %{rust_version}
BuildRequires: rustfmt >= %{rust_version}
%endif
%endif
%if 0%{?use_rustts}
%if 0%{?use_rustts}
BuildRequires: rust
>= 1.59
-toolset-%{rust_version}
BuildRequires: rust-toolset-%{rust_version}
%endif
%endif
%if 0%{?use_llvmts}
%if 0%{?use_llvmts}
...
@@ -452,52 +453,76 @@ BuildRequires: gcc-toolset-12-annobin-plugin-gcc
...
@@ -452,52 +453,76 @@ BuildRequires: gcc-toolset-12-annobin-plugin-gcc
%endif
%endif
%endif
%endif
# Bundled libraries
# Bundled libraries
Provides: bundled(angle)
Provides: bundled(angle)
Provides: bundled(audioipc-2)
Provides: bundled(brotli)
Provides: bundled(bzip2)
Provides: bundled(cairo)
Provides: bundled(cairo)
Provides: bundled(cfworker)
Provides: bundled(d3.js)
Provides: bundled(double-conversion)
Provides: bundled(expat)
Provides: bundled(fdlibm)
Provides: bundled(ffvpx)
Provides: bundled(freetype2)
Provides: bundled(graphite2)
Provides: bundled(graphite2)
Provides: bundled(harfbuzz)
Provides: bundled(harfbuzz)
Provides: bundled(ots)
Provides: bundled(highway)
Provides: bundled(sfntly)
Provides: bundled(intgemm)
Provides: bundled(skia)
Provides: bundled(json-c)
Provides: bundled(thebes)
Provides: bundled(WebRender)
Provides: bundled(audioipc-2)
Provides: bundled(ffvpx)
Provides: bundled(kissfft)
Provides: bundled(kissfft)
Provides: bundled(libaom)
Provides: bundled(libaom)
Provides: bundled(libcubeb)
Provides: bundled(libcubeb)
Provides: bundled(libdav1d)
Provides: bundled(libdav1d)
Provides: bundled(libgcrypt)
Provides: bundled(libgpg-error)
Provides: bundled(libjpeg)
Provides: bundled(libjpeg)
Provides: bundled(libjxl)
Provides: bundled(libjxl)
Provides: bundled(libmar)
Provides: bundled(libmkv)
Provides: bundled(libmkv)
Provides: bundled(libnestegg)
Provides: bundled(libnestegg)
Provides: bundled(libogg)
Provides: bundled(libogg)
Provides: bundled(libopus)
Provides: bundled(libopus)
Provides: bundled(libotr)
Provides: bundled(libpng)
Provides: bundled(libpng)
Provides: bundled(libprio)
Provides: bundled(libsoundtouch)
Provides: bundled(libsoundtouch)
Provides: bundled(libspeex_resampler)
Provides: bundled(libspeex_resampler)
Provides: bundled(libsrtp)
Provides: bundled(libtheora)
Provides: bundled(libtheora)
Provides: bundled(libtremor)
Provides: bundled(libtremor)
Provides: bundled(libvorbis)
Provides: bundled(libvorbis)
Provides: bundled(libvpx)
Provides: bundled(libvpx)
Provides: bundled(libwebp)
Provides: bundled(libwebp)
Provides: bundled(libwebrtc)
Provides: bundled(libyuv)
Provides: bundled(libyuv)
Provides: bundled(mp4parse-rust)
Provides: bundled(mp4parse-rust)
Provides: bundled(mp4parse-rust)
Provides: bundled(msgpack-c)
Provides: bundled(msgpack-c)
Provides: bundled(mtransport)
Provides: bundled(mtransport)
Provides: bundled(niwcompat)
Provides: bundled(openmax_dl)
Provides: bundled(openmax_dl)
Provides: bundled(double-conversion)
Provides: bundled(openmax_il)
Provides: bundled(brotli)
Provides: bundled(openmax_il)
Provides: bundled(fdlibm)
Provides: bundled(ots)
Provides: bundled(freetype2)
Provides: bundled(qcms)
Provides: bundled(libmar)
Provides: bundled(rlbox_sandboxing_api)
Provides: bundled(rnp)
Provides: bundled(sfntly)
Provides: bundled(sipcc)
Provides: bundled(skia)
Provides: bundled(sqlite3)
Provides: bundled(thebes)
Provides: bundled(wasm2c)
Provides: bundled(WebRender)
Provides: bundled(woff2)
Provides: bundled(woff2)
Provides: bundled(xz-embedded)
Provides: bundled(xz-embedded)
Provides: bundled(ycbcr)
Provides: bundled(zlib)
Provides: bundled(zlib)
Provides: bundled(expat)
Provides: bundled(msgpack-c)
Provides: bundled(libprio)
Provides: bundled(rlbox_sandboxing_api)
Provides: bundled(sqlite3)
%if 0%{?bundle_nss}
%if 0%{?bundle_nss}
Provides: bundled(nss) = 3.79.0
Provides: bundled(nss) = 3.79.0
...
@@ -599,6 +624,7 @@ echo "use_rustts %{?use_rustts}"
...
@@ -599,6 +624,7 @@ echo "use_rustts %{?use_rustts}"
%patch422 -p1 -b .mozilla-s390x-skia-gradient
%patch422 -p1 -b .mozilla-s390x-skia-gradient
%patch423 -p1 -b .one_swizzle_to_rule_them_all
%patch423 -p1 -b .one_swizzle_to_rule_them_all
%patch424 -p1 -b .svg-rendering
%patch424 -p1 -b .svg-rendering
%patch425 -p1 -b .D158770.diff
# PGO patches
# PGO patches
%if %{build_with_pgo}
%if %{build_with_pgo}
...
@@ -1222,10 +1248,13 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
...
@@ -1222,10 +1248,13 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#===============================================================================
#===============================================================================
%changelog
%changelog
* Tue
Sep 27
2022 Release Engineering <releng@rockylinux.org> - 102.3.0-
3
%{?with_rlplus:.plus}
* Tue
Oct 18
2022 Release Engineering <releng@rockylinux.org> - 102.3.0-
4
%{?with_rlplus:.plus}
- Add Rocky Linux debranding
- Add Rocky Linux debranding
- Add rlplus conditional
- Add rlplus conditional
* Wed Oct 12 2022 Jan Horak <jhorak@redhat.com> - 102.3.0-4
- Fix for expat CVE-2022-40674
* Fri Sep 16 2022 Jan Horak <jhorak@redhat.com> - 102.3.0-3
* Fri Sep 16 2022 Jan Horak <jhorak@redhat.com> - 102.3.0-3
- Update to 102.3.0 build1
- Update to 102.3.0 build1
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment