Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
A
anthy-unicode
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
src-rhel
rpms
anthy-unicode
Commits
10135d44
Commit
10135d44
authored
2 years ago
by
CentOS Sources
Browse files
Options
Downloads
Patches
Plain Diff
import anthy-unicode-1.0.0.20201109-9.el9
parent
24469f9c
Branches
c9
Tags
imports/c9/anthy-unicode-1.0.0.20201109-9.el9
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/anthy-unicode-HEAD.patch
+67
-0
67 additions, 0 deletions
SOURCES/anthy-unicode-HEAD.patch
SPECS/anthy-unicode.spec
+7
-1
7 additions, 1 deletion
SPECS/anthy-unicode.spec
with
74 additions
and
1 deletion
SOURCES/anthy-unicode-HEAD.patch
+
67
−
0
View file @
10135d44
...
...
@@ -4547,3 +4547,70 @@ index 0bb9917..13edcc2 100644
--
2.28.0
From 255323305b3621286cc4025ac59fa7d37fa1e7ce Mon Sep 17 00:00:00 2001
From: fujiwarat <takao.fujiwara1@gmail.com>
Date: Fri, 6 May 2022 20:33:47 +0900
Subject: [PATCH] src-main/context.c: Code reviews
---
src-main/context.c | 20 +++++++++++++++++++-
1 file changed, 19 insertions(+), 1 deletion(-)
diff --git a/src-main/context.c b/src-main/context.c
index 20dde71..d84858c 100644
--- a/src-main/context.c
+++ b/src-main/context.c
@@ -451,7 +451,7 @@
anthy_get_nth_segment(struct segment_list *sl, int n)
n < 0) {
return NULL;
}
- for (i = 0, se = sl->list_head.next; i < n; i++, se = se->next);
+ for (i = 0, se = sl->list_head.next; (i < n) && se; i++, se = se->next);
return se;
}
@@ -499,6 +499,17 @@
get_change_state(struct anthy_context *ac)
int i;
for (i = 0; i < ac->seg_list.nr_segments; i++) {
struct seg_ent *s = anthy_get_nth_segment(&ac->seg_list, i);
+ if (!ac->split_info.ce) {
+ anthy_log(0, "ac->split_info.ce is NULL %s:%d\n", __FILE__, __LINE__);
+ resize = 1;
+ break;
+ }
+ if (!s) {
+ anthy_log(0, "ac->seg_list %dth entry is NULL %s:%d\n",
+ i, __FILE__, __LINE__);
+ resize = 1;
+ continue;
+ }
if (ac->split_info.ce[s->from].initial_seg_len != s->len) {
resize = 1;
}
@@ -538,6 +549,11 @@
write_history(int fd,
struct seg_ent *s = anthy_get_nth_segment(&ac->seg_list, i);
char *c;
/**/
+ if (!s) {
+ anthy_log(0, "ac->seg_list %dth entry is NULL %s:%d\n",
+ i, __FILE__, __LINE__);
+ continue;
+ }
if (s->committed < 0) {
dprintf(fd, "?|");
continue ;
@@ -647,9 +663,11 @@
print_segment(struct seg_ent *e)
{
int i;
+ assert(e);
anthy_putxstr(&e->str);
printf("(");
for ( i = 0 ; i < e->nr_cands ; i++) {
+ assert(e->cands);
anthy_print_candidate(e->cands[i]);
printf(",");
}
--
2.35.1
This diff is collapsed.
Click to expand it.
SPECS/anthy-unicode.spec
+
7
−
1
View file @
10135d44
...
...
@@ -4,7 +4,7 @@
Name: anthy-unicode
Version: 1.0.0.20201109
Release:
7
%{?dist}
Release:
9
%{?dist}
# The entire source code is LGPLv2+ and dictionaries is GPLv2. the corpus data is under Public Domain.
License: LGPLv2+ and GPLv2 and Public Domain
URL: https://github.com/fujiwarat/anthy-unicode/wiki
...
...
@@ -161,6 +161,12 @@ cd ..
%changelog
* Fri May 06 2022 Takao Fujiwara <fujiwara@redhat.com> 1.0.0.20201109-9
- Fix covscan report. Related: rhbz#2068287
* Fri Apr 29 2022 Takao Fujiwara <fujiwara@redhat.com> 1.0.0.20201109-8
- Rebuild to add anthy-unicode-devel to CRB. Related: rhbz#2068287
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.0.0.20201109-7
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment