Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
D
delve
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
src-rhel
rpms
delve
Commits
62d31733
Commit
62d31733
authored
10 months ago
by
importbot
Browse files
Options
Downloads
Patches
Plain Diff
import delve-1.21.2-3.module+el8.10.0+1716+138d5b84
parent
8ec2ca1e
Branches
c9
Tags
imports/c9/delve-1.24.1-2.el9_5
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
.delve.checksum
+1
-1
1 addition, 1 deletion
.delve.checksum
SOURCES/modify-tests.patch
+16
-12
16 additions, 12 deletions
SOURCES/modify-tests.patch
SPECS/delve.spec
+7
-2
7 additions, 2 deletions
SPECS/delve.spec
with
24 additions
and
15 deletions
.delve.checksum
+
1
−
1
View file @
62d31733
3ca34be7657870004c9feeeeb98db2fa566c34d5b1cc3ee557ca229b2ea4e25a
14d23d2f2d17c7d11ab871729a51692221c7ac8dd4303b4f6298cb4fd7f44557
This diff is collapsed.
Click to expand it.
SOURCES/modify-
por
ts.patch
→
SOURCES/modify-
tes
ts.patch
+
16
−
12
View file @
62d31733
From
1ba9183936e11839811cf27472677d44ea4eb1a
2 Mon Sep 17 00:00:00 2001
From
0d8ba2001ceacd67a8861f470399f695cabc880
2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=C3=81lex=20S=C3=A1ez?= <asm@redhat.com>
Date: Wed, 24 Jan 2024 13:10:29 +0100
Subject: [PATCH] Modify tests
...
...
@@ -7,9 +7,9 @@ Some tests are not working properly with the build system so we need to
adapt them, like changing the ports they used.
---
_fixtures/notify-v2.go | 2 +-
pkg/proc/proc_test.go |
6
+++
+++
pkg/proc/proc_test.go |
3
+++
pkg/terminal/command_test.go | 2 +-
3 files changed,
8
insertions(+), 2 deletions(-)
3 files changed,
5
insertions(+), 2 deletions(-)
diff --git a/_fixtures/notify-v2.go b/_fixtures/notify-v2.go
index eb80526b..0f562c27 100644
...
...
@@ -23,26 +23,30 @@ index eb80526b..0f562c27 100644
+ log.Fatalln(http.ListenAndServe("127.0.0.1:8889", nil))
}
diff --git a/pkg/proc/proc_test.go b/pkg/proc/proc_test.go
index 714a4d1d..
ae9f0bd
9 100644
index 714a4d1d..
ea1d94a
9 100644
--- a/pkg/proc/proc_test.go
+++ b/pkg/proc/proc_test.go
@@ -2512,6 +2512,
9
@@
func TestStepConcurrentDirect(t *testing.T) {
@@ -2512,6 +2512,
7
@@
func TestStepConcurrentDirect(t *testing.T) {
}
func TestStepConcurrentPtr(t *testing.T) {
+ if runtime.GOARCH == "ppc64le" {
+ t.Skipf("Skipping due to CI issues")
+ }
+ t.Skipf("Skipping due to CI issues")
protest.AllowRecording(t)
withTestProcess("teststepconcurrent", t, func(p *proc.Target, grp *proc.TargetGroup, fixture protest.Fixture) {
setFileBreakpoint(p, t, fixture.Source, 24)
@@ -6080,6 +6083,9 @@
func TestEscapeCheckUnreadable(t *testing.T) {
@@ -5491,6 +5492,7 @@
func TestWatchpointCounts(t *testing.T) {
skipOn(t, "not implemented", "386")
skipOn(t, "see https://github.com/go-delve/delve/issues/2768", "windows")
skipOn(t, "not implemented", "ppc64le")
+ skipOn(t, "fails on CI", "arm64")
protest.AllowRecording(t)
withTestProcess("databpcountstest", t, func(p *proc.Target, grp *proc.TargetGroup, fixture protest.Fixture) {
@@ -6080,6 +6082,7 @@
func TestEscapeCheckUnreadable(t *testing.T) {
}
func TestStepShadowConcurrentBreakpoint(t *testing.T) {
+ if runtime.GOARCH == "ppc64le" {
+ t.Skipf("Skipping due to CI issues")
+ }
+ t.Skipf("Skipping due to CI issues")
// Checks that a StepBreakpoint can not shadow a concurrently hit user breakpoint
withTestProcess("stepshadow", t, func(p *proc.Target, grp *proc.TargetGroup, fixture protest.Fixture) {
break2 := setFunctionBreakpoint(p, t, "main.stacktraceme2")
...
...
This diff is collapsed.
Click to expand it.
SPECS/delve.spec
+
7
−
2
View file @
62d31733
...
...
@@ -4,7 +4,7 @@
Name: delve
Version: 1.21.2
Release:
2
%{?dist}
Release:
3
%{?dist}
Summary: A debugger for the Go programming language
License: MIT
...
...
@@ -19,7 +19,7 @@ BuildRequires: lsof
Provides: dlv = %{version}
Patch0001: modify-
por
ts.patch
Patch0001: modify-
tes
ts.patch
%description
...
...
@@ -71,6 +71,11 @@ done
%changelog
* Wed Jan 31 2024 Alejandro Sáez <asm@redhat.com> - 1.21.2-3
- Skip an additional test as it's breaking in the CI system.
- Modify the name of the patch.
- Resolves: RHEL-22820
* Fri Jan 26 2024 Alejandro Sáez <asm@redhat.com> - 1.21.2-2
- Fix: Remove architectures from exclude ExcludeArch
- Resolves: RHEL-22820
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment