Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
D
dotnet3.1
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
src-rhel
rpms
dotnet3.1
Commits
5eaed3f4
Commit
5eaed3f4
authored
4 years ago
by
CentOS Sources
Browse files
Options
Downloads
Patches
Plain Diff
import dotnet3.1-3.1.105-1.el8
parent
1c3935a0
No related branches found
Branches containing commit
Tags
imports/c9-beta/anthy-unicode-1.0.0.20201109-7.el9
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
.dotnet3.1.metadata
+1
-1
1 addition, 1 deletion
.dotnet3.1.metadata
.gitignore
+1
-1
1 addition, 1 deletion
.gitignore
SPECS/dotnet3.1.spec
+18
-8
18 additions, 8 deletions
SPECS/dotnet3.1.spec
with
20 additions
and
10 deletions
.dotnet3.1.metadata
+
1
−
1
View file @
5eaed3f4
f8edfbafa001861019a179c45d4aa73e6873ec13
SOURCES/dotnet-v3.1.10
4
-SDK.tar.gz
3818a42e01f00d5fe00548704a1878bc38fc74ef
SOURCES/dotnet-v3.1.10
5
-SDK.tar.gz
This diff is collapsed.
Click to expand it.
.gitignore
+
1
−
1
View file @
5eaed3f4
SOURCES/dotnet-v3.1.10
4
-SDK.tar.gz
SOURCES/dotnet-v3.1.10
5
-SDK.tar.gz
This diff is collapsed.
Click to expand it.
SPECS/dotnet3.1.spec
+
18
−
8
View file @
5eaed3f4
...
...
@@ -23,10 +23,10 @@
%endif
%global dotnet_ldflags %(echo %{__global_ldflags} | sed -re 's/-specs=[^ ]*//g')
%global host_version 3.1.
4
%global runtime_version 3.1.
4
%global host_version 3.1.
5
%global runtime_version 3.1.
5
%global aspnetcore_runtime_version %{runtime_version}
%global sdk_version 3.1.10
4
%global sdk_version 3.1.10
5
%global templates_version %(echo %{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
%global host_rpm_version %{host_version}
...
...
@@ -59,7 +59,7 @@
Name: dotnet3.1
Version: %{sdk_rpm_version}
Release:
3
%{?dist}
Release:
1
%{?dist}
Summary: .NET Core CLI tools and runtime
License: MIT and ASL 2.0 and BSD
URL: https://github.com/dotnet/
...
...
@@ -306,7 +306,7 @@ pushd src/dotnet-corefx.*
%patch103 -p1
popd
pushd src/coreclr.*
pushd src/
dotnet-
coreclr.*
%patch200 -p1
%patch201 -p1
popd
...
...
@@ -353,11 +353,11 @@ sed -e 's|[@]LIBDIR[@]|%{_libdir}|g' %{SOURCE101} > dotnet.sh
%install
install -dm 0755 %{buildroot}%{_libdir}/dotnet
ls
bin
/%{runtime_arch}/Release
tar xf
bin
/%{runtime_arch}/Release/dotnet-sdk-%{sdk_version}-%{runtime_id}.tar.gz -C %{buildroot}%{_libdir}/dotnet/
ls
artifacts
/%{runtime_arch}/Release
tar xf
artifacts
/%{runtime_arch}/Release/dotnet-sdk-%{sdk_version}-%{runtime_id}.tar.gz -C %{buildroot}%{_libdir}/dotnet/
# Install managed symbols
tar xf
bin
/%{runtime_arch}/Release/runtime/dotnet-runtime-symbols-%{runtime_version}-%{runtime_id}.tar.gz \
tar xf
artifacts
/%{runtime_arch}/Release/runtime/dotnet-runtime-symbols-%{runtime_version}-%{runtime_id}.tar.gz \
-C %{buildroot}/%{_libdir}/dotnet/shared/Microsoft.NETCore.App/%{runtime_version}/
# Fix executable permissions on files
...
...
@@ -380,6 +380,12 @@ chmod 0644 %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Ref/3.1.0/
chmod 0644 %{buildroot}/%{_libdir}/dotnet/packs/NETStandard.Library.Ref/2.1.0/data/PackageOverrides.txt
chmod 0644 %{buildroot}/%{_libdir}/dotnet/packs/NETStandard.Library.Ref/2.1.0/data/FrameworkList.xml
# See https://github.com/dotnet/source-build-reference-packages/pull/121
rm -r %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Ref/3.1.0/obj
rm -r %{buildroot}/%{_libdir}/dotnet/packs/Microsoft.NETCore.App.Ref/3.1.0/microsoft.netcore.app.ref
rm -r %{buildroot}/%{_libdir}/dotnet/packs/NETStandard.Library.Ref/2.1.0/netstandard.library.ref
rm -r %{buildroot}/%{_libdir}/dotnet/packs/NETStandard.Library.Ref/2.1.0/obj
install -dm 0755 %{buildroot}%{_sysconfdir}/profile.d/
install dotnet.sh %{buildroot}%{_sysconfdir}/profile.d/
...
...
@@ -454,6 +460,10 @@ echo "Testing build results for debug symbols..."
%dir %{_libdir}/dotnet/packs
%changelog
* Tue Jun 09 2020 Omair Majid <omajid@redhat.com> - 3.1.105-1
- Update to .NET Core Runtime 3.1.5 and SDK 3.1.105
- Resolves: RHBZ#1844491
* Mon Jun 01 2020 Omair Majid <omajid@redhat.com> - 3.1.104-3
- Update to .NET Core Runtime 3.1.4 and SDK 3.1.104
- Resolves: RHBZ#1832685
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment