Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
gcc-toolset-14-binutils
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
src-rhel
rpms
gcc-toolset-14-binutils
Commits
a1423674
Commit
a1423674
authored
10 months ago
by
importbot
Browse files
Options
Downloads
Patches
Plain Diff
import gcc-toolset-14-binutils-2.41-2.el8
parent
cf784bf1
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/binutils-s390-testsuite-fixes.patch
+52
-0
52 additions, 0 deletions
SOURCES/binutils-s390-testsuite-fixes.patch
SPECS/binutils.spec
+5
-1
5 additions, 1 deletion
SPECS/binutils.spec
with
57 additions
and
1 deletion
SOURCES/binutils-s390-testsuite-fixes.patch
0 → 100644
+
52
−
0
View file @
a1423674
diff -rup binutils.orig/binutils/testsuite/binutils-all/compress.exp binutils-2.41/binutils/testsuite/binutils-all/compress.exp
--- binutils.orig/binutils/testsuite/binutils-all/compress.exp 2024-04-30 15:04:40.935567791 +0100
+++ binutils-2.41/binutils/testsuite/binutils-all/compress.exp 2024-04-30 15:10:31.703681471 +0100
@@ -139,6 +139,10 @@
if ![string match "" $got] then {
}
}
+if { [istarget "s390x-*-*"] } {
+ return
+}
+
# Xfail this test if there are no compressed sections.
setup_xfail "$compression_used$target_triplet"
set testname "objcopy compress debug sections in archive with zlib-gnu"
diff -rup binutils.orig/ld/testsuite/ld-elf/indirect.exp binutils-2.41/ld/testsuite/ld-elf/indirect.exp
--- binutils.orig/ld/testsuite/ld-elf/indirect.exp 2024-04-30 15:04:42.275572059 +0100
+++ binutils-2.41/ld/testsuite/ld-elf/indirect.exp 2024-04-30 15:15:19.760991281 +0100
@@ -135,6 +135,10 @@
set testname "Indirect symbol 2"
set cmd "$ld -shared -o tmpdir/indirect2.so tmpdir/indirect2.o"
check_link_message "$cmd" [list $string2] "$testname"
+if { [istarget "s390x-*-*"] } {
+ return
+}
+
set run_tests [list \
[list "Run with libindirect3c.so 1" \
"-Wl,--no-as-needed tmpdir/indirect3a.o tmpdir/indirect3b.o tmpdir/libindirect3c.so" "" \
diff -rup binutils.orig/ld/testsuite/ld-shared/shared.exp binutils-2.41/ld/testsuite/ld-shared/shared.exp
--- binutils.orig/ld/testsuite/ld-shared/shared.exp 2024-04-30 15:04:42.436572571 +0100
+++ binutils-2.41/ld/testsuite/ld-shared/shared.exp 2024-04-30 15:16:21.522057698 +0100
@@ -267,7 +267,7 @@
if ![ld_compile "$CC_FOR_TARGET $SHCFLAG
setup_xfail "x86_64-*-linux*"
}
setup_xfail "x86_64-*-linux-gnux32"
- setup_xfail "s390x-*-linux*"
+ # setup_xfail "s390x-*-linux*"
if [ string match $shared_needs_pic "yes" ] {
setup_xfail "arm*-*-linux*"
}
diff -rup binutils.orig/ld/testsuite/ld-vsb/vsb.exp binutils-2.41/ld/testsuite/ld-vsb/vsb.exp
--- binutils.orig/ld/testsuite/ld-vsb/vsb.exp 2024-04-30 15:04:42.454572629 +0100
+++ binutils-2.41/ld/testsuite/ld-vsb/vsb.exp 2024-04-30 15:17:37.850139781 +0100
@@ -366,7 +366,7 @@
proc visibility_run {visibility} {
|| [ string match $visibility "protected_weak" ]
|| [ string match $visibility "normal" ] } {
setup_xfail "powerpc-*-linux*"
- setup_xfail "s390x-*-linux*"
+ # setup_xfail "s390x-*-linux*"
if { [istarget sparc*-*-linux*] && [is_elf64 $tmpdir/mainnp.o] } {
setup_xfail "sparc*-*-linux*"
}
This diff is collapsed.
Click to expand it.
SPECS/binutils.spec
+
5
−
1
View file @
a1423674
...
...
@@ -9,7 +9,7 @@ BuildRequires: scl-utils-build
Summary: A GNU collection of binary utilities
Name: %{?scl_prefix}binutils
Version: 2.41
Release:
1
%{?dist}
Release:
2
%{?dist}
License: GPL-3.0-or-later AND (GPL-3.0-or-later WITH Bison-exception-2.2) AND (LGPL-2.0-or-later WITH GCC-exception-2.0) AND BSD-3-Clause AND GFDL-1.3-or-later AND GPL-2.0-or-later AND LGPL-2.1-or-later AND LGPL-2.0-or-later
URL: https://sourceware.org/binutils
...
...
@@ -338,6 +338,7 @@ Patch39: binutils-multilib.am.patch
Patch40: binutils-Intel-APX-CODE_6_GOTTPOFF.patch
Patch41: binutils-extra-testsuite-fixes.patch
Patch42: binutils-s390-testsuite-fixes.patch
# Purpose: Suppress the x86 linker's p_align-1 tests due to kernel bug on CentOS-10
# Lifetime: TEMPORARY
...
...
@@ -1448,5 +1449,8 @@ exit 0
#----------------------------------------------------------------------------
%changelog
* Tue Apr 30 2024 Nick Clifton <nickc@redhat.com> - 2.41-2
- Fix s390x testsuite errors to allow building for RHEL-8. (RHEL-30410)
* Mon Apr 29 2024 Nick Clifton <nickc@redhat.com> - 2.41-1
- Initial import of upstream 2.41 release with patches from Fedora 40. (RHEL-30410)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment