Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
golang
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
src-rhel
rpms
golang
Commits
8e714429
Commit
8e714429
authored
8 months ago
by
importbot
Browse files
Options
Downloads
Patches
Plain Diff
import golang-1.21.11-1.module+el8.10.0+21986+2112108a
parent
2734e53d
No related branches found
Branches containing commit
Tags
imports/c8-stream-rhel8/golang-1.21.11-1.module+el8.10.0+21986+2112108a
Tags containing commit
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
.golang.checksum
+1
-1
1 addition, 1 deletion
.golang.checksum
.golang.metadata
+2
-2
2 additions, 2 deletions
.golang.metadata
SOURCES/skip-test-overlong-message.patch
+0
-15
0 additions, 15 deletions
SOURCES/skip-test-overlong-message.patch
SPECS/golang.spec
+15
-5
15 additions, 5 deletions
SPECS/golang.spec
with
18 additions
and
23 deletions
.golang.checksum
+
1
−
1
View file @
8e714429
f2bf7c9f0109048c7bfca987b1297c8fa4e40cd45d87552f626126a8caa82046
2ad56252c6b44ca0cc924a8fb53c4c4c0da21fa77d4b0fa35f3fdf562d18ad10
This diff is collapsed.
Click to expand it.
.golang.metadata
+
2
−
2
View file @
8e714429
2272a9777a25d35e59832bf918e798c429cbc4e11de4bc7a09eee899a3710a9
9 SOURCES/go1.21.
9
-1-openssl-fips.tar.gz
9724c45609f4468bfd9277a58021d59a938a4275b6c0d7c20555e19bf1941c63
SOURCES/go1.21.
9
.tar.gz
d8f5705cb14bfa075a12312a5dc12d0c4b32287432f11c0b656872fe15a1751
9 SOURCES/go1.21.
11
-1-openssl-fips.tar.gz
7df313860016b625cccaf8e94b91ca746b85b19df4d828ad36e7eff5d097e05a
SOURCES/go1.21.
11
.tar.gz
This diff is collapsed.
Click to expand it.
SOURCES/skip-test-overlong-message.patch
deleted
100644 → 0
+
0
−
15
View file @
2734e53d
diff --git a/src/crypto/rsa/pkcs1v15_test.go b/src/crypto/rsa/pkcs1v15_test.go
index 0853178e3a..16eb37734b 100644
--- a/src/crypto/rsa/pkcs1v15_test.go
+++ b/src/crypto/rsa/pkcs1v15_test.go
@@ -247,6 +247,10 @@
func TestVerifyPKCS1v15(t *testing.T) {
}
func TestOverlongMessagePKCS1v15(t *testing.T) {
+ // OpenSSL now returns a random string instead of an error
+ if boring.Enabled() {
+ t.Skip("Not relevant in boring mode")
+ }
ciphertext := decodeBase64("fjOVdirUzFoLlukv80dBllMLjXythIf22feqPrNo0YoIjzyzyoMFiLjAc/Y4krkeZ11XFThIrEvw\nkRiZcCq5ng==")
_, err := DecryptPKCS1v15(nil, rsaPrivateKey, ciphertext)
if err == nil {
This diff is collapsed.
Click to expand it.
SPECS/golang.spec
+
15
−
5
View file @
8e714429
...
...
@@ -92,7 +92,7 @@
%endif
%global go_api 1.21
%global version 1.21.
9
%global version 1.21.
11
%global pkg_release 1
Name: golang
...
...
@@ -145,7 +145,6 @@ Patch1939923: skip_test_rhbz1939923.patch
Patch2: disable_static_tests_part1.patch
Patch3: disable_static_tests_part2.patch
Patch4: skip-test-overlong-message.patch
Patch5: modify_go.env.patch
# Having documentation separate was broken
...
...
@@ -243,9 +242,12 @@ Requires: %{name} = %{version}-%{release}
pushd ..
tar -xf %{SOURCE1}
popd
patch -p1 < ../go-go%{version}-%{pkg_release}-openssl-fips/patches/000-initial-setup.patch
patch -p1 < ../go-go%{version}-%{pkg_release}-openssl-fips/patches/001-initial-openssl-for-fips.patch
patch -p1 < ../go-go%{version}-%{pkg_release}-openssl-fips/patches/002-strict-fips-runtime-detection.patch
patch_dir="../go-go%{version}-%{pkg_release}-openssl-fips/patches"
# Add --no-backup-if-mismatch option to avoid creating .orig temp files
for p in "$patch_dir"/*.patch; do
echo "Applying $p"
patch -p1 --no-backup-if-mismatch < $p
done
# Configure crypto tests
pushd ../go-go%{version}-%{pkg_release}-openssl-fips
...
...
@@ -518,6 +520,14 @@ cd ..
%endif
%changelog
* Wed Jun 12 2024 Archana Ravindar <aravinda@redhat.com> - 1.21.11-1
- Update to Go1.21.11 to address CVE-2024-24789 and CVE-2024-24790
- Resolves: RHEL-40274
* Thu May 23 2024 David Benoit <dbenoit@redhat.com> - 1.21.10
- Update to Go 1.21.10
- Resolves: RHEL-36993
* Fri Apr 12 2024 David Benoit <dbenoit@redhat.com> - 1.21.9-1
- Fix CVE-2023-45288
- Resolves: RHEL-31915
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment