Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
G
golang
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
src-rhel
rpms
golang
Commits
bfada355
Commit
bfada355
authored
4 months ago
by
importbot
Browse files
Options
Downloads
Patches
Plain Diff
import golang-1.22.7-2.el9_5
parent
e479a6f9
No related branches found
Branches containing commit
Tags
imports/c10s/golang-1.23.1-2.el10
Tags containing commit
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
.golang.checksum
+1
-1
1 addition, 1 deletion
.golang.checksum
.golang.metadata
+2
-2
2 additions, 2 deletions
.golang.metadata
SOURCES/fix-standard-crypto-panic.patch
+0
-44
0 additions, 44 deletions
SOURCES/fix-standard-crypto-panic.patch
SPECS/golang.spec
+10
-2
10 additions, 2 deletions
SPECS/golang.spec
with
13 additions
and
49 deletions
.golang.checksum
+
1
−
1
View file @
bfada355
0
537a003d35515e42278f07e5b0dacbb3ae1f520af0c5851332563bbc9c2dbf8
0
7a2690330f97c01c06bb67780fb249ae7b67fb5228fdfb198d5b5f42863def2
This diff is collapsed.
Click to expand it.
.golang.metadata
+
2
−
2
View file @
bfada355
e054e99a9c9240720616e927cb52363abbc8b4f1ef0286bad3df79ec8fdf892f SOURCES/compiler-rt-18.1.8.src.tar.xz
c0e4070e614b211c66d7d55b827b0595b3333e225a1fae619dc74cbef138edfa
SOURCES/go1.22.
5
-1-openssl-fips.tar.gz
7943adac83b278f5171fbf94cd29c062a726f0adc10cb3891e1804f542444a51
SOURCES/go1.22.
5
.tar.gz
a104e23de7dd7c657fed13b2e2f485e41780f76c21e2bcfe8e8105915a70e552
SOURCES/go1.22.
7
-1-openssl-fips.tar.gz
0b9b3cabe42b74530df7f2d792c07e92ac40176ca618aef5a800b2ef10aa3804
SOURCES/go1.22.
7
.tar.gz
This diff is collapsed.
Click to expand it.
SOURCES/fix-standard-crypto-panic.patch
deleted
100644 → 0
+
0
−
44
View file @
e479a6f9
diff --git a/src/crypto/internal/backend/openssl.go b/src/crypto/internal/backend/openssl.go
index 3d3a9a36ee..8dc2d46b52 100644
--- a/src/crypto/internal/backend/openssl.go
+++ b/src/crypto/internal/backend/openssl.go
@@ -25,6 +25,22 @@
var enabled bool
var knownVersions = [...]string{"3", "1.1", "11", "111", "1.0.2", "1.0.0", "10"}
func init() {
+ // 0: FIPS opt-out: abort the process if it is enabled and can't be disabled.
+ // 1: FIPS required: abort the process if it is not enabled and can't be enabled.
+ // other values: do not override OpenSSL configured FIPS mode.
+ var fips string
+ if v, ok := syscall.Getenv("GOLANG_FIPS"); ok {
+ fips = v
+ } else if hostFIPSModeEnabled() {
+ // System configuration can only force FIPS mode.
+ fips = "1"
+ }
+
+ // Use Go standard crypto, do not load openssl
+ if (fips != "1") {
+ return
+ }
+
version, _ := syscall.Getenv("GO_OPENSSL_VERSION_OVERRIDE")
if version == "" {
var fallbackVersion string
@@ -49,16 +65,6 @@
func init() {
if err := openssl.Init(version); err != nil {
panic("opensslcrypto: can't initialize OpenSSL " + version + ": " + err.Error())
}
- // 0: FIPS opt-out: abort the process if it is enabled and can't be disabled.
- // 1: FIPS required: abort the process if it is not enabled and can't be enabled.
- // other values: do not override OpenSSL configured FIPS mode.
- var fips string
- if v, ok := syscall.Getenv("GOLANG_FIPS"); ok {
- fips = v
- } else if hostFIPSModeEnabled() {
- // System configuration can only force FIPS mode.
- fips = "1"
- }
switch fips {
case "0":
if openssl.FIPS() {
This diff is collapsed.
Click to expand it.
SPECS/golang.spec
+
10
−
2
View file @
bfada355
...
...
@@ -93,7 +93,7 @@
%endif
%global go_api 1.22
%global go_version 1.22.
5
%global go_version 1.22.
7
%global version %{go_version}
%global pkg_release 1
...
...
@@ -154,7 +154,6 @@ Patch1939923: skip_test_rhbz1939923.patch
Patch4: modify_go.env.patch
Patch6: skip_TestCrashDumpsAllThreads.patch
Patch7: fix-standard-crypto-panic.patch
# Having documentation separate was broken
Obsoletes: %{name}-docs < 1.1-4
...
...
@@ -584,6 +583,15 @@ cd ..
%endif
%changelog
* Thu Oct 03 2024 Archana <aravinda@redhat.com> - 1.22.7-2
- Rebuilt to use right build target
- Related: RHEL-57867
* Tue Sep 24 2024 David Benoit <dbenoit@redhat.com> - 1.22.7-1
- Update to Go 1.22.7
- Remove fix-standard-crypto-panic.patch (upstreamed)
- Resolves: RHEL-57867
* Wed Aug 14 2024 David Benoit <dbenoit@redhat.com> - 1.22.5-2
- Rebuild race detector archives from LLVM sources
- Add golang-race subpackage
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment