Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
mesa
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
src-rhel
rpms
mesa
Commits
23f6a09b
Commit
23f6a09b
authored
8 months ago
by
importbot
Browse files
Options
Downloads
Patches
Plain Diff
import mesa-24.1.0-2.el10
parent
8073c6de
Branches
c9-beta
Tags
imports/c9-beta/mesa-24.1.2-3.el9
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/fix-s390x-modes.patch
+34
-0
34 additions, 0 deletions
SOURCES/fix-s390x-modes.patch
SPECS/mesa.spec
+6
-2
6 additions, 2 deletions
SPECS/mesa.spec
with
40 additions
and
2 deletions
SOURCES/fix-s390x-modes.patch
0 → 100644
+
34
−
0
View file @
23f6a09b
diff -up mesa-24.1.0/src/gallium/frontends/dri/dri_screen.c.s390x mesa-24.1.0/src/gallium/frontends/dri/dri_screen.c
--- mesa-24.1.0/src/gallium/frontends/dri/dri_screen.c.s390x 2024-06-20 14:57:54.495763904 -0400
+++ mesa-24.1.0/src/gallium/frontends/dri/dri_screen.c 2024-06-20 15:01:33.555766438 -0400
@@ -386,17 +386,21 @@
dri_fill_in_modes(struct dri_screen *scr
uint8_t msaa_modes[MSAA_VISUAL_MAX_SAMPLES];
/* Expose only BGRA ordering if the loader doesn't support RGBA ordering. */
- if (!allow_rgba_ordering &&
- util_format_get_component_shift(pipe_formats[f],
- UTIL_FORMAT_COLORSPACE_RGB, 0)
+ if (!allow_rgba_ordering) {
+ unsigned sh_ax = util_format_get_component_shift(pipe_formats[f], UTIL_FORMAT_COLORSPACE_RGB, 3);
+ unsigned sh_b = util_format_get_component_shift(pipe_formats[f], UTIL_FORMAT_COLORSPACE_RGB, 2);
#if UTIL_ARCH_BIG_ENDIAN
- >
+ unsigned sz_b = util_format_get_component_bits(pipe_formats[f], UTIL_FORMAT_COLORSPACE_RGB, 2);
+
+ if (sz_b + sh_b == sh_ax)
+ continue;
#else
- <
+ unsigned sz_ax = util_format_get_component_bits(pipe_formats[f], UTIL_FORMAT_COLORSPACE_RGB, 3);
+
+ if (sz_ax + sh_ax == sh_b)
+ continue;
#endif
- util_format_get_component_shift(pipe_formats[f],
- UTIL_FORMAT_COLORSPACE_RGB, 2))
- continue;
+ }
if (!allow_rgb10 &&
util_format_get_component_bits(pipe_formats[f],
This diff is collapsed.
Click to expand it.
SPECS/mesa.spec
+
6
−
2
View file @
23f6a09b
...
...
@@ -2,7 +2,7 @@
## (rpmautospec version 0.6.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number =
1
;
release_number =
2
;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
...
...
@@ -107,7 +107,8 @@ BuildRequires: spirv-headers-devel
BuildRequires: spirv-tools-devel
BuildRequires: zlib-devel
Patch10: gnome-shell-glthread-disable.patch
Patch: gnome-shell-glthread-disable.patch
Patch: fix-s390x-modes.patch
# Build our own version but keep the dependency for the RPM macros
BuildRequires: meson
...
...
@@ -820,6 +821,9 @@ popd
%changelog
## START: Generated by rpmautospec
* Fri Jun 21 2024 Ray Strode <rstrode@redhat.com> - 24.1.0-2
- Fix egl on s390x
* Wed Jun 05 2024 José Expósito <jexposit@redhat.com> - 24.1.0-1
- Update to 24.1.0
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment