Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
Z
zsh
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
src-rhel
rpms
zsh
Commits
4afb9179
Commit
4afb9179
authored
2 years ago
by
CentOS Sources
Browse files
Options
Downloads
Patches
Plain Diff
import zsh-5.5.1-10.el8
parent
7262f04e
No related branches found
Branches containing commit
Tags
imports/r10s/libpciaccess-0.16-15.el10
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/0006-zsh-5.5.1-fix-wait.patch
+28
-0
28 additions, 0 deletions
SOURCES/0006-zsh-5.5.1-fix-wait.patch
SPECS/zsh.spec
+7
-1
7 additions, 1 deletion
SPECS/zsh.spec
with
35 additions
and
1 deletion
SOURCES/0006-zsh-5.5.1-fix-wait.patch
0 → 100644
+
28
−
0
View file @
4afb9179
From 6af0b07cc7950159129156cb85ef3f72fdd828cc Mon Sep 17 00:00:00 2001
From: Peter Stephenson <p.w.stephenson@ntlworld.com>
Date: Sat, 3 Aug 2019 19:48:18 +0100
Subject: [PATCH] 44635: Don't apply STAT_NOPRINT to backgrounded jobs
Upstream-commit: e0d063a2ade821baf570eb300d4be93692b494f8
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
---
Src/exec.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Src/exec.c b/Src/exec.c
index 8045db2..da089d6 100644
--- a/Src/exec.c
+++ b/Src/exec.c
@@ -1666,7 +1666,8 @@
execpline(Estate state, wordcode slcode, int how, int last1)
lastwj = thisjob = newjob;
- if (list_pipe || (pline_level && !(how & Z_TIMED)))
+ if (list_pipe || (pline_level && !(how & Z_TIMED) &&
+ !(jn->stat & STAT_NOSTTY)))
jn->stat |= STAT_NOPRINT;
if (nowait) {
--
2.34.1
This diff is collapsed.
Click to expand it.
SPECS/zsh.spec
+
7
−
1
View file @
4afb9179
Summary: Powerful interactive shell
Name: zsh
Version: 5.5.1
Release:
9
%{?dist}
Release:
10
%{?dist}
License: MIT
URL: http://zsh.sourceforge.net/
Source0: https://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
...
...
@@ -27,6 +27,9 @@ Patch4: 0004-zsh-5.5.1-CVE-2019-20044.patch
# do not perform PROMPT_SUBST evaluation on %F/%K arguments (CVE-2021-45444)
Patch5: 0005-zsh-5.5.1-CVE-2021-45444.patch
# make zsh wait built-in wait properly for all active child processes (#2070342)
Patch6: 0006-zsh-5.5.1-fix-wait.patch
BuildRequires: autoconf
BuildRequires: coreutils
BuildRequires: gawk
...
...
@@ -182,6 +185,9 @@ fi
%doc Doc/*.html
%changelog
* Fri Apr 01 2022 Kamil Dudka <kdudka@redhat.com> - 5.5.1-10
- make zsh wait built-in wait properly for all active child processes (#2070342)
* Tue Feb 22 2022 Kamil Dudka <kdudka@redhat.com> - 5.5.1-9
- do not perform PROMPT_SUBST evaluation on %F/%K arguments (CVE-2021-45444)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment