Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
Z
zlib
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Iterations
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
staging
rpms
zlib
Commits
b90ffffa
Commit
b90ffffa
authored
2 years ago
by
Rocky Automation
Browse files
Options
Downloads
Patches
Plain Diff
import zlib-1.2.11-32.el9_0
parent
d13d2cdd
No related branches found
Branches containing commit
Tags
imports/r8-beta/zlib-1.2.11-17.el8
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
SOURCES/zlib-1.2.11-cve-2022-37434.patch
+35
-0
35 additions, 0 deletions
SOURCES/zlib-1.2.11-cve-2022-37434.patch
SOURCES/zlib-1.2.11-cve-2022-37434_2.patch
+32
-0
32 additions, 0 deletions
SOURCES/zlib-1.2.11-cve-2022-37434_2.patch
SPECS/zlib.spec
+12
-1
12 additions, 1 deletion
SPECS/zlib.spec
with
79 additions
and
1 deletion
SOURCES/zlib-1.2.11-cve-2022-37434.patch
0 → 100644
+
35
−
0
View file @
b90ffffa
From eff308af425b67093bab25f80f1ae950166bece1 Mon Sep 17 00:00:00 2001
From: Mark Adler <fork@madler.net>
Date: Sat, 30 Jul 2022 15:51:11 -0700
Subject: [PATCH] Fix a bug when getting a gzip header extra field with
inflate().
If the extra field was larger than the space the user provided with
inflateGetHeader(), and if multiple calls of inflate() delivered
the extra header data, then there could be a buffer overflow of the
provided space. This commit assures that provided space is not
exceeded.
---
inflate.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/inflate.c b/inflate.c
index 7be8c63..7a72897 100644
--- a/inflate.c
+++ b/inflate.c
@@ -763,9 +763,10 @@
int flush;
copy = state->length;
if (copy > have) copy = have;
if (copy) {
+ len = state->head->extra_len - state->length;
if (state->head != Z_NULL &&
- state->head->extra != Z_NULL) {
- len = state->head->extra_len - state->length;
+ state->head->extra != Z_NULL &&
+ len < state->head->extra_max) {
zmemcpy(state->head->extra + len, next,
len + copy > state->head->extra_max ?
state->head->extra_max - len : copy);
--
2.35.3
This diff is collapsed.
Click to expand it.
SOURCES/zlib-1.2.11-cve-2022-37434_2.patch
0 → 100644
+
32
−
0
View file @
b90ffffa
From 1eb7682f845ac9e9bf9ae35bbfb3bad5dacbd91d Mon Sep 17 00:00:00 2001
From: Mark Adler <fork@madler.net>
Date: Mon, 8 Aug 2022 10:50:09 -0700
Subject: [PATCH] Fix extra field processing bug that dereferences NULL
state->head.
The recent commit to fix a gzip header extra field processing bug
introduced the new bug fixed here.
---
inflate.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/inflate.c b/inflate.c
index 7a72897..2a3c4fe 100644
--- a/inflate.c
+++ b/inflate.c
@@ -763,10 +763,10 @@
int flush;
copy = state->length;
if (copy > have) copy = have;
if (copy) {
- len = state->head->extra_len - state->length;
if (state->head != Z_NULL &&
state->head->extra != Z_NULL &&
- len < state->head->extra_max) {
+ (len = state->head->extra_len - state->length) <
+ state->head->extra_max) {
zmemcpy(state->head->extra + len, next,
len + copy > state->head->extra_max ?
state->head->extra_max - len : copy);
--
2.35.3
This diff is collapsed.
Click to expand it.
SPECS/zlib.spec
+
12
−
1
View file @
b90ffffa
...
...
@@ -2,7 +2,7 @@
Name: zlib
Version: 1.2.11
Release: 3
1
%{?dist}
.1
Release: 3
2
%{?dist}
Summary: Compression and decompression library
# /contrib/dotzlib/ have Boost license
License: zlib and Boost
...
...
@@ -37,6 +37,11 @@ Patch15: zlib-1.2.11-covscan-issues-rhel9.patch
Patch16: zlib-1.2.11-s390x-vectorize-crc32.patch
Patch18: zlib-1.2.11-CVE-2018-25032.patch
# Fix for CVE-2022-37434
Patch19: zlib-1.2.11-cve-2022-37434.patch
Patch20: zlib-1.2.11-cve-2022-37434_2.patch
BuildRequires: make
BuildRequires: automake, autoconf, libtool
...
...
@@ -105,6 +110,8 @@ developing applications which use minizip.
%patch15 -p1
%patch16 -p1
%patch18 -p1
%patch19 -p1
%patch20 -p1
iconv -f iso-8859-2 -t utf-8 < ChangeLog > ChangeLog.tmp
...
...
@@ -182,6 +189,10 @@ find $RPM_BUILD_ROOT -name '*.la' -delete
%changelog
* Wed Aug 10 2022 Matej Mužila <mmuzila@redhat.com> - 1.2.11-32
- Fix heap-based buffer over-read or buffer overflow in inflate in inflate.c
- Resolves: CVE-2022-37434
* Mon Apr 25 2022 Matej Mužila <mmuzila@redhat.com> - 1.2.11-31.1
- Fix CVE-2018-25032
Resolves: CVE-2018-25032
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment